IPv6 mulicast and PIM

Unanswered Question
Mar 30th, 2012

Hi

Is there a good study material with sample configuration to understand ipv6 Multicast;MLD and PIM...

I have a topology R1--R2--R3 and a requirement  to "Enable the PIM on the routers R1, R2, R3  globally and at the interface level". Even after some googling Im still not able to grasp the basics..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
navarannan Fri, 03/30/2012 - 05:09

Just to add on here is my topology

R1(fa0/0)------(fa0/0)R2(fa0/1)-----(fa0/0)R3

All the routers are configured fro RIP and routes are advertised.

And here is the requirement

1.Enable the PIM on the routers R1, R2, R3  globally and at the interface level.        

2. Enable the MLDv2 on routers R2,R3, and the hosts join the multicast groups.                                                            3. Send few multicast packets from the source connected to the R1 to the multicast groups.                              

4. Verify that the multicast messages are exchanged                      

5. Verify that the multicast routes are learnt on the routers R1, R2, R3  

6. Send multicast packets or traffic  from the source connected to the R1 to the multicast groups.                              

7. Verify that the mrouters are learnt on the routers R1, R2, R3                      

8. Verify that the multicast traffic is received by the hosts(joined the group)    

Nandan Mathure Fri, 04/13/2012 - 18:47

Hi ,

I know its been almost 2 weeks for your post but just in case if you still need this.

Following is the configuration that you need to do on your routers to get things working as per your requirement.

Only difference is I have put eigrp instead of rip.

R1#

!

ipv6 unicast-routing

ipv6 multicast-routing

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ipv6 address 2001:1111:1111::1/128

ipv6 eigrp 111

!

interface FastEthernet0/0

ipv6 address 2001:1212:1212::1/64

ipv6 eigrp 111

!

ipv6 router eigrp 111

no shutdown

!

R2#

!

ipv6 unicast-routing

ipv6 multicast-routing

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

ipv6 address 2001:2222:2222::2/128

ipv6 eigrp 111

ipv6 mld join-group FF0D::2

!

interface FastEthernet0/0

ipv6 address 2001:1212:1212::2/64

ipv6 eigrp 111

!

interface FastEthernet0/1

ipv6 address 2001:2323:2323::2/64

ipv6 eigrp 111

!

ipv6 router eigrp 111

no shutdown

!

ipv6 pim bsr candidate bsr 2001:2222:2222::2

ipv6 pim bsr candidate rp 2001:2222:2222::2 interval 10

!

R3#

!

ipv6 unicast-routing

ipv6 multicast-routing

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

ipv6 address 2001:3333:3333::3/128

ipv6 eigrp 111

ipv6 mld join-group FF0D::3

!

interface FastEthernet0/0

ipv6 address 2001:2323:2323::3/64

ipv6 eigrp 111

!

!

ipv6 router eigrp 111

no shutdown

!

---NOTES & VERIFICATION COMMANDS--

1] Once ipv6 multicast-routing is enabled it turns ipv6 pim (default and only mode is sparse) and MLD ver 2 on all the ipv6 enabled interfaces. 

show ipv6 pim interface , show ipv6 pim neighbor, show ipv6 mld interface

2] show ipv6 pim mld groups (on R2 and R3)

3] Remember that since ipv6 pim has sparce mode only RP is necessary. I have used PIM BSR. You can use static rp as well.

show ipv6 pim bsr candidate-rp (for RP) and show ipv6 pim bsr election (for BSR)

4] ping from R1 (FF0D::2 and FF0D::3 specify the exact outgoing interface with full name e.g fastethernet0/0)

5] show ipv6 mroute (on R2 and R3)

6] debug ipv6 pim

Let me know if this was helpful Thanks.

Nandan Mathure

Actions

Login or Register to take actions

This Discussion

Posted March 30, 2012 at 4:59 AM
Stats:
Replies:2 Avg. Rating:
Views:958 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard