1841 serial interface problem

Unanswered Question
Mar 30th, 2012

Hi,

  In one of my client location cisco 1841 router and the link is down.

while i troubleshooting the serial interface they show like this.

so i check with the service provider they told line is ok.

  how to i locate the problem.

how to troubleshoot??/where is the problem our end or service provider end???

Serial0/1/0 is up, line protocol is down

  Hardware is GT96K Serial

  Internet address is 192.168.109.53/30

  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP ACKsent, loopback not set

  Keepalive set (10 sec)

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters 02:47:29

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     299 packets input, 4186 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 3 giants, 0 throttles

     424 input errors, 424 CRC, 213 frame, 4 overrun, 0 ignored, 212 abort

     874 packets output, 12236 bytes, 0 underruns

     0 output errors, 0 collisions, 53 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     13 carrier transitions

    DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (1 ratings)
Vasileios Bouloukos Sat, 03/31/2012 - 00:02

Hi,

It seems that you have errors and CRC to your interface

  424 input errors, 424 CRC, 213 frame, 4 overrun, 0 ignored, 212 abort

Be sure that the link is ok.

you should have a layer 2 problem.

Serial0/1/0 is up, line protocol is down

Check the mtu and full duplex is the same to both interface ends.

Also check any L2 encapsulation config. PPP config should be the correct and similar to both ends

Hope that helps

Vasilis


kumarpmt83 Sat, 03/31/2012 - 00:52

I clear the error and CRC using the command clear counter.

Config:

RDC-GODOWN#sh running-config

Building configuration...

Current configuration : 2260 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RDC-GODOWN

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 notifications

enable secret 5 $1$DGSg$2d/PkBqOj7iypcHH6S8v80

enable password cisco

!

no aaa new-model

ip cef

!

!

!

!

multilink bundle-name authenticated

isdn switch-type basic-net3

!

!

username cisco privilege 15 secret 5 $1$qB55$CoVxYzC/y/oB3SCOv0qw90

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address 10.20.245.100 255.255.255.0

duplex auto

speed auto

keepalive 1000

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface BRI0/0/0

ip address negotiated

encapsulation ppp

dialer idle-timeout 180

dialer string 04428299970

dialer load-threshold 200 either

dialer watch-disable 15

dialer watch-group 10

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

ppp authentication chap

ppp multilink

!

interface Serial0/1/0

bandwidth 128

ip address 192.168.109.53 255.255.255.252

ip accounting output-packets

encapsulation ppp

!

router eigrp 100

passive-interface default

no passive-interface BRI0/0/0

network 10.0.0.0

no auto-summary

!

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 10.10.245.0 mask 255.255.255.0

neighbor 192.168.109.54 remote-as 9829

no auto-summary

!

ip forward-protocol nd

!

!

no ip http server

!

snmp-server community startrac RW 55

snmp-server ifindex persist

snmp-server location ***DELHI-RO***

snmp-server contact ***Datacraft GSC , Bangalore***

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps envmon

snmp-server enable traps config

snmp-server enable traps cpu threshold

snmp-server host 152.102.153.235 startrac

Can u check any problem in my config.

How to check mtu value??

Any problem in modem or cable???

johnlloyd_13 Sat, 03/31/2012 - 02:17

hi,

ask the SP to give you a loopback from the nearest exchange towards the 1841. you must check from inside LAN and should see the serial link to be up/up (looped). if it's still up/down, push the SP to dispatch an onsite technician to check the cabling or the NTU.

kumarpmt83 Sat, 03/31/2012 - 03:14

I am not getting loop from my nearest exchange.

Any problem in modem or sp cable pair??

johnlloyd_13 Sat, 03/31/2012 - 03:26

yes and it's highly probable. ask the SP to send a tech in order to rectify your issue.

Vasileios Bouloukos Sat, 03/31/2012 - 04:56

Hi,

I do not see any problem to your config.

Your mtu value can be checked with the show interface command.

To the provided output is 1500bytes

Serial0/1/0 is up, line protocol is down

  Hardware is GT96K Serial

  Internet address is 192.168.109.53/30

  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,

  Encapsulation PPP

It should be the same to the other endpoint.

The ppp negotiation is stuck to the LCP phase

(from your output)

Serial0/1/0 is up, line protocol is down

  Hardware is GT96K Serial

  Internet address is 192.168.109.53/30

  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP ACKsent, loopback not set

If you type debug ppp negotiation you will see that L2 fails (ppp to be established) and this is the reason that the interface is up/down

Regards,

Vasilis

kumarpmt83 Sun, 04/01/2012 - 22:17

I given the command debug ppp negotiation in the router

it shows like

PPP protocol negotiation debugging is on.

No error has came.

After that what i am to check?

Vasileios Bouloukos Mon, 04/02/2012 - 00:02

PPP can not be established otherwise you should see this subent as connected to the show ip route output.

Can you see this subnet to the routing table?

It seems that should be an error in the physical layer. I would suggest to procced with the actions mentioned by johnlloyd13

Actions

Login or Register to take actions

This Discussion

Posted March 30, 2012 at 11:35 PM
Stats:
Replies:9 Avg. Rating:4
Views:1076 Votes:0
Shares:0
Tags: No tags.
Categories: Routers
+

Discussions Leaderboard