3ware CLI

Answered Question
Apr 5th, 2012

I need some help with the Raid 5 array. I had two disk drives fail and now the raid-5 is Inoperable. I have been reading the AMCC Storage 3ware CLI guide, but I can't figure out how to add the drives I replace to the Raid Unit. Does anyone know how to do this?

//csit-svr-cam-8> //csit-svr-cam-8> /c2 show

Unit  UnitType  Status         %RCmpl  %V/I/M  Stripe  Size(GB)  Cache  AVrfy
------------------------------------------------------------------------------
u0    RAID-5    INOPERABLE     -       -       64K     4656.51   OFF    OFF    

Port   Status           Unit   Size        Blocks        Serial
---------------------------------------------------------------
p0     OK               u0     465.76 GB   976773168     9QGA22LV
p1     OK               u0     465.76 GB   976773168     9QM0EHKW
p2     OK               u0     465.76 GB   976773168     9QM0EVJN
p3     OK               -      465.76 GB   976773168     9WJ1M0ZH
p4     OK               u0     465.76 GB   976773168     9QM0G9DP
p5     OK               u0     465.76 GB   976773168     9QM0FQKT
p6     OK               -      465.76 GB   976773168     9WJ1LRP9
p7     OK               u0     465.76 GB   976773168     9QM0CBPN
p8     OK               u0     465.76 GB   976773168     9QGA26D8
p9     OK               u0     465.76 GB   976773168     9QM0GBYR
p10    OK               u0     465.76 GB   976773168     9QM0FQSA
p11    OK               u0     465.76 GB   976773168     9QM0E7TJ

I have this problem too.
0 votes
Correct Answer by harsandh about 2 years 1 week ago
  1. The server had lost 2 drives. They are not showing with any unit ID
  2. Screen Shot 2012-04-05 at 1.42.02 PM.png

  1. We did a delete partitions

/c2/u0 del

Do a show to see if it deleted properly

/c2 show

Screen Shot 2012-04-05 at 2.28.50 PM.png

  1. Then build the raid

/c2 add type=raid5 disk=0-11

  1. Do a show and it should show initializing. This is background init.

/c2 show

Screen Shot 2012-04-05 at 2.30.14 PM.png

  1. Exit out of tw_cli,
  2. ---------------------------------------------------------------------------------
  3. Do a cat/proc/partitions to see partitions showing up

cat/proc/partitions

  1. Create filesystem

parted /dev/sdb mklabel gpt

  1. Do a print to see the filesystem

parted /deb/sdb print

  1. Make the sdb partition into an xfs filesysem

parted -- /dev/sdb mkpart primary xfs 0 -0

  1. Do a print to check filesystem again

parted /dev/sdb print

  1. Now  format the disk

mkfs –t xfs –f /dev/sdb1

  1. Then mount the disk

mount /dev/sdb1 /media1

  1. Put entry for media1 in fstab (use vi or whatever)

vi /etc/fstab

  1. Then do an unmount and mount, test filesystem table entry

umount /media1

mount /media1

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
harsandh Thu, 04/05/2012 - 15:49
  1. The server had lost 2 drives. They are not showing with any unit ID
  2. Screen Shot 2012-04-05 at 1.42.02 PM.png

  1. We did a delete partitions

/c2/u0 del

Do a show to see if it deleted properly

/c2 show

Screen Shot 2012-04-05 at 2.28.50 PM.png

  1. Then build the raid

/c2 add type=raid5 disk=0-11

  1. Do a show and it should show initializing. This is background init.

/c2 show

Screen Shot 2012-04-05 at 2.30.14 PM.png

  1. Exit out of tw_cli,
  2. ---------------------------------------------------------------------------------
  3. Do a cat/proc/partitions to see partitions showing up

cat/proc/partitions

  1. Create filesystem

parted /dev/sdb mklabel gpt

  1. Do a print to see the filesystem

parted /deb/sdb print

  1. Make the sdb partition into an xfs filesysem

parted -- /dev/sdb mkpart primary xfs 0 -0

  1. Do a print to check filesystem again

parted /dev/sdb print

  1. Now  format the disk

mkfs –t xfs –f /dev/sdb1

  1. Then mount the disk

mount /dev/sdb1 /media1

  1. Put entry for media1 in fstab (use vi or whatever)

vi /etc/fstab

  1. Then do an unmount and mount, test filesystem table entry

umount /media1

mount /media1

Actions

Login or Register to take actions

This Discussion

Posted April 5, 2012 at 12:59 PM
Stats:
Replies:1 Avg. Rating:5
Views:471 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard