×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

2811 Internet. Why is this stil working?

Unanswered Question
Apr 6th, 2012
User Badges:

Hello everyone,



I had a 2811 that was getting a private IP address on the outside interface and was sending outbound Internet to that interface.  We had the cable modem but into bridge mode and now we are getting a public IP via DHCP on the outside interface.  I tried to change the route statement to 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx to reflect the new IP address but traffic stopped.  I even tried IP route 0.0.0.0 0.0.0.0  interface FastEthernet0/1.  Router took the command but traffic stopped again. the only time traffic will flow is when I set IP route 0.0.0.0 0.0.0.0 192.168.0.2


Any ideas?  All replies rated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
John Blakley Fri, 04/06/2012 - 09:07
User Badges:
  • Purple, 4500 points or more

Does it work without adding a static route? If so, can you do a "show ip route | inc 0.0.0.0" and post the results?

angel-moon Fri, 04/06/2012 - 09:20
User Badges:

The config is just as uploaded.


Output is S*      0.0.0.0/[254/0] via xx.xxx.230.133.1

Richard Burts Fri, 04/06/2012 - 09:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I recognize that the original poster says that it works when the static route uses 192.168.0.2. But the config that is posted does not support that. In the posted config the router has no way to know where 192.168.0.2 would be. So I can only assume that the posted config does not accurately reflect the operating environment when the original poster was doing the configuration and troubleshooting.


I do have a comment and a suggestion.

- configuring 0.0.0.0 0.0.0.0 fasteth0/1 is not recommended. For it to work requires that the provider router is supporting proxy arp, and increasingly providers are turning off support for proxy arp (and Cisco mirrors that since the default in recent versions of IOS has  been proxy arp is off). Since the original poster says that this passed no traffic we can assume that this provider has turned off proxy arp.

- if you are getting the interface address via DHCP it is likely that the provider is also offering you a default route learned via DHCP. I suggest that you try this and see if it works:

ip route 0.0.0.0 0.0.0.0 dhcp


HTH


Rick

Actions

This Discussion