Assigning IP address to VLANs in SGE2010P

Unanswered Question
Apr 10th, 2012

Hi.  Recently purchased 5 SGE2010P 48-port switches to replace older L2 switches.  I have 4 switches in single stack and one as a standalone.  Both the stack and standalone will connect to at least 1 Dell 2724 switch.  Both the stack and the standalone Cisco are in Layer 3 mode.

I have created several VLans on the Cisco switches, and am trying to assign an IP address to the VLan, but cannot seem to figure out the web gui.  Each time I try to use Systems > System Management > IP Addressing > IP Interface, then click Add, it simply changes the existing IP of the management interface.  So, I'm not sure how to go about assigning an IP Address to an Vlan. 

Your help is greatly appreciated.

Thanks

Jeff.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
amikat Tue, 04/10/2012 - 12:44

Hi,

When you click "Add" button in L3 mode you should see the "Add IP Interface" page which displays Interface types at the first row (Port, LAG, VLAN). Here you should mark "VLAN" and choose the Vlan NUMBER. Then you should fill in the "IP address" and "Network mask" fields and click "Apply" and as a result the appropriate interface vlan address should be updated. This of course expect the appropriate vlans are created before.

Best regards,

Antonin 

jeff.ewing Tue, 04/10/2012 - 13:19

Thank you, Antonin, for your quick reply.  However, that is the exact point where it doesn't work.  I will insert an screen shot so you can see that I have created VLan 22 and I think I have followed the steps you outlined above.  When I click Apply, only the IP address of the switch interface changes and I can no longer access the switch.  I have to resort to a console connection and Putty to remove the IP address and it reverts back to the 192.168.1.254 address.  Perhaps I am in the wrong menu to begin with.  - Jeff.

amikat Tue, 04/10/2012 - 13:52

Hi,

Thanks for the reply and the screenshot provided. I do hope you are doing well just to be 100% sure: at the moment of the screenshot taken you have changed the interface to be configured to Vlan 22 and then filled the IP address field to something like 192.168.22.254 and the network mask field to something like 255.255.255.0 and then clicked "Apply". Are you saying that just after that click you have lost the connection to the switch and had to remove this (like 192.168.22.254) address - can you please confirm.

Best regards,

Antonin

jeff.ewing Wed, 04/11/2012 - 08:35

That is correct.  I have attached another screen shot of my console after I make the change.  It shows that IP address 192.168.22.1/24 is indeed VLAN 22.  However, VLAN 1 is no longer listed. 

amikat Wed, 04/11/2012 - 09:56

Hi,

Thanks for the information provided. For the next steps let us work with only 2 vlans, Vlan 1 and Vlan 22. As soon as you succeed you can extend for other Vlans.

First please check if you have both vlans defined. Please go to Bridging > VLAN Management > Properties menu and have a look if both Vlans are displayed here. If not please use the "Add" button and add a vlan. Then please repeat the procedure with the IP V4 address assignment. If both Vlans are listed at this menu then I must think over what the problem could be. In the meantime I wish to advise you how to succeed with CLI. Please do as follows:

Open your console & putty session. If you are using older version of software you will be presented with the menu, then please choose TextView CLI. If you are using new software you will be presented CLI prompt directly (ie.: switchxxxx#). At this prompt please type the following sequence of commands (each one followed by "enter"):

conf t

vlan database

vlan 22

exit

interface vlan 22

ip address 192.168.22.254 255.255.255.0

exit

exit

The prompt will change during the configuration but after the last "exit" you should be back at the switch prompt

(ie.: switchxxxx#).

Now you may decide to write down your configuration and issue the "wr" command. After the confirmation your start-up configuration will be updated. Now you can display this configuration via the "sh start" command and if you decide you can post it for me to check.

Finally please check via your http session whether you can see both IP V4 addresses.

Good luck!

Best regards,

Antonin

jeff.ewing Wed, 04/11/2012 - 10:05

Both Vlans are listed (see attached screen shot).  I will try the CLI later today and let you know how that goes.  Glad I could provide a head-scratcher for you.

thanks.  Jeff.

jeff.ewing Wed, 04/11/2012 - 12:45

Antonin,

Initially, after getting into the lcli, I was unsuccessful.  I assigned the ip address to vlan 22 but then it changed the interface to that ip and no knowledge of 192.168.1.254. Then I went into the vlan 1 interface and assigned it the .1 subnet manually.  After that, I was able to use the web gui to assign vlans and ip addresses to my hearts content.  Not sure why I had to do that through the lcli, but it worked in the long run.

Now, it's my understanding that the 2010p, in L3 mode, will autmatically create the inter-vlan routes.  No VTP setup is required.  Correct?  Also, if you have a sample config you can pass along, that would be helpful.  Not sure I trust the Admin guide.

Thanks for all your help.

Jeff.

amikat Wed, 04/11/2012 - 13:28

Hi Jeff,

Yes, you are correct, with the CLI the same behaviour happens: as soon as you assign IP address to interface Vlan 22 you need to re-assign the IP address to interface Vlan 1 (in config mode: interface vlan 1 ip address 192.168.1.254 255.255.255.0 - you have found your way) - sorry, I forgot to mention. It has been quite some time since I worked with these units and currently I have none in my lab, so I cannot remember the catch, but I think it has something to do with the original setting of the unit to be able to receive the IP address from DHCP via Vlan 1. But this applies to the original factory configuration only, when adding more vlans you should not experience this type of issues.

As for your other questions my comment is as follows: in L3 mode the unit recognizes directly connected IP subnets and can forward the packets accordingly, I guess that is what you may call inter-vlan routes in the case you assign IP address to Vlan interface. Also please remember you can configure static routes. For the dynamic Vlan creation/distribution GVRP is supported. I am sorry to say I cannot provide any sample config.

I do not keep sample configs. I have been working with various Cisco equipment for quite some time but tend to forget a lot. I am not a man with a systematic approach I am affraid. If there is anything I need solve I usually try to simulate in my lab if possible. If not I try to use my head to find out the solution. As you have already discovered and quite correctly mentioned there is plenty of documentation with various levels of quality but at the end it is up to you to find the solution. That is (networking) life.

Good luck with the Cisco equipment!

Best regards,

Antonin

jeff.ewing Thu, 04/12/2012 - 08:38

Hello Antonin.  I have my vlans configured, however, now I am having trouble getting DHCP to relay to the VLan.  I have a W2k8 server running DHCP with defined scopes of:

192.168.0.0 /24 - Vlan 1 (def gw is 192.168.01 - actual gw to the real world)

192.168.22.0 /24 - Vlan 22 (def gw is 192.168.22.1 - ip of vlan interface)

I can get DHCP on vlan 1, but not on vlan 22.

I have set DHCP Server to my W2k8 box which is on vlan 1 at 192.168.0.16

I have set DHCP Interface as Vlan 22

The gui on this switch is not very intuitive to me.  Your help is greatly appreciated.

thanks.  Jeff.

amikat Thu, 04/12/2012 - 09:26

Hi Jeff,

Have you enabled DHCP Relay at the DHCP Server page (System > System Management > IP Addressing > DHCP Relay  > DHCP Server)?

Best regards,

Antonin

jeff.ewing Thu, 04/12/2012 - 09:35

Antonin, yes I have enabled DHCP Relay and added Vlan 22 to the DHCP Interface.  Screen Shots attached.

amikat Thu, 04/12/2012 - 09:56

Hi Jeff,

Up until now I thought that your Vlan1 IP address range is 192.168.1.0/24 but now I can see that your DHCP server is at 192.168.0.0/24. Is this intended?

Best regards,

Antonin

jeff.ewing Thu, 04/12/2012 - 10:36

Right.  192.168.1.254 is the default address/subnet for the switch interface.  When we were able to add IP addresses to the vlans, I made vlan 1 192.168.0.0 and vlan 2 is 192.168.22.0. So, the dgw is on 192.168.0.0.

jeff

amikat Thu, 04/12/2012 - 12:07

Hi Jeff,

Thanks for the answer. Have you checked/configured that your Win2008 server supports DHCP Option 82?

Best regards,

Antonin

amikat Thu, 04/12/2012 - 23:49

Hi Jeff,

How are you doing? If still not succeeded can you please return to switch CLI and issue the "sh ip d r" command and post the output. Also as a quick check can you please assign one of your Vlan 22 host static IP address and DG and try to ping both Vlan 22 and Vlan 1 interfaces. Also as you are running L3 mode can you please try without Option 82 enabled.

Best regards,

Antonin

Actions

Login or Register to take actions

This Discussion

Posted April 10, 2012 at 7:05 AM
Stats:
Replies:15 Avg. Rating:
Views:1302 Votes:0
Shares:0
Tags: No tags.
Categories: Switches
+

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
69
65
55