IS-IS configured over a trunk link between l3 switches

Unanswered Question
Apr 10th, 2012

Hi,

I have got two switches s1 and s2 which are connected through a trunk port. SVIs are configured on two switches along with ISIS. Problem is switches are not able to route the SVIs or networks configured on other switches. I dont know if it can be done on trunk link, so  I need help in this. I am copying the configuration of two switches:

This is the trunk link:

S1(3/3) <--->S2(7/1)

I have checked this scenario by making the the ports 3/3 and 7/1 on both switches as l3 ports and it was working fine. So just wanted to confirm if this can be done or not.

Switch 1

Switch#sh run

Building configuration...

Current configuration : 2852 bytes

!

! Last configuration change at 06:50:48 UTC Tue Apr 10 2012

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service compress-config

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

hw-module system max-queue-limit 7000

!

!

!        

vtp domain cisco

vtp mode transparent

!

power redundancy-mode redundant

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 6-7,10,20,30

!

!

!

!

!

!

!

interface Loopback1

ip address 3.3.3.3 255.255.255.255

ip router isis

!

interface FastEthernet1

no ip address

shutdown

speed auto

duplex auto

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface GigabitEthernet1/5

!

interface GigabitEthernet1/6

!

interface GigabitEthernet3/1

!        

interface GigabitEthernet3/2

!

interface GigabitEthernet3/3

switchport mode trunk

!

interface GigabitEthernet3/4

!

interface GigabitEthernet3/5

!

interface GigabitEthernet3/6

!

interface GigabitEthernet3/7

!

interface GigabitEthernet3/8

!

interface GigabitEthernet3/9

!

interface GigabitEthernet3/10

!

interface GigabitEthernet3/11

!

interface GigabitEthernet3/12

!

interface GigabitEthernet3/13

!

interface GigabitEthernet3/14

!

interface GigabitEthernet3/15

!

interface GigabitEthernet3/16

!

interface GigabitEthernet3/17

!

interface GigabitEthernet3/18

!

interface GigabitEthernet3/19

!

interface GigabitEthernet3/20

!

interface GigabitEthernet3/21

!

interface GigabitEthernet3/22

!

interface GigabitEthernet3/23

!        

interface GigabitEthernet3/24

!

interface GigabitEthernet3/25

!

interface GigabitEthernet3/26

!

interface GigabitEthernet3/27

!

interface GigabitEthernet3/28

!

interface GigabitEthernet3/29

!

interface GigabitEthernet3/30

!

interface GigabitEthernet3/31

!

interface GigabitEthernet3/32

!

interface GigabitEthernet3/33

!

interface GigabitEthernet3/34

!

interface GigabitEthernet3/35

!

interface GigabitEthernet3/36

!

interface GigabitEthernet3/37

!

interface GigabitEthernet3/38

!

interface GigabitEthernet3/39

!

interface GigabitEthernet3/40

!

interface GigabitEthernet3/41

!

interface GigabitEthernet3/42

!

interface GigabitEthernet3/43

!

interface GigabitEthernet3/44

!

interface GigabitEthernet3/45

!

interface GigabitEthernet3/46

!        

interface GigabitEthernet3/47

!

interface GigabitEthernet3/48

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 10.0.0.2 255.0.0.0

ip router isis

!

interface Vlan30

ip address 30.0.0.1 255.0.0.0

ip router isis

!

router isis

net 49.0001.0000.0000.000c.00

nsf cisco

nsf interval 0

nsf interface wait 30

maximum-paths 8

!

no ip http server

!

!

!

!

!

!

line con 0

stopbits 1

speed 38400

line vty 0 4

login

!

end

Switch#      

Switch 2

Switch#sh run

Building configuration...

Current configuration : 4604 bytes

!

! Last configuration change at 04:45:49 UTC Tue Apr 10 2012

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service compress-config

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

ip vrf mgmtVrf

!

!        

!

vtp domain cisco

vtp mode transparent

!

power redundancy-mode redundant

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

redundancy

mode sso

!

vlan internal allocation policy ascending

!

vlan 7-11,14-15,20,30

!

!

!

!        

!

!

!

interface Loopback0

no ip address

!

interface Loopback1

ip address 1.1.1.1 255.255.255.255

ip router isis

!

interface FastEthernet1

ip vrf forwarding mgmtVrf

no ip address

speed auto

duplex auto

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface GigabitEthernet1/5

!

interface GigabitEthernet1/6

!

interface GigabitEthernet1/7

!

interface GigabitEthernet1/8

!

interface GigabitEthernet1/9

!

interface GigabitEthernet1/10

!

interface GigabitEthernet1/11

!

interface GigabitEthernet1/12

!

interface GigabitEthernet1/13

!

interface GigabitEthernet1/14

!

interface GigabitEthernet1/15

!        

interface GigabitEthernet1/16

!

interface GigabitEthernet1/17

!

interface GigabitEthernet1/18

!

interface GigabitEthernet1/19

!

interface GigabitEthernet1/20

!

interface GigabitEthernet1/21

!

interface GigabitEthernet1/22

!

interface GigabitEthernet1/23

!

interface GigabitEthernet1/24

!

interface GigabitEthernet1/25

!

interface GigabitEthernet1/26

!

interface GigabitEthernet1/27

!

interface GigabitEthernet1/28

!

interface GigabitEthernet1/29

!

interface GigabitEthernet1/30

!

interface GigabitEthernet1/31

!

interface GigabitEthernet1/32

!

interface GigabitEthernet1/33

!

interface GigabitEthernet1/34

!

interface GigabitEthernet1/35

!

interface GigabitEthernet1/36

!

interface GigabitEthernet1/37

!

interface GigabitEthernet1/38

!        

interface GigabitEthernet1/39

!

interface GigabitEthernet1/40

!

interface GigabitEthernet1/41

!

interface GigabitEthernet1/42

!

interface GigabitEthernet1/43

!

interface GigabitEthernet1/44

!

interface GigabitEthernet1/45

!

interface GigabitEthernet1/46

!

interface GigabitEthernet1/47

!

interface GigabitEthernet1/48

!

interface TenGigabitEthernet3/1

!

interface TenGigabitEthernet3/2

!

interface GigabitEthernet3/3

!

interface GigabitEthernet3/4

!

interface GigabitEthernet3/5

!

interface GigabitEthernet3/6

!

interface TenGigabitEthernet4/1

!

interface TenGigabitEthernet4/2

!

interface GigabitEthernet4/3

!

interface GigabitEthernet4/4

!

interface GigabitEthernet4/5

!

interface GigabitEthernet4/6

!

interface GigabitEthernet7/1

switchport mode trunk

!

interface GigabitEthernet7/2

!

interface GigabitEthernet7/3

!

interface GigabitEthernet7/4

!

interface GigabitEthernet7/5

!

interface GigabitEthernet7/6

!

interface GigabitEthernet7/7

!

interface GigabitEthernet7/8

!

interface GigabitEthernet7/9

!

interface GigabitEthernet7/10

!

interface GigabitEthernet7/11

!

interface GigabitEthernet7/12

!        

interface GigabitEthernet7/13

!

interface GigabitEthernet7/14

!

interface GigabitEthernet7/15

!

interface GigabitEthernet7/16

!

interface GigabitEthernet7/17

!

interface GigabitEthernet7/18

!

interface GigabitEthernet7/19

!

interface GigabitEthernet7/20

!

interface GigabitEthernet7/21

!

interface GigabitEthernet7/22

!

interface GigabitEthernet7/23

!

interface GigabitEthernet7/24

!

interface GigabitEthernet7/25

!

interface GigabitEthernet7/26

!

interface GigabitEthernet7/27

!

interface GigabitEthernet7/28

!

interface GigabitEthernet7/29

!

interface GigabitEthernet7/30

!

interface GigabitEthernet7/31

!

interface GigabitEthernet7/32

!

interface GigabitEthernet7/33

!

interface GigabitEthernet7/34

!

interface GigabitEthernet7/35

!        

interface GigabitEthernet7/36

!

interface GigabitEthernet7/37

!

interface GigabitEthernet7/38

!

interface GigabitEthernet7/39

!

interface GigabitEthernet7/40

!

interface GigabitEthernet7/41

!

interface GigabitEthernet7/42

!

interface GigabitEthernet7/43

!

interface GigabitEthernet7/44

!

interface GigabitEthernet7/45

!

interface GigabitEthernet7/46

!

interface GigabitEthernet7/47

!

interface GigabitEthernet7/48

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 10.0.0.1 255.0.0.0

ip router isis

!

interface Vlan20

ip address 20.0.0.1 255.0.0.0

ip router isis

!

router isis

net 49.0001.0000.0000.000b.00

nsf cisco

nsf interval 0

nsf interface wait 30

maximum-paths 8

!

no ip http server

!        

!

!

!

!

!

line con 0

stopbits 1

speed 38400

line vty 0 4

login

!

end

Switch# 

Thanks,

Krishna,

Employee Id:-496777,

Cisco Systems, Inc,

Bangalore.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
kmckayMRU Fri, 04/13/2012 - 08:46

Does a routing adjacency establish between the two routers?

If I am understanding you correctly, the issue is that you cannot route to the other switch from the local switch - meaning you are not recieving routes from the neighbor ?

kpvnss Fri, 04/13/2012 - 09:13

Yes Kyle I am not recieving routes from the neighbor

kpvnss Fri, 04/13/2012 - 09:19

Kyle I forgot to mention something If I configure the ports that are linked between the switches as access ports adding them to some vlan and configure SVI on both of the switches for that particular vlan and also configure ISIS on this SVI and remaining SVIs/L3 ports, I am able to see the routes of neighbouring switch. I could see problem only with configuring the ports as trunk.

Reza Sharifi Fri, 04/13/2012 - 10:36

I know your ports are trunked and therefore all vlans are allowed, but can you add the specific vlans and test again?

kpvnss Sun, 04/15/2012 - 00:18

Yes Reza I did that using "sw trunk   allowed ", but not able to see the routes of another switch.

Peter Paluch Sun, 04/15/2012 - 03:10

Reza, Krisha,

Please allow me to join the discussion. This is an interesting issue.

Krisha, can you please provide the output of the following commands from both switches? It's going to be quite a list but possibly it will help us narrow down the scope of the problem.

  • show cdp neighbor
  • show interfaces trunk
  • show isis neighbors
  • show clns
  • show clns protocol
  • show clns neighbors
  • show ip protocols
  • show ip route

Thank you!

Best regards,

Peter

kpvnss Sun, 04/15/2012 - 23:53

Peter, I am sending you the info which you asked me.

Switch 1:-

s1#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

gsgsw-labswitch16

                 Fas 1             162             R S I  WS-C4948  Gig 1/13

s2               Gig 3/1           127             R S I  WS-C4503- Gig 3/1

s1#sh run int gi3/1

Building configuration...

Current configuration : 93 bytes

!

interface GigabitEthernet3/1

switchport trunk allowed vlan 10

switchport mode trunk

end

s1#sh ip int br | i up

FastEthernet1          unassigned      YES unset  up                    up     

GigabitEthernet3/1     unassigned      YES unset  up                    up     

GigabitEthernet3/2     unassigned      YES unset  up                    up     

GigabitEthernet3/3     unassigned      YES unset  up                    up     

GigabitEthernet3/4     unassigned      YES unset  up                    up     

Loopback1              1.1.1.1         YES manual up                    up     

Vlan1                  unassigned      YES unset  up                    up     

Vlan10                 10.0.0.1        YES manual up                    up     

Vlan20                 20.0.0.1        YES manual up                    up     

s1#sh inter

s1#sh interfaces tru

s1#sh interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi3/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi3/1       10

Port        Vlans allowed and active in management domain

Gi3/1       10

Port        Vlans in spanning tree forwarding state and not pruned

Gi3/1       10

s1#sh

s1#show isi

s1#show isis neigh

s1#show isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id

s1#sh

s1#show clsn

s1#show clns

Global CLNS Information:

  3 Interfaces Enabled for CLNS

  Configuration Timer: 60, Default Holding Timer: 300, Packet Lifetime 64

  ERPDU's requested on locally generated packets

  Running IS-IS in IP-only mode (CLNS forwarding not allowed)

  NET: 49.0001.0002.0002.0002.00

s1#sh clns proto

s1#sh clns protocol

IS-IS Router: 2

  System Id: 0002.0002.0002.00  IS-Type: level-1-2

  Manual area address(es):

        49.0001

  Routing for area address(es):

        49.0001

  Interfaces supported by IS-IS:

        Loopback1 - IP

        Vlan20 - IP

        Vlan10 - IP

  Redistribute:

    static (on by default)

  Distance for L2 CLNS routes: 110

  RRR level: none

  Generate narrow metrics: level-1-2

  Accept narrow metrics:   level-1-2

  Generate wide metrics:   none

  Accept wide metrics:     none

s1#sh

s1#show clns

s1#show clns neigh

s1#show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol

s1#sh ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "isis 2"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Redistributing: isis 2

  Address Summarization:

    None

  Maximum path: 4

  Routing for Networks:

    Vlan10

    Vlan20

    Loopback1

  Routing Information Sources:

    Gateway         Distance      Last Update

  Distance: (default is 115)

s1#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets

C        1.1.1.1 is directly connected, Loopback1

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.0.0.0/8 is directly connected, Vlan10

L        10.0.0.1/32 is directly connected, Vlan10

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        20.0.0.0/8 is directly connected, Vlan20

L        20.0.0.1/32 is directly connected, Vlan20

s1#

s1#

Switch 2:-

s2#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

s1               Gig 3/1           122             R S I  WS-C4503  Gig 3/1

s2#sh run int gi3/1

Building configuration...

Current configuration : 93 bytes

!

interface GigabitEthernet3/1

switchport trunk allowed vlan 10

switchport mode trunk

end

s2#sh ip int br | i up

GigabitEthernet3/1     unassigned      YES unset  up                    up     

GigabitEthernet3/2     unassigned      YES unset  up                    up     

GigabitEthernet3/3     unassigned      YES unset  up                    up     

GigabitEthernet3/4     unassigned      YES unset  up                    up     

Loopback1              2.2.2.2         YES manual up                    up     

Vlan1                  unassigned      YES unset  up                    up     

Vlan10                 10.0.0.2        YES NVRAM  up                    up     

Vlan30                 30.0.0.1        YES manual up                    up     

s2#sh inter

s2#sh interfaces tru

s2#sh interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi3/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi3/1       10

Port        Vlans allowed and active in management domain

Gi3/1       10

Port        Vlans in spanning tree forwarding state and not pruned

Gi3/1       10

s2#sh

s2#show isi

s2#show isis neig

s2#show isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id

s2#sh

s2#show clns

s2#show clns

Global CLNS Information:

  3 Interfaces Enabled for CLNS

  Configuration Timer: 60, Default Holding Timer: 300, Packet Lifetime 64

  ERPDU's requested on locally generated packets

  Running IS-IS in IP-only mode (CLNS forwarding not allowed)

  NET: 49.0001.0001.0001.0001.00

s2#sh clns pro

s2#sh clns protocol

IS-IS Router: 2

  System Id: 0001.0001.0001.00  IS-Type: level-1-2

  Manual area address(es):

        49.0001

  Routing for area address(es):

        49.0001

  Interfaces supported by IS-IS:

        Loopback1 - IP

        Vlan30 - IP

        Vlan10 - IP

  Redistribute:

    static (on by default)

  Distance for L2 CLNS routes: 110

  RRR level: none

  Generate narrow metrics: level-1-2

  Accept narrow metrics:   level-1-2

  Generate wide metrics:   none

  Accept wide metrics:     none

s2#sh

s2#show clns

s2#show clns neigh

s2#show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol

s2#sh ip

s2#sh ip pro

s2#sh ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "isis 2"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Redistributing: isis 2

  Address Summarization:

    None

  Maximum path: 4

  Routing for Networks:

    Vlan10

    Vlan30

    Loopback1

  Routing Information Sources:

    Gateway         Distance      Last Update

  Distance: (default is 115)

s2#sh ip

s2#sh ip route

s2#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets

C        2.2.2.2 is directly connected, Loopback1

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.0.0.0/8 is directly connected, Vlan10

L        10.0.0.2/32 is directly connected, Vlan10

      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        30.0.0.0/8 is directly connected, Vlan30

L        30.0.0.1/32 is directly connected, Vlan30

s2#

kpvnss Mon, 04/16/2012 - 00:06

Hi Peter,

Another small thing which I wanted to mention if I make the ports which are linked between switch 1 and switch 2 as access instead of trunk then everything works fine, I am sending you the required info for that also please look into it.

Switch 1:-

s1#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

gsgsw-labswitch16

                 Fas 1             179             R S I  WS-C4948  Gig 1/13

s2               Gig 3/1           144             R S I  WS-C4503- Gig 3/1

s1#sh run int gi3/1

Building configuration...

Current configuration : 87 bytes

!

interface GigabitEthernet3/1

switchport access vlan 10

switchport mode access

end

s1#sh ip int br | i up

FastEthernet1          unassigned      YES unset  up                    up     

GigabitEthernet3/1     unassigned      YES unset  up                    up     

GigabitEthernet3/2     unassigned      YES unset  up                    up     

GigabitEthernet3/3     unassigned      YES unset  up                    up     

GigabitEthernet3/4     unassigned      YES unset  up                    up     

Loopback1              1.1.1.1         YES manual up                    up     

Vlan1                  unassigned      YES unset  up                    up     

Vlan10                 10.0.0.1        YES manual up                    up     

Vlan20                 20.0.0.1        YES manual up                    up     

s1#sh isis niegh

s1#sh isis neigh

s1#sh isis neighbors

System Id      Type Interface   IP Address      State Holdtime Circuit Id

s2             L1   Vl10        10.0.0.2        UP    8        s2.01             

s2             L2   Vl10        10.0.0.2        UP    8        s2.01             

s1#sh clns

Global CLNS Information:

  3 Interfaces Enabled for CLNS

  Configuration Timer: 60, Default Holding Timer: 300, Packet Lifetime 64

  ERPDU's requested on locally generated packets

  Running IS-IS in IP-only mode (CLNS forwarding not allowed)

  NET: 49.0001.0002.0002.0002.00

s1#sh clns proto

s1#sh clns protocol

IS-IS Router: 2

  System Id: 0002.0002.0002.00  IS-Type: level-1-2

  Manual area address(es):

        49.0001

  Routing for area address(es):

        49.0001

  Interfaces supported by IS-IS:

        Loopback1 - IP

        Vlan20 - IP

        Vlan10 - IP

  Redistribute:

    static (on by default)

  Distance for L2 CLNS routes: 110

  RRR level: none

  Generate narrow metrics: level-1-2

  Accept narrow metrics:   level-1-2

  Generate wide metrics:   none

  Accept wide metrics:     none

s1#sh clns neigh

System Id      Interface   SNPA                State  Holdtime  Type Protocol

s2             Vl10        0021.d8ce.51ff      Up     8         L1L2 IS-IS

s1#sh ip proto

s1#sh ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "isis 2"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Redistributing: isis 2

  Address Summarization:

    None

  Maximum path: 4

  Routing for Networks:

    Vlan10

    Vlan20

    Loopback1

  Routing Information Sources:

    Gateway         Distance      Last Update

    2.2.2.2              115      00:06:19

  Distance: (default is 115)

s1#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets

C        1.1.1.1 is directly connected, Loopback1

      2.0.0.0/32 is subnetted, 1 subnets

i L1     2.2.2.2 [115/20] via 10.0.0.2, 00:07:25, Vlan10

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.0.0.0/8 is directly connected, Vlan10

L        10.0.0.1/32 is directly connected, Vlan10

      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        20.0.0.0/8 is directly connected, Vlan20

L        20.0.0.1/32 is directly connected, Vlan20

i L1  30.0.0.0/8 [115/20] via 10.0.0.2, 00:07:25, Vlan10

s1#

Switch 2:-

s2#

s2#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

s1               Gig 3/1           160             R S I  WS-C4503  Gig 3/1

s2#sh run int gi3/1

Building configuration...

Current configuration : 87 bytes

!

interface GigabitEthernet3/1

switchport access vlan 10

switchport mode access

end

s2#sh ip int br | i up

GigabitEthernet3/1     unassigned      YES unset  up                    up     

GigabitEthernet3/2     unassigned      YES unset  up                    up     

GigabitEthernet3/3     unassigned      YES unset  up                    up     

GigabitEthernet3/4     unassigned      YES unset  up                    up     

Loopback1              2.2.2.2         YES manual up                    up     

Vlan1                  unassigned      YES unset  up                    up     

Vlan10                 10.0.0.2        YES NVRAM  up                    up     

Vlan30                 30.0.0.1        YES manual up                    up     

s2#sh isis neigh

System Id      Type Interface   IP Address      State Holdtime Circuit Id

s1             L1   Vl10        10.0.0.1        UP    24       s2.01             

s1             L2   Vl10        10.0.0.1        UP    29       s2.01             

s2#sh clns

Global CLNS Information:

  3 Interfaces Enabled for CLNS

  Configuration Timer: 60, Default Holding Timer: 300, Packet Lifetime 64

  ERPDU's requested on locally generated packets

  Running IS-IS in IP-only mode (CLNS forwarding not allowed)

  NET: 49.0001.0001.0001.0001.00

s2#sh clns

s2#sh clns neig

s2#sh clns pro      

s2#sh clns protocol

IS-IS Router: 2

  System Id: 0001.0001.0001.00  IS-Type: level-1-2

  Manual area address(es):

        49.0001

  Routing for area address(es):

        49.0001

  Interfaces supported by IS-IS:

        Loopback1 - IP

        Vlan30 - IP

        Vlan10 - IP

  Redistribute:

    static (on by default)

  Distance for L2 CLNS routes: 110

  RRR level: none

  Generate narrow metrics: level-1-2

  Accept narrow metrics:   level-1-2

  Generate wide metrics:   none

  Accept wide metrics:     none

s2#sh clns

s2#sh clns neigh

System Id      Interface   SNPA                State  Holdtime  Type Protocol

s1             Vl10        000d.ed4a.49ff      Up     29        L1L2 IS-IS

s2#sh ip pro

s2#sh ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "isis 2"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Redistributing: isis 2

  Address Summarization:

    None

  Maximum path: 4

  Routing for Networks:

    Vlan10

    Vlan30

    Loopback1

  Routing Information Sources:

    Gateway         Distance      Last Update

    1.1.1.1              115      00:00:03

  Distance: (default is 115)

s2#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets

i L1     1.1.1.1 [115/20] via 10.0.0.1, 00:09:00, Vlan10

      2.0.0.0/32 is subnetted, 1 subnets

C        2.2.2.2 is directly connected, Loopback1

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.0.0.0/8 is directly connected, Vlan10

L        10.0.0.2/32 is directly connected, Vlan10

i L1  20.0.0.0/8 [115/20] via 10.0.0.1, 00:09:00, Vlan10

      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        30.0.0.0/8 is directly connected, Vlan30

L        30.0.0.1/32 is directly connected, Vlan30

s2#

Thanks,

Krishna.

Peter Paluch Mon, 04/16/2012 - 00:13

Hello Krishna,

I will go over your outputs in more detail later today - thanks for uploading them.

The difference in the behavior caused by the trunk reminds me of a possible problem related to system MTU. Can you please enter the following command on the interface Vlan10 on both switches and see if it makes the IS-IS work through the trunk?

interface Vlan 10

  no isis hello padding

Thank you!

Best regards,

Peter

kpvnss Mon, 04/16/2012 - 01:43

Hi Peter,

I checked it by adding "no isis hello padding" this to the "int vlan 10" of both switches. Still it is not working...

Thanks,

krishna.

Peter Paluch Mon, 04/16/2012 - 01:54

Hello Krishna,

I'd say it's time to do some debugging

Set the ports between the switches to access mode, and issue the debug isis adj-packets and debug isis protocol-errors. Observe the buildup of the adjacency and possibly record the sequence of steps taken for the routers to become adjacent.

Then, set the ports between the switches to trunk mode and again, observe the debug output. Try to find the spot where the debug begins to differ.

Best regards,

Peter

kpvnss Mon, 04/16/2012 - 23:45

Hi Peter,

After changing the native vlan of trunk ports using (sw trunk native vlan 10), I could see the routes and ISIS is working fine.

interface GigabitEthernet3/1

switchport trunk native vlan 10

switchport trunk allowed vlan 10

switchport mode trunk

end

Thanks a lot everyone :-)

Regards,

krishna.

Peter Paluch Tue, 04/17/2012 - 00:20

Krishna,

Thank you for updating us! But frankly, the solution does not make any sense Why should a native VLAN modification cause the IS-IS to miraculously start working?

I am suspecting some problem with STP here. Can you put back the native VLAN 1, wait 20-30 seconds, and check the output of show spanning-tree and show spanning-tree inconsistentports if there is any issue related to some STP-discovered inconsistency?

Once again, this solution is weird - and we've got to know the exact mechanism behind it.

Best regards,

Peter

kpvnss Wed, 04/18/2012 - 06:42

Hi Peter,

I tested it and I am sure that this is not the problem of Spanning tree protocol. What I understand from my knowledge and after discussing with my teammates that as we need atleast one l3 channel on the top of  which we can configure a routing protocol so that the routes can be exchanged using that l3 channel.

In my setup the intention was to create an SVI for vlan 10 on both of the switches which resembles configuring l3 interfaces between the switches. As we know that it is working fine if I make it as access port of the vlan 10. Problems come with trunk port whose default native vlan is 1, and all the untagged packets(including the packets which carry is-is routes info) are tagged with vlan 1, which shouldn't be the case and get dropped at other switch  as there is no virtual l3 channel configured on vlan 1(i.e., configuring SVIs for vlan 1 at both ends), as we are creating a virtual l3 channel using SVIs of vlan 10. So if we change the native vlan of the trunk to vlan 10, the untagged packets will be tagged with vlan 10 info and as the  SVIs are configured at both ends, routing info is exchanged and it is working successfully.

I hope that this makes sense. Once again thank you very much Peter.

Thanks,

Krishna.

Actions

Login or Register to take actions

This Discussion

Posted April 10, 2012 at 8:13 AM
Stats:
Replies:14 Avg. Rating:
Views:682 Votes:0
Shares:0
Tags: No tags.
Categories: Switches, IP SLA
+

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,745
4 7,088
5 6,742
Rank Username Points
140
80
78
69
40