EIGRP all FD are infinite.

Unanswered Question
Apr 10th, 2012
User Badges:
  • Bronze, 100 points or more

Hi All,

Planning a migration from OSPF to EIGRP. I'm firing up the EIGRP on my devices with an AD of 120 for internal and 170 for external. I was hoping to check the topology tables and verify the correct routes are being learned, metrics look correct etc. to my Surprise, all of the FD in my routing tables say Infinite/Infinity/Inaccessible (depending on platform). OSPF is fine. I guess i'm confused, should I not see an FD if EIGRP route isn't being used?

I have 2x Nexus 5548 as my cores with L3 card. I have 2x 3945E (3900-1 and 3900-2) connected to the Nexus' via routed links.


All my peerings are up. The Nexus' are peered to eachother, a couple of L3 switches are peered to the Nexus' and my 3945Es are peered as well. All the subnets from the Nexus switches appear on my 3900s in the topology table, but FD is infinite. I have a 3rd 3945E (3900-3) peered to 3900-2. The 3rd 3900 isn't getting any topology information from 3900-2 for any routes that are sourced off the Nexus boxes. It's getting topology for the /30 interfaces on 3900-2 going to the Nexuses though and the loopback on 3900-2. I have not tweaked any delays / bandwidths yet. I need to get past this hurdle before I do that. Thanks.

here's Nexus EIGRP config (from one of them, both are identical):

version 5.1(3)N1(1)

feature eigrp


router eigrp 10

  distance 120 170

  redistribute static route-map redistribution

  address-family ipv4 unicast

    authentication mode md5

    authentication key-chain EIGRP-Keychain


interface loopback1

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan59

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan90

  ip router eigrp 10


interface Vlan99

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan101

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan102

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan103

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan104

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan105

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan106

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan108

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan110

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan111

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan112

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan113

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan114

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan116

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan120

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan121

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan131

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan141

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan151

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan250

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Vlan799

  ip router eigrp 10

  ip passive-interface eigrp 10


interface Ethernet1/9

  ip router eigrp 10


interface Ethernet2/7

  ip router eigrp 10


EIGRP Config from 3900-2 connects to E2/7 on the Nexus above

router eigrp 10

network 66.194.154.252 0.0.0.3

network 192.168.100.12 0.0.0.3

network 192.168.100.16 0.0.0.3

network 192.168.100.28 0.0.0.3

network 192.168.250.38 0.0.0.0

distance eigrp 120 170

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

no passive-interface Tunnel1



Here's a small part of the topology table from 3900-2; Its enough to illustrate my point.

P 192.168.99.0/24, 0 successors, FD is Infinity

        via 192.168.100.17 (3072/2816), GigabitEthernet0/1

        via 192.168.100.13 (3072/2816), GigabitEthernet0/0


P 192.168.116.0/24, 0 successors, FD is Infinity

        via 192.168.100.17 (3072/2816), GigabitEthernet0/1

        via 192.168.100.13 (3072/2816), GigabitEthernet0/0


P 192.168.151.0/24, 0 successors, FD is Infinity

        via 192.168.100.17 (3072/2816), GigabitEthernet0/1

        via 192.168.100.13 (3072/2816), GigabitEthernet0/0


P 192.168.101.0/24, 0 successors, FD is Infinity

        via 192.168.100.17 (3072/2816), GigabitEthernet0/1

        via 192.168.100.13 (3072/2816), GigabitEthernet0/0


Debug on 3900-3 for incoming topology information. debug ip eigrp

This output i'd expect... Routing table not updated, but the info is put into the topology table. The networks learned are that directly connected to 3900-2. The ones being advertised are in the topology on 3900-3.

Apr 10 11:17:17.136: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 192.168.100.29 (Tunnel1) is up: new adjacency

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 66.194.206.76/30 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.95.0/25 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.95.128/25 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.100.24/30 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.100.28/30 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.250.18/32 - do advertise out Tunnel1

Apr 10 11:17:19.138: EIGRP-IPv4(10): table(default): 192.168.100.20/30 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 66.194.206.76/30 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.95.0/25 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.95.128/25 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.100.24/30 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.100.28/30 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.250.18/32 - do advertise out Tunnel1

Apr 10 11:17:19.142: EIGRP-IPv4(10): table(default): 192.168.100.20/30 - do advertise out Tunnel1

Apr 10 11:17:19.152: EIGRP-IPv4(10): Int 192.168.100.12/30 M 11008 - 250000 30000000 SM 2816 - 2524971008 152

Apr 10 11:17:19.152: EIGRP-IPv4(10): table(default): 192.168.100.12/30 routing table not updated thru 192.168.100.29

Apr 10 11:17:19.152: EIGRP-IPv4(10): Int 192.168.100.16/30 M 11008 - 250000 30000000 SM 2816 - 2524971008 152

Apr 10 11:17:19.152: EIGRP-IPv4(10): table(default): 192.168.100.16/30 routing table not updated thru 192.168.100.29

Apr 10 11:17:19.152: EIGRP-IPv4(10): Int 192.168.250.38/32 M 138752 - 250000 5020000000 SM 128256 - 4060086272 76293

Apr 10 11:17:19.152: EIGRP-IPv4(10): table(default): 192.168.250.38/32 routing table not updated thru 192.168.100.29

Apr 10 11:17:19.152: EIGRP-IPv4(10): Int 66.194.154.252/30 M 28672 - 100000 120000000 SM 28160 - 3774873600 1525

Apr 10 11:17:19.152: EIGRP-IPv4(10): table(default): 66.194.154.252/30 routing table not updated thru 192.168.100.29

Apr 10 11:17:19.152: EIGRP-IPv4(10): Int 192.168.100.28/30 M 11008 - 250000 30000000 SM 10496 - 2524971008 152

Apr 10 11:17:19.152: EIGRP-IPv4(10): table(default): 192.168.100.28/30 routing table not updated thru 192.168.100.29



I know I'm not giving full configs, but I think this is enough to get the idea of the problem im facing. Is what I'm seeing normal? How can I remedy? Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Peter Paluch Tue, 04/10/2012 - 13:50
User Badges:
  • Cisco Employee,

Hello,


If the EIGRP is unable to insert an EIGRP-learned route into the routing table because of higher AD, it will mark its FD as infinite in the topology table. The reason is that each distance vector routing protocol advertises a network only if it has been successfully installed into the routing table (i.e. a router running EIGRP advertises an EIGRP-learned network only if it is using it itself). If an EIGRP-learned route is not used by the router, it will not be advertised further.


Because you have set the AD of internal EIGRP routes to 120, you have made them less preferred than the OSPF routes using the AD of 110. That prevents the EIGRP from installing its own routes into the routing table, and marking all EIGRP-learned routes as unreachable. Why did you modify the EIGRP's AD in the first place?


Best regards,

Peter

Richard Burts Tue, 04/10/2012 - 14:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Peter


The original poster was pretty clear about why he changed the AD for EIGRP. He is currently running OSPF and does not want to disrupt his live environment while he checks out EIGRP. And I believe that this is a sound approach. However it is not as simple a thing to accomplish as he had thought. He was assuming that he would be able to check out the metrics of advertised routes. But as you so accurately point out EIGRP does not advertise a learned route that does not get inserted into its routing table as an EIGRP route.


So when you look in the topology table you would see entries for the local subnets matching network statements, and you would see entries for subnets learned from its immediate neighbors. But you would not see anything from an EIGRP router more than one hop away. And you would not be able to check the propagation of the routing metric.


HTH


Rick

rtjensen4 Wed, 04/11/2012 - 06:44
User Badges:
  • Bronze, 100 points or more

Thanks for everyone's input. Yeah, it was just a matter of making the EIGRP routes active. It's been a good 4-5 years since I've used EIGRP... i forgot how much more "user-friendly" it is.

Richard Burts Wed, 04/11/2012 - 10:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I am glad that you got it worked out. Thank you for posting back to the forum and giving us the updated status.


HTH


Rick

qstyk Wed, 08/07/2013 - 07:57
User Badges:

Neither is more or less user-friendly; it is just based around familiarity. I cut my teeth on OSPF, but have worked with many clients using EIGRP.


After working with both protocols and having completed my R&S CCIE, I really don't give a RIP.


-Jon

Actions

This Discussion

Related Content