×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

3560CG shows 0 traffic in class-map

Answered Question
Apr 11th, 2012
User Badges:

Hi, QoS expert


I tried to put QoS in a  WS-C3560CG-8TC-S  version 12.2(55)EX2.


It shows 0 traffic in class-map.


Here is the config


My question is why I can not see the traffic via class-map?

it should in the default Q if incorrect mark.


I erased the config and config with the autoQoS, shows the same result.


Let me know and thanks.


*******************

class-map match-any VoIP
  description Voice IP Phone RTP
match access-group 157

class-map match-any WEB
  description Internal Web, SSL Web, DNS query, Pinnacle
match access-group 153

!


policy-map QOSMARK

class VoIP
  set dscp ef


class WEB
  set dscp cs3


class class-default
  set dscp default


access-list 153 remark * WEB class (IP Precedence 2)
access-list 153 remark - HTTP traffic (within local only)
access-list 153 permit tcp any any eq www
access-list 153 permit tcp any eq www any
access-list 153 remark - SSL Web traffic
access-list 153 permit tcp any any eq 443
access-list 153 permit tcp any eq 443 any


access-list 157 remark * VoIP class (IP Precedence 5)
access-list 157 remark - voice RTP packets
access-list 157 permit udp any any range 16384 32767
access-list 157 permit udp any range 16384 32767 any


interface GigabitEthernet0/8

switchport access vlan 874

switchport mode access

service-policy input QOSMARK


*******************


here is the result


Switch#show policy-map interface g0/8
GigabitEthernet0/8

  Service-policy input: QOSMARK


    Class-map: VoIP (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 157
        0 packets, 0 bytes
        5 minute rate 0 bps


    Class-map: WEB (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 153
        0 packets, 0 bytes
        5 minute rate 0 bps


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        5 minute rate 0 bps
Switch#


Switch#show int g0/8

GigabitEthernet0/8 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is a456.3091.5488 (bia a456.3091.5488)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:03, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 1 packets/sec

  5 minute output rate 5000 bits/sec, 7 packets/sec

     3111 packets input, 311714 bytes, 0 no buffer

     Received 91 broadcasts (79 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 79 multicast, 0 pause input

     0 input packets with dribble condition detected

     22156 packets output, 11306901 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Switch#

Correct Answer by krahmani323 about 5 years 4 months ago

Hello Dahua, Adam,


Yes, it is a famous limitation regarding the "show policy-map interface" and documented by bug CSCso80701.


Just like Adam mentionned you can use 'show mls qos interface....[stat]' to get some infos instead.


===========================================

CSCso80701


Symptom: "show policy-map interface"  shows no matches


Conditions:

This command is run on one of the following switches:

2950 / 2960 / 2970 / 3550 /3560 /3750


Workaround:

This is a hardware limitation and these switches do not support this output.  There is no workaround.

===========================================


Best regards.

Karim

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Adam Styles Wed, 04/11/2012 - 15:01
User Badges:

A lot of the time the 'sh policy map interface' command in a switching environment will simply show you what is applied to the interface. Try issuing a 'sh mls qos interface g0/8' or 'sh mls qos interface g0/8 stats'.


Thanks,


Adam

Correct Answer
krahmani323 Wed, 04/11/2012 - 18:03
User Badges:
  • Silver, 250 points or more

Hello Dahua, Adam,


Yes, it is a famous limitation regarding the "show policy-map interface" and documented by bug CSCso80701.


Just like Adam mentionned you can use 'show mls qos interface....[stat]' to get some infos instead.


===========================================

CSCso80701


Symptom: "show policy-map interface"  shows no matches


Conditions:

This command is run on one of the following switches:

2950 / 2960 / 2970 / 3550 /3560 /3750


Workaround:

This is a hardware limitation and these switches do not support this output.  There is no workaround.

===========================================


Best regards.

Karim

Actions

This Discussion