×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Passing voice and data Vlans on Cisco SG200-08P help

Answered Question
Apr 13th, 2012
User Badges:

Hello All,


I'm struggling with a configuration issue on the Cisco SG200-08P.


We are using the Cisco SG200-08P on a mobile cart that will go from class room to class room that will have computer and cisco Voip phone plugged into it. The issue is that each of our closets are in differnt VLANS ( 1 voice and 1 data....lets say data vlan 20 and voice vlan 2025 for conversation) and that we route to each closet.


It would be great if I could just create a generic data and voice vlan to dynamically pick up what the upstream switch has however, it seems that I've been unsuccessful in doing so.


So far I can pass the data Vlan no probablem. The upstream switch port is set to access port and a switch port access voice vlan (these are 3750x switches)


If the above is not possible I guess I will take what I can get. Should I just create data vlan 20 and voice vlan2025 on the Cisco SG200-08P and make a trunk port on the Cisco SG200-08P and a trunk on the 3750x? Is there an option on the Cisco SG200-08P to tag voice traffic?


I'm also concerned with VTP and I did not see an area in the Cisco SG200-08P to set that as a client and transparent mode.


Thanks for any help,

Dan

Correct Answer by rmanthey about 5 years 4 months ago

Playne,


first the bad news, the small business switches currently don't support VTP, they support GVRP which is like VTP, but it only reports the VLANs that are used it will not automatically learn like VTP.


You should be able to setup the 3750 as a trunk with vlan 1U or untagged and vlan 2025 as tagged for voice. setup the small business switch port the same way for its connecting port. All the ports that only have phones will be access 2025U and all PC only ports would be access 1U. All phone and computer ports would be trunk 1u, 2025T




Cisco Small Business Support Center

Randy Manthey

CCNA, CCNA - Security

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
rmanthey Fri, 04/13/2012 - 14:12
User Badges:
  • Bronze, 100 points or more

Playne,


first the bad news, the small business switches currently don't support VTP, they support GVRP which is like VTP, but it only reports the VLANs that are used it will not automatically learn like VTP.


You should be able to setup the 3750 as a trunk with vlan 1U or untagged and vlan 2025 as tagged for voice. setup the small business switch port the same way for its connecting port. All the ports that only have phones will be access 2025U and all PC only ports would be access 1U. All phone and computer ports would be trunk 1u, 2025T




Cisco Small Business Support Center

Randy Manthey

CCNA, CCNA - Security

dan hale Fri, 04/13/2012 - 20:27
User Badges:

Thanks, Randy....worked out just as described!

Eric Glodowski Tue, 01/08/2013 - 11:54
User Badges:

Sorry to revive such an old thread, but I'm having the same exact issue, and have not resolved it.


I have a 3750X connecting to a SG200-08P.  The switchport on the 3750X is configured as:


switchport trunk encap dot1q

switchport mode trunk


On the SG, I'm using port 8 as the uplink, and have it configured as 1U,5T (where vlan 5 is the voice vlan).  A Cisco phone is connected to port 1.


I've tried to follow this from Randy:

"All the ports that only have phones will be access 2025U and all PC only ports would be access 1U. All phone and computer ports would be trunk 1u, 2025T"


If I configure port 1 as 5U, the phone grabs DHCP from the vlan5 pool.

If I configure port 1 as 1U,5T the phone pulls DHCP from vlan1 pool, when it should be pulling from vlan5.  A PC connected behind this phone also pulls DHCP from vlan 1.


I have not been able to correctly configure this switch so that a phone on port 1 pulls DHCP from vlan 5 (voice vlan), and a PC behind that phone pulls DHCP from vlan 1.


I have also configured what I "think" is auto voip like so:


Telephony OUI Based Auto VoIP:

Vlan: enabled (checked)

Vlan ID: 5

Priority: 7


I then made sure "Auto VoIP Mode" is enabled (checked).



I work day in and day out with Cisco switch, but this "port to vlan" and "port vlan membership" stuff really confuses me.  If I were to translate what I'm looking for into IOS, it would look like this:


SG switch:

conf t

!

int gig 1

switchport mode access

switchport access vlan 1 (default, i know)

switchport voice vlan 5

!

int gig 8

switchport trunk encap dot1q

switchport mode trunk

!


3750X switch:

int gig 1/0/36 (connecting to port 8 on SG)

switchport trunk encap dot1q

switchport mode trunk

!


I can't seem to make that happen. 

Tom Watts Tue, 01/08/2013 - 12:33
User Badges:
  • Green, 3000 points or more

To translate the 3750 literally how the SG200 sees it, it would look like


switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 5


This makes it 1u, 5t.

The most likely problem is the 3750 is sending tag packet and the sg200 is discarding it since it is adhering to 802.1q which specifies the native vlan is untagged. You may change the port mode on the sg200 to general and disable ingress filter to see if it makes a difference.



-Tom
Please mark answered for helpful posts

Eric Glodowski Tue, 01/08/2013 - 13:02
User Badges:

Hi Tom,


Thank you so much for you reply.  I have tried what you suggested, however that still didn't do it.  If ingress filtering is enabled when a port is in trunk mode, wouldn't that mean that packets tagged with vlan 5 are being discarded at port 8 (uplink port)?


I've tried to make port 8 general, and disable ingress filterings, same results.

Tom Watts Tue, 01/08/2013 - 13:28
User Badges:
  • Green, 3000 points or more

On a Catalyst switch, when a port is defined as a trunk without a vlan specified on the port, all vlan pass through the port. On a small business switch it is nearly the opposite. You must specify the vlans on the links. Additionally, ingress filter discards anything not associated to the port.


802.1q specifies there must be an untagged vlan which is the native vlan (of course you can make exceptions, tagging the default vlan..).


One thing I did in the past with a 2960, I made an LLDP network policy and it basically "provisioned" the downstream switch connecting link and voice vlan. That may be another idea for you.


Here's a link that may be useful-


https://supportforums.cisco.com/message/3811376



Here is the 2960 config I used to feed a SB switch voice info


Switch#show run

Building configuration...


Current configuration : 2206 bytes

!

! Last configuration change at 00:41:16 UTC Mon Mar 1 1993

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

system mtu routing 1500

vtp mode transparent

!

!

!

!

!

!

!

!

!

network-policy profile 1

voice vlan 100 cos 4

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 2

name test

!

vlan 100

lldp run

!

!

!

!

!

!

interface FastEthernet0/1

network-policy 1

spanning-tree portfast

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan100

no ip address

!

ip http server

ip http secure-server

logging esm config

!

line con 0

line vty 5 15

!

end


Switch#




-Tom
Please mark answered for helpful posts

I was having the same problems as you.  While I haven't done packet capturing to see what the culprit actually is, I do have this working on my SG200-08P. 

My setup is (roughly):

SIP Firewall (Edgemark 4750, vlan 90 native)
Cisco ASA 5516-X (vlan 90, native)
Cisco 3850 Core Stack (vlan 90, native)
Cisco 2960X Stack (trunk, all vlans)
Cisco 3560CX (trunk, all vlans)
Cisco SG200-08P (trunk, 80T (data), 90T (voice), 500T (mgmt))
Polycom VVX300 (general, 80UP, 90U)

To be more clear about the SG200-08P's port config:

g1, general, pvid 80, vlan 80 untagged, vlan 90 untagged
g8, trunk, pvid 1, 1 tagged, 80 tagged, 90 tagged, 500 tagged

Since we use DHCP-based voice configuration, vlan 80 has DHCP option 60 defined as vlan 90; vlan 90 has the remainder of the options for the Polycom.  Unfortunately this part doesn't seem to work.  Our hosted voice provider never set up LLDP and so I can't use it. 

Like many have reported with similar setups, this kept dumping the phone into the data network. 

What worked for me:

* upgrading the firmware of the SG200-08P to 1.0.8.3 (from 1.0.6.2)
* Vlan Management -> Voice and Media -> Telephony OUI
* Defined the Polycom mac
* Vlan Management -> Voice and Media -> Telephony OUU Based Auto VoIP
- Vlan (enabled), VLAN ID 90, Priority 7 -> Apply
- Interface g1 -> edit -> enable auto VoIP mode -> Apply -> Ok -> Close

Of course, save. 

I rebooted the Polycom and it came up in the correct VLAN.  What I don't see on the phone is where the VLANID is defined- it's blank (Home -> Settings -> Status -> Network -> TCP/IP Parameters).  On every other phone (not connected to the SG200) it shows the correct VLAN.  That's why I'm thinking something weird is happening with DHCP.  I'd go out on a limb that it has something to do with VLAN 1. 

However, it seems that forcing Telephony OUI, that the device is at least in the correct subnet, and the phone registers with the SIP gateway. 




Roman Iskhakov Fri, 11/21/2014 - 03:32
User Badges:

Hello!

I need your help, i have cisco sg200 switch, i need to configure it for data and voice vlan, i configured trunk to cisco 2960X

Trunk -  1 VLAN Untagged (Data) 100 VLAN Tagged (for voice)

if i do access ports for PC and IP PHONE separately it works, if i want to connect through one port it's not

I tried many ways, Trunk 1U 100T, Trunk 1T 100T, tried General 1U 100T, 1T 100T Port settings, how i have to configure to connect data voice to same port?

Aleksandra Dargiel Fri, 11/21/2014 - 10:56
User Badges:
  • Silver, 250 points or more

Hi Roman,

Can you configure your phone to tag VLAN 100? That should help.

Aleksandra

Roman Iskhakov Sun, 11/23/2014 - 22:48
User Badges:

Hello, I have 7821 IP Phones, you mean in ip phone setting set voice vlan 100? can you please explain

Actions

This Discussion