cti 8.5 issue

Unanswered Question
Apr 13th, 2012


We have the Call center with following setup

Hosted IPCC 8.5

CVP 8.5

UCM 8.5

It is three months old setup, we are having some cti issues as follows with agent randomly happening

1. Calls is landing to Phone and cti screen takes more time to display the call details (agent changed to reserved takes time change the status in cti bar)

2. Some times agent receiving two calls.

We have checked the configuration throughly and not found any configuration issues. What we suspect some where tune-up work is there, or some bugs in the new version (not possible).

We are getting the following error in event viewer.

Route request timeout (threshold: 30000) happened with call (ID: 2130714274) and cross reference (ID: 73375)

please help us.

with Regards,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
david.macias Sun, 04/15/2012 - 07:53

These sounds like either firewall issues or network latency issues.  Are you on the latest version of ICM?  8.5.3 I think.  I would take a look at your cti server log and compare it with the agent ctios log and see how the time stamps compare.


geoff@hp.com Sun, 04/15/2012 - 13:47

Or someone has messed up the CUCM config in the interim.

First satisfy yourself that the SIP signaling is all working correctly between CVP, your proxy server, and the SIP User Agent on CUCM. If those messages are all correct, SIP ladder diagram is correct, times are all fast and reflect your network, start to look at CUCM and the logs.

When the desktop lights up with Reserved, that means the Call Router chose that agent and the Peripheral Gateway is sending the pre-call message through CTIOS. Now the call has to follow.



Dass Prakash R Sun, 04/15/2012 - 23:58

Additionally to Geoff's point you need to look up on the Max calls and Busy triggeer configured on CCM for the Phone's line config. Busy trigger should be set to 2. This is one of the possibility where you could receive more than one call in the agent's phone



manivannan.para... Mon, 04/16/2012 - 00:12

Hi All,

thanks for the input, I do have observed one more behaviour we have two subscribers in UCM cluster.

PG1A  jtapi pointing to sub1

PG1B jtapi piointing to sub2

When PG1B is active we are experiencing the above mentioned problems, so that means something wrong with PG1B configuration, subscriber 2.

please share you ideas what to check

with Regards,


Dass Prakash R Mon, 04/16/2012 - 03:15

Is PG1A and PG1B are seperated over WAN? and where are the agents picking up the calls

manivannan.para... Mon, 04/16/2012 - 03:37


Yes it is seperated over WAN, but we have 10gig dark-fibre link between the sites.

with Regards,


manivannan.para... Sat, 05/12/2012 - 23:44

We have changed busy trigger to one, now they dont have double call issue, but having doubt about what is cisco recommendation for this busy trigger.

anchoudh Sat, 05/12/2012 - 23:54


Requires a busy trigger of 1 (no call waiting), although calls can be forwarded to other extensions on the phone when busy.

Refer the UCCE SRND guide, section "Agent Phones" for more details.



geoff@hp.com Sun, 05/13/2012 - 06:21

manivannan.paramasivam wrote:

We have changed busy trigger to one, now they dont have double call issue, but having doubt about what is cisco recommendation for this busy trigger.

1 and 2 are the correct settings.



geoff@hp.com Mon, 05/14/2012 - 05:05

Sorry, by 1 and 2, I meant Busy Trigger = 1, Max Calls = 2.




This Discussion