MPLS LDP Session not coming up

Unanswered Question
Apr 14th, 2012

I have an LDP session configured over my P2P interface and it is not coming up . What can be the reason ? I can ping the P2P IP adddress

*************************

interface FastEthernet4/1

ip address 10.10.0.46 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Router #sh mpls ldp neighbor

*****************************************

interface GigabitEthernet3/4.1254

encapsulation dot1Q 1254

ip address 10.10.0.45 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Regards

Haris P

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
chatwithharis Sat, 04/14/2012 - 03:50

Router2#sh mpls ldp discovery

Local LDP Identifier:

172.16.12.6:0

Discovery Sources:

Interfaces:

GigabitEthernet3/4.326 (ldp): xmit

Router1#sh mpls ldp discovery

Local LDP Identifier:

172.16.22.137:0

Discovery Sources:

Interfaces:

FastEthernet4/1 (ldp): xmit

Ivan Krimmel Sat, 04/14/2012 - 04:08

Hi Haris,

thanks, I guess these IPs - 172.16.12.6 and 172.16.22.137 are assigned to the loopback interfaces? do you advertise 'em in OSPF, i.e can R1 reach 172.16.12.6 and vice versa?

you can also enable these debugs, assuming you're in a lab that'll not cause any issues:

debug mpls ldp messages received all

debug mpls ldp messages sent all

HTH,

Ivan.

chatwithharis Sat, 04/14/2012 - 05:05

Yes ,IP's 172.16.12.6 and 172.16.22.137 are for loopbacks and im advertising

this thru OSPF and ping each other loopback IP's (also from lookpack to

loopback ip by specifying source IP)

During the below debug , I saw some messages going to some other neighbors

but not to the one we want . The message are going to loopback while in my

case the P2P ldp session itself not coming up

debug mpls ldp messages received all

0 messages

debug mpls ldp messages sent all

0 messages

chatwithharis Sat, 04/14/2012 - 05:58

Router1#sh mpls interfaces

nterface IP Tunnel Operational

FastEthernet4/1 Yes (ldp) No Yes

Router1#sh mpls ldp bindings

tib entry: 0.0.0.0/0, rev 1106706

local binding: tag: imp-null

tib entry: 10.10.10.0/30, rev 62

local binding: tag: imp-null

tib entry: 10.10.10.4/30, rev 64

local binding: tag: imp-null

tib entry: 10.10.10.12/30, rev 60

Router1#sh mpls ldp parameters

Protocol version: 1

Downstream label generic region: min label: 16; max label: 100000

Session hold time: 180 sec; keep alive interval: 60 sec

Discovery hello: holdtime: 15 sec; interval: 5 sec

Discovery targeted hello: holdtime: 90 sec; interval: 10 sec

Downstream on Demand max hop count: 255

LDP for targeted sessions

LDP initial/maximum backoff: 15/120 sec

LDP loop detection: off

Rouetr2#sh mpls ldp parameters

Protocol version: 1

Session hold time: 180 sec; keep alive interval: 60 sec

Discovery hello: holdtime: 15 sec; interval: 5 sec

Discovery targeted hello: holdtime: 90 sec; interval: 10 sec

Downstream on Demand max hop count: 255

LDP for targeted sessions

LDP initial/maximum backoff: 15/120 sec

LDP loop detection: off

Ivan Krimmel Sat, 04/14/2012 - 06:10

Haris,

what is in between, some sort of a switch I guess? is that capable of multicast forwarding, for example can you ping 224.0.0.2 from both routers?

please issue 'sh ip int' for respective interfaces.

chatwithharis Sat, 04/14/2012 - 06:25

Router1#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Reply to request 0 from 10.10.0.45, 16 ms

On the Router 2 ,im not receiving any reply for this host (it is configured as ospf network non-broadcast )whether this will effect >?

Router2#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Router2#sh mpls ldp discovery

Local LDP Identifier:

    172.16.12.6:0

    Discovery Sources:

    Interfaces:

GigabitEthernet3/4.326 (ldp): xmit

Router1#sh mpls ldp discovery

Local LDP Identifier:

    172.16.22.137:0

    Discovery Sources:

    Interfaces:

        FastEthernet4/1 (ldp): xmit

interface FastEthernet4/1

ip address 10.10.0.46 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

*****************************************

interface GigabitEthernet3/4.1254

encapsulation dot1Q 1254

ip address 10.10.0.45 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

chatwithharis Sat, 04/14/2012 - 06:41

In between it is a telco network , OSPF is coming up

I just remove the " ip ospf network non-broadcast " and removed the static neighbor statements and i was able to establish the ospf neighbor relationship

Regards

clavallee01 Sat, 04/14/2012 - 07:10

Harris,

  In your setup can you add mpls ldp router-id Loopback force

Also, do you have mpls label protocol ldp

Craig

chatwithharis Sat, 04/14/2012 - 07:31

Yes , I enter this manually on router

mpls label protocol ldp

no mpls ip propagate-ttl

mpls ldp router-id Loopback1

interface Loopback1

ip address 172.16.22.137 255.255.255.255

end

clavallee01 Sat, 04/14/2012 - 07:45

Harris,

Would you reconfigure the mpls ldp router-id X.X.X.X with a /32 network

mask

Craig

clavallee01 Sat, 04/14/2012 - 07:46

Harris,

Would you reconfigure the mpls ldp router-id to X.X.X.X with a /32 network mask

Craig

chatwithharis Sat, 04/14/2012 - 08:42

i reconfigure mpls ldp id ,but nothing happened !!!!!!!!!

no mpls ldp router-id Loopback1

mpls ldp router-id Loopback1

Regards

clavallee01 Sat, 04/14/2012 - 08:50

Harris,

  Replace the word Loopback1 with the IP Address /32 mask

Craig

chatwithharis Sat, 04/14/2012 - 09:06

there is no option to mpls ldp router-id to X.X.X.X with a /32 network mask , i have onkly the options below

Router1(config)#mpls ldp router-id ?

ATM ATM interface

Async Async interface

BVI Bridge-Group Virtual Interface

CDMA-Ix CDMA Ix interface

CTunnel CTunnel interface

Dialer Dialer interface

FastEthernet FastEthernet IEEE 802.3

Group-Async Async Group interface

Lex Lex interface

Loopback Loopback interface

MFR Multilink Frame Relay bundle interface

Multilink Multilink-group interface

Null Null interface

Port-channel Ethernet Channel of interfaces

Tunnel Tunnel interface

Vif PGM Multicast Host interface

Virtual-PPP Virtual PPP interface

Virtual-Template Virtual Template interface

Virtual-TokenRing Virtual TokenRing

XTagATM Extended Tag ATM interface

chatwithharis Sat, 04/14/2012 - 07:32

#sh mpls interfaces

Interface IP Tunnel Operational

FastEthernet4/1 Yes (ldp) No Yes

#sh mpls interfaces

GigabitEthernet3/4.325 Yes (ldp) No No No Yes

chatwithharis Sat, 04/14/2012 - 09:21

While pinging from R1 with 224.0.0.2 ,from R2 im getting reply but not vice versa

R1#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Reply to request 0 from 10.10.0.45, 20 ms

SHDSL_GEF3#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Actions

Login or Register to take actions

This Discussion

Posted April 14, 2012 at 3:06 AM
Stats:
Replies:20 Avg. Rating:
Views:1680 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard