VCS with CUCM Integration

Unanswered Question
Apr 15th, 2012

Hi All,

We have a VCS 7.1 and CUCM 7.1 integrated using SIP Trunk.

We have Cisco 99xx phones registered with CUCM.

EX90 and C40's are registered with VCS.

Had done the integration as per cisco document, iam able to do a video call from vcs endpoints to cisco 99xx video phones successfully.

All endpoints are in the same campus.

iam able to dial from cisco 99xx phone to vcs endpoint but i have only "audio",  no video.

Configuration done from CUCM:

1)Configured a separate Region(Video BW-Default) and Device pool for video phones.

2)Configured SIP Trunk.

3)Route pattern for dialing Tandberg Endpoints.

4)Configured SIP Trunk  Security Profile.

VCS:

1)Configured Search Rules.

2)Configured Transform.

3)Default bandwidth is set to 1mb.

Please advice if i missing something.

Thanks

John

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
aljaiswa Sun, 04/15/2012 - 10:37

Hi Binu,

Based on your scneario i have some more questions.  But before that i want to make sure whether i am thinking it right.

Scenario 1

Ex90/C-40 registered on VCS dials to 99xx and audio/video works both ways.

Scenario 2

99xx registered on CUCM calls to Ex90/C-40 and audio works both ways but no video is coming to both the endpoints??correct me if i am wrong.

1) check the phone load of 99xx it should not be too old

2) what is the zone type on VCS created towards CUCM? Is it a custom zone or cisco communication manager zone?

3) do you see any changes in the behavior when the 99xx call to ex90 and c-40?

Thanks

Alok

binu.john Sun, 04/15/2012 - 11:44

Hi Alok,

Scenario 1

Ex90/C-40 registered on VCS dials to 99xx and audio/video works both ways- YES

Scenario 2

99xx registered on CUCM calls to Ex90/C-40 and audio works both ways but no video is coming to both the endpoints??YES - NO VIDEO BOTH SIDES.

1)99XX phone load is 9-2-1, which is not that old.

2) what is the zone type on VCS created towards CUCM? Is it a custom zone or cisco communication manager zone?YES- ZONE PROFILE IS CUCM.

Will increasing the Region- video BW will make it working? I tried with custom- 1mb

Thanks

John

aljaiswa Sun, 04/15/2012 - 19:43

Hi Binu,

two things to test.

First for test purpose do not force any bandwidth restriction. let it be default.

second configure this command on C-series and test the call again.

xConfiguration Experimental CapsetFilter:H.264NIL;H.264RCDO

Thanks

Alok

vivsing2 Sun, 04/15/2012 - 20:35

Hi Binu,

If above, doesn't work then please try disabling H264 completely using following command:

xConfig Experimental CapsetFilter: H.264;H.264RCDO;H.264NIL

Regards,

Vivek

mesutozcan Sun, 04/15/2012 - 22:12

Hi Binu,

please downgrade 99XX to 9.0.3 firmware

and

control BW settings between CUCM and VCS regions on CUCM site while using Location and Regison settings of SIP Trunk

BW must be 384 kbps for video on both setting

Regards,

binu.john Mon, 04/16/2012 - 10:01

Thanks Vivek,Alok and mesut,

Just to confirm- the command to apply on the codec C40 and EX90's?

Hi Mesut- I will check your point and reply you tommorow.

Rgds

Binu John

vivsing2 Mon, 04/16/2012 - 10:23

Hi Binu,

This command work for both EX and C series.

Regards,

Vivek

aljaiswa Mon, 04/16/2012 - 10:43

Binu,

I do not think there is a need to disable the H.264. I think it can be fixed with disabling the additional H.264 parameters.

first try only this

xConfiguration Experimental CapsetFilter:H.264NIL;H.264RCDO

if it doesn't works then upgrade the phone load on the 99xx as pointed by Mesut.

And yes this command works same for both the endpoints.

Thanks

Alok

aljaiswa Tue, 04/17/2012 - 10:32

Hi Binu,

i wanted to know if you got this working. If not then do post here and lets see we can help you more on this.

Thanks

Alok

binu.john Tue, 04/17/2012 - 11:24

Hi Alok,

I will surely update you the result once i apply the above.

Thanks

Binu

binu.john Thu, 04/19/2012 - 04:31

Thanks all,

I had downgraded the FW to 9.0.3 and changed the location&Region-video BW to 384 on CUCM. After that i was able to

make Point to point calls (with both audio and video)between C40 to 99XX and viceversa.

But when iam dialing to MCU permanent conference from cisco phone iam not able to see other party video,its blank.(only audio).

Rgds

Binu John

mesutozcan Thu, 04/19/2012 - 06:34

Binu,

Check your trunk's Loc and Reg setting which is between CUCM and VCS or MCU

binu.john Thu, 04/19/2012 - 06:59

Hi Mesut,

Trunk's location is correct.. Do i need to configure MCU 4505 in call manager as well( as a MRGL)?,

Currently MCU is registered on VCS.

And i had created a Route pattern on call manager to dial MCU Conference Number.

When i dial P2P from 9951 to c40 or viceversa video call is succesful.

Rgds

Binu

mesutozcan Thu, 04/19/2012 - 07:22

Hi Binu,

I dont think you have to register MCU with CUCM as MR

It would be conference settings of MCU which is related with BW of conference

You should check them

binu.john Thu, 04/19/2012 - 07:30

Hi mesut,

The MCU Conference BW settings i tried today for testing was 1920kb.

Rgds

Binu

binu.john Thu, 04/19/2012 - 07:53

Hi Mesut,

Please advice whats the recommended BW settings on MCU4505, for the conference for Cisco phone and VCS Endpoints.?

Currently for testing it was 2mb.

Rgds

Binu John

sagsheth Thu, 04/19/2012 - 13:10

Hi Binu,

Generally at 768 kbps, you should get good video quality. However if you goal is to get 1080p i would say 1.5 to 2 meg is good.

Now here i dont think its a bandwidth issue, it looks more of caps issue.

Can you attach a sip call from CUCM?

-Sagar

Actions

Login or Register to take actions

This Discussion

Posted April 15, 2012 at 3:59 AM
Stats:
Replies:18 Avg. Rating:
Views:1214 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard