Auto-redundancy using etherchannel in 2960 not working.

Unanswered Question
Apr 16th, 2012

I'm using Packet Tracer for testing since I don't have the actual equipment. I have configured etherchannel between two 2960 Switches. I have used the trunk ports FE  0/23 and FE 0/24 on both switches to create the etherchanel. I have connected one PC with each switch. The PCs are in the same VLAN and can ping each other. Howver, when I take down one of the links in the etherchannel, the other link does not take over and I get 100% packet loss. I don't know what seems to be the problem. I'm quoting the configurations below:

Switch0:


Switch#sh running-config

Building configuration...

Current configuration : 1179 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

spanning-tree mode pvst

!

!

! OUTPUT TRUNCATED !

!

!

interface FastEthernet0/23

channel-group 5 mode on

switchport mode trunk

!

interface FastEthernet0/24

channel-group 5 mode on

switchport mode trunk

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Port-channel 5

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

!

! OUTPUT TRUNCATED !

!

!

end

Switch#show interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/23      on           802.1q         trunking      1

Fa0/24      on           802.1q         trunking      1

Po5         on           802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/23      1-1005

Fa0/24      1-1005

Po5         1-1005

Port        Vlans allowed and active in management domain

Fa0/23      1

Fa0/24      1

Po5         1

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/23      1

Fa0/24      1

Po5         1

Switch#show etherchannel summary

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

5      Po5(SU)           -      Fa0/23(P) Fa0/24(P)

Switch 1:

Switch#sh running-config

Building configuration...

Current configuration : 1179 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

spanning-tree mode pvst

!

!

! OUTPUT TRUNCATED !

!

interface FastEthernet0/23

channel-group 5 mode on

switchport mode trunk

!

interface FastEthernet0/24

channel-group 5 mode on

switchport mode trunk

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Port-channel 5

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

! OUTPUT TRUNCATED !

!

!

end

Switch#show interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/23      on           802.1q         trunking      1

Fa0/24      on           802.1q         trunking      1

Po5         on           802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/23      1-1005

Fa0/24      1-1005

Po5         1-1005

Port        Vlans allowed and active in management domain

Fa0/23      1

Fa0/24      1

Po5         1

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/23      1

Fa0/24      1

Po5         1

Switch#show etherchannel summary

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

5      Po5(SU)           -      Fa0/23(P) Fa0/24(P)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
glen.grant Mon, 04/16/2012 - 04:21

  If the channel shows up with only 1 port being int he channel when you shut 1 port down   then it's probably a packet tracer issue.  You can't rely on everything you see in some of these emulator  programs.  I ahve never used PT but if you can check and see where it knows the mac address of the other pc then maybe you can troubleshoot .  Does it still know the mac of the other pc across that etherchannel.

sarmedRahman Sat, 07/14/2012 - 21:26

It was a packet tracer issue. I have tried etherchannel with actual cisco 2960 switches and it is working. This thread may be closed.

Actions

Login or Register to take actions

This Discussion

Posted April 16, 2012 at 4:16 AM
Stats:
Replies:3 Avg. Rating:
Views:393 Votes:0
Shares:0
Tags: No tags.
Categories: Switches
+

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,745
4 7,088
5 6,742
Rank Username Points
140
80
78
69
40