×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Router 819G - Auto-switch & failover between two Cellular Nets

Unanswered Question
Apr 17th, 2012
User Badges:

Hi all,


I have a Cisco 819G WAN Router with the following specifications:


Router3G#show inventory

NAME: "C819G+7-K9 chassis", DESCR: "C819G+7-K9 chassis"

PID: C819G+7-K9        , VID: V01 , SN: xxxxxxxxxxx


NAME: "C819 Mother board on Slot 0", DESCR: "C819 Mother board"

PID: C819G+7-K9        , VID: V01 , SN: xxxxxxxxxxx


NAME: "Modem 0 on Cellular0", DESCR: "Sierra Wireless Mini Card MC8705 HSPA+R7 modem"

PID: 8705              , VID: 1.0, SN: xxxxxxxxxxx



and employee Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.1(4)M3, RELEASE SOFTWARE (fc1)


The router have dual SIM enabled from diferents ISPs, and I use secesfully the following chat-script for both:


chat-script gsm "" "AT!SCACT=1,1" TIMEOUT 60 "OK"


After the device power on, the Dial-In is successful for SIM 0 (Profile 1) obtaining an IP address by DHCP, and the Profile 2 (Inactive) is associated to SIM 1.


Router3G#show cell 0 profile

Profile 1 = ACTIVE*

--------

PDP Type = IPv4

PDP address = A.B.C.D

Access Point Name (APN) = imovil.entelpcs.cl

Authentication = CHAP

Username: xxxxxxx, Password: xxxxxxx

        Primary DNS address = 200.63.56.3

        Secondary DNS address = 200.63.56.5


Profile 2 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = web.tmovil.cl

Authentication = CHAP

Username: web, Password: web


* - Default profile


Configured default profile for active SIM 0 is profile 1.


Router3G#


   My current problem is that I tryied to simulate a conenction fault, e.g. termination by mobile provider, but the router dont switch-over into the second profile in order to start a new Dial-In with the second ISP.


  I attached at following the current configuration:


Router3G#show running-config

Building configuration...



Current configuration : 2831 bytes

!

! Last configuration change at 00:31:05 UTC Wed Apr 18 2012

! NVRAM config last updated at 00:02:54 UTC Wed Apr 18 2012

! NVRAM config last updated at 00:02:54 UTC Wed Apr 18 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

!

hostname Router3G

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$Qr5C$q3BTcNUQzx9.oL7BRpK0k/

!

no aaa new-model

!

crypto pki token default removal timeout 0

!

!        

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.31.209

!

ip dhcp pool SomeDHCPpool

import all

network 192.168.31.208 255.255.255.240

default-router 192.168.31.209

dns-server 4.2.2.2

!

!

ip domain name XYZ.com

no ipv6 cef

!

!

multilink bundle-name authenticated

chat-script gsm "" "AT!SCACT=1" TIMEOUT 60 "OK"

license udi pid C819G+7-K9 sn FTXxxxxxxx

!

!        

!

no spanning-tree vlan 1

username engineer password 0 cisco

!

!

!

!

controller Cellular 0

gsm sim profile 2 slot 1

gsm sim max-retry 65535

gsm failovertimer 1

!

ip ssh version 2

!

!

!

!

!

!

!

interface Cellular0

ip address negotiated

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer idle-timeout 2147483

dialer string gsm

dialer-group 1

async mode interactive

!

interface FastEthernet0

description "Internal LAN"

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0

no ip address

shutdown

clock rate 2000000

!

interface Vlan1

ip address 192.168.31.209 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!        

ip nat inside source route-map nonat interface Cellular0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0

!

access-list 1 permit any

access-list 131 remark ***** NAT ACL *****

access-list 131 deny   ip 192.168.31.208 0.0.0.15 10.0.1.0 0.0.0.255

access-list 131 permit ip 192.168.31.208 0.0.0.15 any

dialer-list 1 protocol ip list 1

!

!

!

!

route-map nonat permit 10

match ip address 131

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line 3

script dialer gsm

login

modem InOut

no exec

transport input all

rxspeed 21600000

txspeed 5760000

line vty 0 4

login local

transport input all

!

end


  I realy appreciate any comment in order to enable Dual-SIM switch over

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mavespig Tue, 04/17/2012 - 23:53
User Badges:
  • Silver, 250 points or more

Hi Claudio,

can you post the full 'show cell 0 all', and also collect these debugs while the failover should occur:

- deb chat

- deb dialer

- deb ppp nego


I can see that the profile should be already associated with the SIM: gsm sim profile 2 slot 1

The failover should start after a minute, be sure to run the debugs long enough.


How do you simulate the failure on the main SIM?


On a side note, there are a couple of config lines that should be corrected:

interface Cellular0

     encapsulation slip    <<<< It should be PPP.

      dialer idle-timeout 2147483  <<< why a value so high? If you want the timeout to be disabled, just use 0


line 3

      rxspeed 21600000

      txspeed 5760000     <<< these two commands are unnecessary, you can't see the 3G speed manually


Hope this helps

Marco

Claudio Cubillos Wed, 04/18/2012 - 07:44
User Badges:

Marco


   Please find attached the requested show commands:



Router3G#show cellular 0 all

Hardware Information

====================

Modem Firmware Version = T1_0_3_2AP R361 CNSZ

Modem Firmware built = 04/15/11

Hardware Version = 1.0

International Mobile Subscriber Identity (IMSI) = 730011165268140

International Mobile Equipment Identity (IMEI) = 357115040062080

Integrated Circuit Card ID (ICCID) = 89560100000318181407

Mobile Subscriber International Subscriber

IDentity Number (MSISDN) =

Factory Serial Number (FSN) = CC3239101641007

Modem Status = Online

Current Modem Temperature = 33 deg C, State = Normal

PRI SKU ID = 9900198, SKU Rev. = 1.2



Profile Information

====================

Profile 1 = ACTIVE*

--------

PDP Type = IPv4

PDP address = 186.10.C.D

Access Point Name (APN) = imovil.entelpcs.cl

Authentication = CHAP

Username: entelpcs, Password: entelpcs

        Primary DNS address = 200.63.56.4

        Secondary DNS address = 200.63.56.6



Profile 2 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = web.tmovil.cl

Authentication = CHAP

Username: web, Password: web



* - Default profile



Configured default profile for active SIM 0 is profile 1.





Data Connection Information

===========================

Data Transmitted = 3049738 bytes, Received = 9733990 bytes

Profile 1, Packet Session Status = ACTIVE

        IP address = 186.10.7.145

        Primary DNS address = 200.63.56.4

        Secondary DNS address = 200.63.56.6

        Negotiated QOS Parameters:

        Precedence = Normal Priority, Delay = Class 2

        Reliability = Unack GTP, LLC, Ack RLC, Protected data

        Peak = 256 kB/sec, Mean = 50000 kB/hr

        Traffic Class = Interactive

        Uplink Max = 2048kbps, Guaranteed = 16kbps

        Downlink Max = 2048kbps, Guaranteed = 64kbps

        Max SDU size = 1500 bytes

        SDU error ratio = 1E-4, BER = 1E-5

Profile 2, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 3, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 4, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 5, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 6, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 7, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 8, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 9, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 10, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 11, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 12, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 13, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 14, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 15, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 16, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state



Network Information

===================

Current Service Status = Normal, Service Error = None

Current Service = Combined

Packet Service = HSPA+ (Attached)

Packet Session Status = Active

Current Roaming Status = Home

Network Selection Mode = Automatic

Country = CHL, Network = ENTEL PC

Mobile Country Code (MCC) = 730

Mobile Network Code (MNC) = 1

Location Area Code (LAC) = 13502

Routing Area Code (RAC) = 100

Cell ID = 21032

Primary Scrambling Code = 22

PLMN Selection = Automatic

Registered PLMN =  , Abbreviated =

Service Provider = entel



Radio Information

=================

Radio power mode = ON

Current Band = WCDMA 1900, Channel Number = 687

Current RSSI = -65 dBm

Band Selected = Auto

Number of nearby cells = 2

Cell 1

        Primary Scrambling Code = 0x16

        RSCP = -68 dBm, ECIO = -12 dBm



Cell 2

        Primary Scrambling Code = 0xE

        RSCP = -72 dBm, ECIO = -13 dBm




Modem Security Information

==========================

Active SIM = 0

SIM switchover attempts = 0

Card Holder Verification (CHV1) = Disabled

SIM Status = OK

SIM User Operation Required = None

Number of CHV1 Retries remaining = 3



GPS Information

==========================



GPS Info

-------------

GPS State: GPS disabled



SMS Information

===============

Incoming Message Information

----------------------------

SMS stored in modem = 0

SMS archived since booting up = 0

Total SMS deleted since booting up = 0

Storage records allocated = 0

Storage records used = 0

Number of callbacks triggered by SMS = 0

Number of successful archive since booting up = 0

Number of failed archive since booting up = 0



Outgoing Message Information

----------------------------

Total SMS sent successfully = 0

Total SMS send failure = 0

Number of outgoing SMS pending = 0

Number of successful archive since booting up = 0

Number of failed archive since booting up = 0

Last Outgoing SMS Status = SUCCESS

Copy-to-SIM Status =     0x0

Send-to-Network Status = 0x0

Report-Outgoing-Message-Number:

  Reference Number =     0

  Result Code =          0x0

  Diag Code =            0x0 0x0 0x0 0x0 0x0



SMS Archive URL =

Router3G#


  To generate the failover condition over the main SIM (SIM card in slot 0 and engaged to Profile 1) I run the following commands:


Router3G(config)#service internal


Router3G#test cellular 0 modem-power-cycle


Router3G#debug chat

Chat scripts activity debugging is on

Router3G#debug dialer

Dial on demand events debugging is on

Router3G#debug ppp negotiation

PPP protocol negotiation debugging is on

Router3G# 

Router3G#test cellular 0 modem-power-cycle



Apr 18 14:41:23.779: %CISCO800-2-MODEM_DOWN: Cellular0 modem is now DOWN.

Apr 18 14:41:28.859: %LINK-5-CHANGED: Interface Cellular0, changed state to reset

Apr 18 14:41:29.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to down

Apr 18 14:41:32.079: %CISCO800-2-MODEM_UP: Cellular0 modem is now UP.

Modem Power cycled successfully

Router3G#

Apr 18 14:41:33.859: %LINK-3-UPDOWN: Interface Cellular0, changed state to down

Apr 18 14:41:43.859: Ce0 DDR: re-enable timeout

Apr 18 14:41:44.939: Ce0 DDR: place call

Apr 18 14:41:44.939: Ce0 DDR: Dialing cause ip (s=192.168.31.210, d=204.56.87.173)

Apr 18 14:41:44.939: Ce0 DDR: Attempting to dial gsm

Apr 18 14:41:44.939: CHAT3: Attempting async line dialer script

Apr 18 14:41:44.939: CHAT3: Dialing using Modem script: gsm & System script: none

Apr 18 14:41:44.943: CHAT3: process started

Apr 18 14:41:44.943: CHAT3: Asserting DTR

Apr 18 14:41:44.943: CHAT3: Chat script gsm started

Apr 18 14:41:44.943: CHAT3: Sending string: AT!SCACT=1

Apr 18 14:41:44.943: CHAT3: Expecting string: OK

Apr 18 14:41:47.999: CHAT3: Completed match for expect: OK

Apr 18 14:41:48.011: CHAT3: Chat script gsm finished, status = Success

Apr 18 14:41:50.011: %LINK-3-UPDOWN: Interface Cellular0, changed state to up

Apr 18 14:41:50.011: Ce0 DDR: Dialer statechange to up

Apr 18 14:41:50.011: Ce0 DDR: Dialer call has been placed

Apr 18 14:41:50.011: Ce0 DDR: dialer protocol up

Apr 18 14:41:51.011: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up

Router3G#



mavespig Thu, 04/19/2012 - 02:16
User Badges:
  • Silver, 250 points or more

Hi Claudio,

'test cellular 0 modem-power-cycle' will actually reset the whole card, so when the card will come back online it will still use the first SIM.

To simulate a switchover you either need to remove physically the SIM, or use the command 'cellular 0 gsm sim activate slot x'


Let me know if this works.

Marco

AndersBramsen Wed, 12/05/2012 - 06:38
User Badges:

Can I ask a question?

I have tryed to acomplish PBR, so i could choose trafic to go via other ISP...


What is the No NAT PBR for? Is that because you also have a Asa Firewall on ?

So that could maybe be why i not can make myt PBR working outside in?


BR Anders Bramsen

Amit Singh Mon, 09/02/2013 - 02:07
User Badges:
  • Cisco Employee,

Hi Caludio,


I do not see the second profile attached to the controller cellular 0.


controller Cellular 0

gsm sim profile 2 slot 1

gsm sim max-retry 65535

gsm failovertimer 1


Please configure both the profiles under the cellular 0.


Also, why you have MAX-retry that high?

Actions

This Discussion

Related Content