Apple TV with WLC

Unanswered Question
Apr 18th, 2012

Hi

We have 2 WiSMs and multiple SSIDs, and multiple AP groups so each building has it's own wireless VLAN. We use a mix of 1131s, 1142s, 1252s and 3500 series APs. The wireless VLANs are on the same chassis as the WiSM.

We are running a test with AppleTV. It connects over wireless to the same subnet/vlan as the clients and projects on to a screen in a meeting room.

If I just enable multicast in gobal mode and igmp snooping it works in the same that you get the airplay icon on the ipad, but the projector does not mirror what the ipad is doing, so something is happening but not everything.

Any ideas?

We use source specific multicast in the rest of the network and that works fine, but this is the first time we've done any multicast with wireless.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (4 ratings)
Scott Fella Wed, 04/18/2012 - 04:03

To get the mirror option, it is only supported with the iPad 2 and the iPhone 4GS. Is this what you are testing the mirror option with?

Sent from Cisco Technical Support iPhone App

Scott Fella Thu, 04/19/2012 - 04:57

I don't see how the mirror option could be affected with the wireless. If the device is able to see the Apple TV, then the wireless/network us working fine. The device decides if it will mirror or not. You will have to verify what model devices they are using.

Sent from Cisco Technical Support iPhone App

codflanglers Thu, 04/19/2012 - 06:04

I have just confirmed that the model of iphone being used is the iPhone 4S which is compatible

Scott Fella Thu, 04/19/2012 - 07:06

Try this

https://discussions.apple.com/thread/3407261?start=0&tstart=0

Thanks,

Scott Fella

Sent from my iPhone

codflanglers Thu, 04/19/2012 - 07:56

I don't think that's my problem. WIth the setup i have I can see both clients (the iphone and the appletv box) on the controller using normal multicast with the multicast group address of 224.0.0.251 (mDNS).

(WiSM) >show network multicast mgid detail 1227

Mgid........................................ 1227
Multicast Group Address..................... 224.0.0.251
Vlan........................................ XXXX
No of clients............................... 2
Client List.................................
Client MAC AP Name Expire Time (mm:ss) Multicast-Status Qos User Priority
----------------- --------------------------------- ------------------- ------------------------- ---------------
xx:xx:xx:xx:xx:xx AP/40 0:24 Normal Multicast 0

xx:xx:xx:xx:xx:xx AP/400:24 Normal Multicast 0

So I am assuming that although both clients are on the same subnet and connect to the same AP, the AP itself is on a different subnet and tunnels through to a controller, and so the bonjour service is having to cross subnets which it can't do.

All the interfaces, the controller and the network in general are set up for multicast and I even put ip forward-protocol udp 5353 but that didn't work either.

You get the icon on the iphone, but no content coming through on the apple tv (output to a projector).

Scott Fella Thu, 04/19/2012 - 08:19

I don't know what else to say... I have it working on my lab and at a few of my clients with the same setup.  That being the iDevices an Apple TV are on the same subnet.  So the issue isn't really mirroring option, its displaying the content on the Apple TV. 

codflanglers Thu, 04/19/2012 - 09:03

Just one thing, in the controller under general -- AP multicast mode, I have it set to multicast. What should I have for the multicast group address? I've just got a random multicast address, but I don't think that's right?

Scott Fella Thu, 04/19/2012 - 09:14

Should be a 239.x.x.x. Must be a unique address.

Thanks,

Scott Fella

Sent from my iPhone

codflanglers Fri, 04/20/2012 - 01:42

Thanks for the article. It looks great. I'll go through it and let you know how I get on.

codflanglers Fri, 04/20/2012 - 05:16

Right, well I've gone through the article as stated (at this stage only doing it for the single vlan for testing). I can see the interface vlan has a MGID and the appropriate 224.0.0.251 Group address but it's still not working. The tester with the iphone doesn't even see the icon now.

Thanks to all for your help so far! I'm determined to crack it and find out what's up.

codflanglers Fri, 04/20/2012 - 05:24

Quick question, the multicast address I have used under controller - general - AP multicast mode is 239.10.10.254, which shouldn't be used by anything esle. Should that be set up anywhere else? I mean how is it referenced?

Scott Fella Fri, 04/20/2012 - 05:28

It's just like an ip address... you don't want a duplicate.  So what I did, was just pick a random address in the 239.x.x.x range and put that in.  I just bought an Apple TV for my home and connected right up to my lab with no issues.  My itunes on my PC even can see the Apple TV.  I'm running v5.0 on the Apple TV.

Scott Fella Fri, 04/20/2012 - 05:32

Here is what my WLC looks like.  My Apple TV was working even with Broadcast Forwarding disabled.

Stephen Rodriguez Fri, 04/20/2012 - 06:42

The address you configure on the WLC is the multicast group that the AP will join. They learn it from the WLC when they join or on an update

Steve

Sent from Cisco Technical Support iPad App

codflanglers Thu, 04/19/2012 - 01:30

I have just confirmed that the model of iphone being used is the iPhone 4S which is compatible and I know they have been used with the mirror function successfully on the LAN. So they must be the correct versions.

Should also add that the AP connects to a layer 2 PoE switch, with it's DG on the layer 3 distribution switch above. The distribution switch connects and routes to the 6500 chassis that holds the WiSM. The AP vlan has an ip helper address to tunnel back to the controller. Pretty standard stuff.

Rob Huffman Fri, 04/20/2012 - 11:46

Hey folks,

Really interesting thread here, with some great ideas

+5 to all involved; (Scott, George, Steve & cod) for this informative

and entertaining conversation!

Cheers!

Rob

Scott Fella Fri, 04/20/2012 - 12:18

Long time no hear! How's it going Rob:)

Sent from Cisco Technical Support iPhone App

Rob Huffman Fri, 04/20/2012 - 12:36

Hey Scott,

Life is great at this end! I hope all is well with you as well

I always read the excellent stuff that all of you guys

post up here @ CSC on the Wireless side of the house just to try

and keep in the "loop" a little bit. The knowledge and willingness to share

you and the others display is pretty awesome!!

Keep on Rockin!

Cheers!

Rob

codflanglers Mon, 04/23/2012 - 02:58

Ok, I've gone through the process of removing the changed configs back to the original and I've re-created the vlans, wlans, interfaces, etc and I've set up everything again following the Cisco article exactly. Just in case I got something wrong.

Still no joy and unfortunately I don't have any hair to pull out (not bald, just got a haircut). Would the fact that we are running source specific multicast on the network rather than using rendezvous points have anything to do with it?

Scott Fella Mon, 04/23/2012 - 03:34

It shouldn't because I have used RP and not used RP in some installs, depending if my client is running multicast or not already. Do you have a lab you can use to test? Maybe it is something specific on your network.

Thanks,

Scott Fella

Sent from my iPhone

codflanglers Mon, 04/23/2012 - 03:39

I do have a lab, but sadly no spare wireless controllers so it wouldn't be a fair test. This is on the live network, but within my own building on an isolated AP, so it is a test.

I think the next stage will be to use an autonomous AP, as that should work. However, this is not an ideal solution as the real network doesn't have any fat APs.

Scott Fella Mon, 04/23/2012 - 03:43

With an IOS ap others had no issue. There were previous post stating that it worked on an autonomous ap but not when using a wlc.

Thanks,

Scott Fella

Sent from my iPhone

mali1977us Mon, 04/23/2012 - 06:46

Try the multicast IP of 239.0.0.0, I had the issue where devices were not able to see the ATV and once I changed the IP from 239.255.255.250 to 239.0.0.0 it just works without any further issues.

codflanglers Wed, 04/25/2012 - 07:51

Ok, I've had a small breakthrough in the sense that it now works using the AP multicast mode set to 'Unicast'. However, there is a bit of lag between the client and what's shown on the screen.

Of course, I don't want to use Unicast so it's not really progress. The moment I switch it back to Multicast, it stops working. I will keep tinkering though.

codflanglers Tue, 05/01/2012 - 04:17

Ok, I'm still working on this and I've shifted my attention to the wired network, as the config on the controller seems fine, I figured the multicast traffic must be being dropped on the wired network.

Set up is this 6500 with WiSM -- distribution switch -- edge switch -- AP -- Apple TV and client

This is on the 6500 chassis where the WiSM is located

6500#sh ip mroute 239.192.7.179
IP Multicast Routing Table
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.192.7.179), 00:02:29/00:00:30, RP 0.0.0.0, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

On the distribution switch (vlan 12 is the AP vlan)

distribution#sh ip mroute

(*, 239.192.7.179), 17:46:40/00:02:43, RP 0.0.0.0, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan12, Forward/Sparse, 17:46:42/00:02:40

So it looks like the 6500 chassis doesn't know where its coming from or going to

surbg Thu, 05/31/2012 - 22:37

Lemme See whats the difference while using SRE..

Please post ur configs..

sh run (from the SRE)

show run-config

Regards

Surendra

Jaaazman777 Mon, 06/04/2012 - 02:46

problem with Apple TV is solved!

we have 3 interfaces at our router

  • vlan1 - for wlan mgmt
  • vlan 50 - for wifi users
  • g0/1.40 - for LAPs

multicast was enabled only between vl1 and vlan 50

enabling multicast (ip pim dense-mode) on g0/1.40 resolved the issue

useful links

  • WLC best practice

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a0080810880.shtml#topic2

  • Multicast with Wireless LAN Controllers

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00807cc10d.shtml

saravlak Mon, 06/04/2012 - 11:02

If the issue is different from above then try below.

To isolate wireless multicast or L3 issue.

#Get rid of all L3, Bring Multicast server, WLC management interface, AP and Multicast receiver on same L2 subnet and try.

#Does the Wired client sees Multicast on the switch connected to the SRE connected router.

*Are the router connected SRE doing L2/L3 or an external device does that.

*Multicast Routing is end to end so check all applicable infrastructure.

Are you using interface group along with AP group?

Actions

Login or Register to take actions

This Discussion

Posted April 18, 2012 at 3:25 AM
Stats:
Replies:31 Avg. Rating:5
Views:3530 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard