×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Can't enable MPLS on 6509-E

Unanswered Question
Apr 18th, 2012
User Badges:

Hello,


I've got a 6509-E in the lab at the moment for some pre-deployment testing, however I don't seem to be able to enable MPLS on a select interface.


router#conf t

router(config)# interface gi1/48

router(config-if)#mpls ip

router(config)#


As you can see after I enter the "MPLS IP" command it simply backs out of interface level configuration back to global exec, and naturally the MPLS command doesn't show in configuration for that interface.


Am I missing something obvious or do I have a genuine issue?


I'm running a SUP720-3BXL with WS-X6748-GE-TX line cards with the DFC upgrade (WS-F6700-3BXL).


The IOS is: s72033-adventerprisek9_wan-mz.122-33.SXI2a.bin


Any thoughts?

Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Peter Paluch Wed, 04/18/2012 - 08:39
User Badges:
  • Cisco Employee,

Duncan,


Is the port pre-configured with no switchport and assigned an IP address?


It may be possible that the MPLS is only supported on selected line cards but I have no personal experience with 6500 boxes so this has to be taken with a grain of salt. Hopefully someone with bigger experiences joins this thread!


Best regards,

Peter

Leo Laohoo Wed, 04/18/2012 - 15:59
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Multiprotocol Label Switching (MPLS)


I've never seen that command before.  Try the link above.

Peter Paluch Thu, 04/19/2012 - 04:43
User Badges:
  • Cisco Employee,

Leo,


You mean using the tag-switching ip ? Right, that was the original command to activate MPLS and its predecessor, Tag Switching... yeah, I remember seeing that command on earlier IOSes. Most of recent IOSes have reverted to using mpls ip instead of the tag-switching ip. Thanks for pointing this out, hopefully it solves the mystery here!


Best regards,

Peter

DuncanM2008 Thu, 04/19/2012 - 05:20
User Badges:

Hello,


Many thanks for your input Peter & Leo, in the end I think this problem boiled down to a supervisor issue of some sort.


Previously when I treid to enable the command it was after I'd done some NSF/SSO testing by rebooting a supervisor, and was running from the new Active SUP (was previously standby). So possibly a dCEF sync issue of some sort, based on the fact MPLS requries an operational FIB table from CEF.


Once I cold-powered the chassis again and let everything start fresh I was able to enter the command succesfully, might be worth noting with 12.2SXI I also had to enable:


"mpls label-protocol ldp"


Seems because 12.2SXI has support of both TDP & LDP that LDP isn't default.


Once I did that the LDP session came up with the 7204 VXR running IOS 15.


Also "tag-switching ip" isn't supported on 12.2SXI, I checked this first to see if needed to run the original incarnation of MPLS / Tag Switching.


Many Thanks!

Actions

This Discussion