7940, 7960 & 7970 not upgrading firmware

Unanswered Question
Apr 18th, 2012

Hi,

We´ve recently upgraded a cluster CCM 5.1(2) over MCS-7835 servers to CCM 8.5(1) over UCS servers. Everything worked fine, but IP Phones didn't upgrade firmware. 7940/7970 are still using P00308000500, 7970 are still using SCCP70.8-2-2SR2S.

About the locale, on CCM 5.1(2) is used cm-locale-es_ES-5.1.1.1-1.cop, and on CCM 8.5(1) it uses cm-locale-es_CO-8.5.1.2100-1.cop and cm-locale-es_ES-8.5.1.2100-1.cop. The issue appears with both the locales on the CCM 8.5(1).

On CCM 8.5(1) we have tried changing device default with 8.1(1), 8.0(9) and 8.0(7) and on every case the phone registers on CCM, showing "authentication error" on screen and not upgrading.

I've downloaded a cnf file for a phone, and it informs the new firmware, for example:

<loadInformation>P00308000900</loadInformation>

On a 7970, I only see that the phones requires the ctlfile.tlv, but I've read that this is not an issue.

On a lab, previous the upgrade of the CCM, we've tested with 7940 and 7960 not property of the customer, and these phones upgraded firmware ok, but they started on a different firmware.

Any idea will be helpful.

Andres Pasten

Entel S.A.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Rob Huffman Wed, 04/18/2012 - 12:09

Hi Andres,

For the 7940/60's you are hitting this install note due to the age of your existing firmware;

Note

You cannot upgrade to firmware release 8.1(2) directly from firmware release 8.0(10) or an earlier release. You have to upgrade to firmware release 8.1(1) first, then upgrade from release 8.1(1) to release 8.1(2).

ttp://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7960g_7940g/firmware/8_1_2/english/release/notes/796040_812.html

So to rectify this issue you will need to download the 8.1(1) firmware from CCO and install it on CUCM

(upgrade phones) as your first step. This will then allow you to move to the desired 8.x(x) firmware build

For the 7970's it's the same issue due to the firmware age again;

Note

For all SCCP firmware upgrades from firmware release versions earlier than 8.3(3) to version 8.5(3) or greater, you must first upgrade your firmware to version 8.5(2). Once you have upgraded to version 8.5(2), you can upgrade your IP Phone to version 8.5(3) or later.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/8_5_3/english/release/notes/7900_853.html#wp164599

So to rectify this issue you will need to download the 8.5(2) firmware from CCO and install it on CUCM

(upgrade phones) as your first step. This will then allow you to move to the desired 9.x(x) firmware build

Cheers!

Rob

andres.pasten Wed, 04/18/2012 - 12:21

Rob,

Thanks for your sooner answer, but the 8.1(1) was the initial firmware we tried on the ccm upgrade. I've read the html that you mentioned, and downloaded the original 8.1(2) to 8.1(1) on every server of the cluster.

Then we tried with 8.0(9), and then with 8.0(6), just to check if the phone can upgrade to another version. on any case, the phones didn´t upgrade.

I'll try with the procedure for 7970, and let you know.

But the customer mostly has 7940 and 7960.

TIA

Andres Pasten

Entel S.A.

andres.pasten Wed, 04/18/2012 - 13:55

Hi Rob,

I've just tried uploading the 8.5(2) firmware for 7970, on all ccm of the cluster, then restart tftp service on all ccm of the cluster, and the issue persists. The 7970 phones are still on the original firmware.

Any idea of what should be happening?

TIA

Andres Pasten

Entel S.A.



Actions

Login or Register to take actions

This Discussion

Posted April 18, 2012 at 11:23 AM
Stats:
Replies:3 Avg. Rating:
Views:908 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,051
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
116
105
103
76
72