i cannot access to internet from asa behind router

Answered Question
Apr 21st, 2012

hello

this is senaro

  exchange server 2010    on  lan------------ asa--------------------------- cisco router ----------------internet 

i cannot access to internet on lan after install cisco asa

this is configration for router and asa

please help in missing configration or wrong command

router


router#sh           
router#show run                 
router#show running-config                            
Building configuration...                        

Current configuration : 6218 bytes                                 
!
version 15.0           
service timestamps debug datetime msec                                     
service timestamps log datetime msec                                   
no service password-encryption                             
!
hostname router                 
!
boot-start-marker                
boot-end-marker              
!
logging buffered 51200 warnings                              
!
no aaa new-model               
!
no ipv6 cef          
ip source-route              
ip cef     
!
!
!
ip dhcp pool Internet                    
   network 192.168.193.0 255.255.255.0                                     
   default-router 192.168.193.2                              
   dns-server 84.235.6.55 84.235.57.230                                      
   lease infinite                
!
!
ip domain name saudi.net.sa                          
ip name-server 84.235.6.55                         
ip name-server 84.235.57.230                           
multilink bundle-name authenticated                                  
!
!
!
crypto pki trustpoint TP-s                        
enrollment selfsigned                     
subject-name cn=IOS-Self-Signed-Certificate-4038588294                                                      
revocation-check none                     
rsakeypair TP-self-signed-4038588294                                    
!
!
crypto pki certificate chain TP-self-signed-4038588294                                                     
certificate self-signed 01                          
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030                                                                        
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274                                                                        
  69666963 6174652D 34303338 35383832 3934301E 170D3131 30393037 31303535                                                                        
  34315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 0313                                                                  
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30333835                                                                        
  38383239 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281                                                                        
  8100B026 8B479786 27010FB7 C47A39BB 3563AFD5 437FFB78 C1F1456A 82691CC9                                                                        
  CE3B4F97 B1D62C35 9E8AF0D1 3BF4B6C2 164705D5 1A41E85E 99B82F97 0E2BB08D                                                                        
  334A5172 ACDC16D6 66B1F2FF 8D579642 F15F4560 3E064E40 5FE83AA8 C6363E06                                                                        
  7A37355A CBBC2A81 A3786FEA 7125DA64 B74E7082 20834C8A EA81A2B7 32EC1048                                                                        
  7D0B0203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 302106                                                                     
  551D1104 1A301882 164E616A 72616E4D 4F492E73 61756469 2E6E6574 2E736130                                                                        
  1F060355 1D230418 30168014 4E6C9815 D28A155B 0D8CB718 CCE74CE2 58D68621                                                                        
  301D0603 551D0E04 1604144E 6C9815D2 8A155B0D 8CB718CC E74CE258 D6862130                                                                        
  0D06092A 864886F7 0D010104 05000381 8100540A 521F52E2 F16C92CE E3A457E8                                                                        
  872D998E E702075A 8383D506 EC9A3207 36C1351F BA3A0676 1491D6C8 33C35B54                                                                        
  B733FC86 78B0B7A9 AB4DFB5D 7F495B94 62945799 724CF137 2D5CF0BB 629DBBD2                                                                        
  CCD13350 FED2676B 994983CD 85CAA52E 9CC7A08F 3F8DBBF8 EB6641FF 39D765                                                                     
  2B1A0051 3BCDFA32 DF12A97D 6641B29D 78BA                                         
        quit           
license udi pid C3900-SPE100/K9 sn FOC15074HMG                                             
!
!
username cisco privilege 15 secret 5 $1$bBcM$DG8ZzlbJPMbKIGwsswNSN1                                                                  
!
!
!
!
!
!
interface GigabitEthernet0/0                           
description NJRNJNAD-RYAD16_34 DIA1                                   
no ip address             
ip virtual-reassembly                     
duplex full           
speed auto          
no keepalive            
!
interface GigabitEthernet0/0.3130                                
description NJRNJNAD-RYAD16_34 DIA1                                   
encapsulation dot1Q 3130                        
ip address 84.235.40.97 255.255.255.252                                       
ip nat outside              
ip virtual-reassembly                     
!
interface Gigab            
description "Connection to internal LAN"                                        
ip address 192.168.193.2 255.255.255.0                                      
ip nat inside             
ip virtual-reassembly                     
duplex full           
speed auto          
media-type rj45               
no keepalive            
no cdp enable             
!
interface GigabitEthernet0/2                           
no ip address             
shutdown        
duplex auto           
speed auto          
!
no ip forward-protocol nd                        
!
ip http server             
ip http access-class 23                      
ip http authentication local                           
ip http secure-server                    
ip http timeout-policy idle 60 life 86400 requests 10000                                                       
!
ip nat pool smtp_nat 84.235.81.50 84.235.81.50 netmask 255.255.255.248                                                                     
ip nat inside source list 101 interface GigabitEthernet0/0.3130 overload                                                                       
ip nat inside source list 102 pool smtp_nat overload                                                   
ip nat inside source static tcp 192.168.193.3 25 84.235.81.50 25 extendable                                                                          
ip nat inside source static tcp 192.168.193.3 80 84.235.81.50 80 extendable                                                                          
ip nat inside source static tcp 192.168.193.3 443 84.235.81.50 443 extendable                                                                            
ip nat inside source static tcp 192.168.193.3 587 84.235.81.50 587 extendable                                                                            
ip route 0.0.0.0 0.0.0.0 84.235.40.98                                    
ip route 10.64.0.0 255.255.0.0 192.168.193.3                                         
!
access-list 23 permit 10.10.10.0 0.0.0.7                                       
access-list 101 deny   tcp host 192.168.193.3 any eq smtp                                                        
access-list 101 deny   tcp host 192.168.193.3 any eq 587                                                       
access-list 101 permit ip 192.0.0.0 0.255.255.255 any                                                    
access-list 102 permit tcp host 192.168.193.3 any eq smtp                                                        
access-list 102 permit tcp host 192.168.193.3 any eq 587                                                       
access-list 102 deny   ip any any                                
!
!
!
control-plane            
!
banner exec ^C             
% Password expiration warning.                             
-----------------------------------------------------------------------                                                                      

Cisco Configuration Professional (Cisco CP) is installed on this device                                                                      
and it provides the default username "cisco" for  one-time use. If you have                                                                          
already used the username "cisco" to login to the router and your IOS image                                                                          
supports the "one-time" user option, then this username has already expired.                                                                           
You will not be able to login to the router with this username after you exit                                                                            
this session.            

It is strongly suggested that you create a new username with a privilege level                                                                             
of 15 using the following command.                                 

username <myuser> privilege 15 secret 0 <mypassword>                                                   

Replace <myuser> and <mypassword> with the username and password you want to                                                                           
use.   

-----------------------------------------------------------------------                                                                      
^C 
banner login ^C              
-----------------------------------------------------------------------                                                                      
Cisco Configuration Professional (Cisco CP) is installed on this device.                                                                       
This feature requires the one-time use of the username "cisco" with the                                                                      
password "cisco". These default credentials have a privilege level of 15.                                                                      

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN                                                                         
CREDENTIALS          

Here are the Cisco IOS commands.                               

username <myuser>  privilege 15 secret 0 <mypassword>                                                    
no username cisco                

Replace <myuser> and <mypassword> with the username and password you want                                                                        
to use.      

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE                                                                        
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.                                                      

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
password cisco
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

router#

cisco asa firewall

:

Saved

:

Written by enable_15 at 02:02:15.239 UTC Wed Apr 18 2012

:

Call-home enabled from prompt by enable_15 at 00:42:06 UTC Apr 18 2012

!

ASA Version 8.2(5

)

!

hostname fwcicso

domain-name server

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.193.3 outside description nat

!

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address outside 255.255.255.0

!

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 192.168.191.1 255.255.255.0

!

interface GigabitEthernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

boot system disk0:/asa825-k8.bin

ftp mode passive

dns server-group DefaultDNS

name-server 4.4.4.4

domain-name server

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

object-group service DM_INLINE_SERVICE_1

service-object icmp echo-reply

service-object tcp eq echo

service-object tcp eq www

service-object tcp eq https

service-object tcp eq smtp

object-group service DM_INLINE_TCP_1 tcp

port-object eq www

port-object eq https

port-object eq smtp

object-group service DM_INLINE_SERVICE_2

service-object icmp echo

service-object icmp echo-reply

service-object tcp eq www

service-object tcp eq https

service-object tcp eq smtp

ccess-list OUTSIDE extended permit ip any any

access-group OUTSIDE in interface outside

access-list INSIDE_nat0_outbound extended permit ip any any

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 192.168.191.0 255.255.255.0 192.168.193.0 255.255.255.0

access-list inside_access_in extended permit ip 192.168.191.0 255.255.255.0 192.168.193.0 255.255.255.0

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_2 any host outside

access-list outside_access_in extended permit tcp any 192.168.191.0 255.255.255.0 object-group DM_INLINE_TCP_1

access-list no-nat standard permit any

pager lines 24

logging asdm informational

mtu management 1500

mtu inside 1500

mtu outside 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm location outside 255.255.255.255 inside

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 192.168.191.0 255.255.255.0 dns

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 outside 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

308205

ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

0

d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

30150603 55040

a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

13165665 72695369 676

e2054 72757374 204e6574 776f726b 313a3038 06035504

0

b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

20617574 686

f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

65726953 69676

e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

65727469 66696361 74696

f6e 20417574 686f7269 7479202d 20473530 1e170d31

30303230 38303030 3030305

a 170d3230 30323037 32333539 35395a30 81b5310b

30090603 55040613 02555331 17301506 0355040

a 130e5665 72695369 676e2c20

496

e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

74776

f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

68747470 733

a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

3130312

f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

63757265 20536572 76657220 4341202

d 20473330 82012230 0d06092a 864886f7

0

d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

9

c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

7

f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

15

fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

63

cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

18

b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

4

a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

81

f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

7474703

a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

45010717 03305630 2806082

b 06010505 07020116 1c687474 70733a2f 2f777777

2

e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

1

c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

03551

d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

69676

e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

02010630 6

d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

6

d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

69676

e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

1

b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

551

d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

1

d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

2

a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

4

bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

6

decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

481

d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

5

becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

6119

b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

6

c2527b9 deb78458 c61f381e a4c4cb66

quit

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username ciscox password wjo38N3qjbkMNQ/7 encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum client auto

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

inspect ip-options

inspect icmp

inspect icmp error

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

Cryptochecksum:d208bf91538cd8ff97172fddc766f5f2

:

end

I have this problem too.
0 votes
Correct Answer by imramoha about 2 years 3 days ago

Hello,

Here is the snapshot of the configuration

on router

ip nat inside source list 101 interface GigabitEthernet0/0.3130 overload

ip nat inside source list 102 pool smtp_nat overload

access-list 101 deny tcp host 192.168.193.3 any eq smtp

access-list 101 deny tcp host 192.168.193.3 any eq 587

access-list 101 permit ip 192.0.0.0 0.255.255.255 any

access-list 102 permit tcp host 192.168.193.3 any eq smtp

access-list 102 permit tcp host 192.168.193.3 any eq 587

access-list 102 deny ip any any

name 192.168.193.3 outside description nat

on ASA

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address outside 255.255.255.0

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 192.168.191.1 255.255.255.0

I also this route on ASA

route outside 0.0.0.0 0.0.0.0 outside ( can you change the ip from outside

to routers ip address)

Thanks & Regards

Mohammed Imran

Customer Support Engineer - Security

Phone: +44 20 3527 4027

Email:imramoha@cisco.com

Central European Time(BRU) :- 07:30 to 16:30 hrs CE(s)T/GMT1(2)

Eastern Daylight Time(US/CAN) :- 01:30 to 10.30 hrs EDT/ GMT -4

Pacific Daylight Time (US/CAN):- 22:30to 07:30 hrs PDT/ GMT -7

Working Days- Mon-Fri

EMEA Technical Assistance Center hotline: +32 2 704 5555

Technical Support Worldwide contacts:

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

***

For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
joseph.steve Sat, 04/21/2012 - 02:39

Can you re-paste your ASA configuration

From Internet Router try to ping 4.2.2.2 with source interface of having public IP also

ping 4.2.2.2 from ASA  and paste the result

cheers

CSCO11825412 Sat, 04/21/2012 - 02:45

thanks for replay me

: Saved

: Written by enable_15 at 02:02:15.239 UTC Wed Apr 18 2012

: Call-home enabled from prompt by enable_15 at 00:42:06 UTC Apr 18 2012

!

ASA Version 8.2(5)

!

hostname fwcicso

domain-name server

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.193.3 outside description nat

!

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address outside 255.255.255.0

!

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 192.168.191.1 255.255.255.0

!

interface GigabitEthernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

boot system disk0:/asa825-k8.bin

ftp mode passive

dns server-group DefaultDNS

name-server 4.4.4.4

domain-name server

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

object-group service DM_INLINE_SERVICE_1

service-object icmp echo-reply

service-object tcp eq echo

service-object tcp eq www

service-object tcp eq https

service-object tcp eq smtp

object-group service DM_INLINE_TCP_1 tcp

port-object eq www

port-object eq https

port-object eq smtp

object-group service DM_INLINE_SERVICE_2

service-object icmp echo

service-object icmp echo-reply

service-object tcp eq www

service-object tcp eq https

service-object tcp eq smtp

access-list INSIDE_nat0_outbound extended permit ip any any

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 192.168.191.0 255.255.255.0 192.168.193.0 255.255.255.0

access-list inside_access_in extended permit ip 192.168.191.0 255.255.255.0 192.168.193.0 255.255.255.0

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_2 any host outside

access-list outside_access_in extended permit tcp any 192.168.191.0 255.255.255.0 object-group DM_INLINE_TCP_1

access-list no-nat standard permit any

pager lines 24

logging asdm informational

mtu management 1500

mtu inside 1500

mtu outside 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm location outside 255.255.255.255 inside

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 192.168.191.0 255.255.255.0 dns

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 outside 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username ciscox password wjo38N3qjbkMNQ/7 encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

  inspect icmp error

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

Cryptochecksum:d208bf91538cd8ff97172fddc766f5f2

: end

CSCO11825412 Sat, 04/21/2012 - 02:48

i can ping 4.4.4.4 from asa

and from lan

i can also  ping 192.168.193.2 this inside interface in cisco router  from lan

Correct Answer
imramoha Sat, 04/21/2012 - 02:48

Hello,

Here is the snapshot of the configuration

on router

ip nat inside source list 101 interface GigabitEthernet0/0.3130 overload

ip nat inside source list 102 pool smtp_nat overload

access-list 101 deny tcp host 192.168.193.3 any eq smtp

access-list 101 deny tcp host 192.168.193.3 any eq 587

access-list 101 permit ip 192.0.0.0 0.255.255.255 any

access-list 102 permit tcp host 192.168.193.3 any eq smtp

access-list 102 permit tcp host 192.168.193.3 any eq 587

access-list 102 deny ip any any

name 192.168.193.3 outside description nat

on ASA

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address outside 255.255.255.0

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 192.168.191.1 255.255.255.0

I also this route on ASA

route outside 0.0.0.0 0.0.0.0 outside ( can you change the ip from outside

to routers ip address)

Thanks & Regards

Mohammed Imran

Customer Support Engineer - Security

Phone: +44 20 3527 4027

Email:imramoha@cisco.com

Central European Time(BRU) :- 07:30 to 16:30 hrs CE(s)T/GMT1(2)

Eastern Daylight Time(US/CAN) :- 01:30 to 10.30 hrs EDT/ GMT -4

Pacific Daylight Time (US/CAN):- 22:30to 07:30 hrs PDT/ GMT -7

Working Days- Mon-Fri

EMEA Technical Assistance Center hotline: +32 2 704 5555

Technical Support Worldwide contacts:

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

***

For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

CSCO11825412 Sat, 04/21/2012 - 02:54

thanks mr imran for replay

u mean i change configration on asa

route outside 0.0.0.0 0.0.0.0 outside ( can you change the ip from outside

to routers ip address this ip 192.168.193.2 or outside ip 84.xx.xx.xx

and i do it already

do u mean also i dont need to configure acl or nat on asa

wait ur replay

imramoha Sat, 04/21/2012 - 03:04

Can you confirm how are the interfaces connected? In you topology

The router configuration is not clear

interface GigabitEthernet0/0.3130

description NJRNJNAD-RYAD16_34 DIA1

encapsulation dot1Q 3130

ip address 84.235.40.97 255.255.255.252

ip nat outside

ip virtual-reassembly

!

interface Gigab

description "Connection to internal LAN"

ip address 192.168.193.2 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex full

speed auto

media-type rj45

no keepalive

no cdp enable

Thanks & Regards

Mohammed Imran

imramoha Sat, 04/21/2012 - 03:46

The route which I have mention shouldn't be a problem

Can you try the below commands and send me the output

access-list cap per icmp any h 4.2.2.2

access-list cap per icmp h 4.2.2.2 any

capture cpi access-list cap int outside

capture cpo access-list cap int inside

do a ping from the lan to 4.2.2.2

take the output

sh cap cpi

sh cap cpo

Note : make sure you have ICMP ACL enable on inside and outside interface or

configure inspect icmp in global policy.

Thanks & Regards

Mohammed Imran

Customer Support Engineer - Security

Phone: +44 20 3527 4027

Email:imramoha@cisco.com

Central European Time(BRU) :- 07:30 to 16:30 hrs CE(s)T/GMT1(2)

Eastern Daylight Time(US/CAN) :- 01:30 to 10.30 hrs EDT/ GMT -4

Pacific Daylight Time (US/CAN):- 22:30to 07:30 hrs PDT/ GMT -7

Working Days- Mon-Fri

EMEA Technical Assistance Center hotline: +32 2 704 5555

Technical Support Worldwide contacts:

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

***

For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

CSCO11825412 Sat, 04/21/2012 - 08:41

i cannot ping also requset time out from lan

can u paste fully configration for asa and router if missing config please

best regards

Actions

Login or Register to take actions

This Discussion

Posted April 21, 2012 at 2:03 AM
Stats:
Replies:8 Avg. Rating:5
Views:449 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 7,866
2 6,140
3 3,170
4 1,473
5 1,446