1941W Wireless config

Unanswered Question
Apr 23rd, 2012

I just purchased a 1941w router to see if we want to use this to replace our existing routers and external access points. At each of our locations we have 1  subnet that has a server, AP, router, switch, etc.

I would like to configure the AP and the router in the 1941w in the same subnet but cannot figure out how to do this. If I setup the wlan-ap0 interface with an IP in the subnet I am using it will not let me assign an IP from that same subnet to any of the ethernet interfaces. It says they overlap.

No matter what I do I cant seem to use the same IP on both. I could if I purchased a 1941 without wireless and then purchased an aironet so why cant I do it when they are in the same box?

I'm not a cisco expert so I assume I'm just not doing something right. Any help appreciated.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
h.grankvist Mon, 04/23/2012 - 14:39

You need to configure a bridged interface that is linked to your ethernet-interface and your wlan-ap0-interface. On the bridged-interface you set the IP-address. Search on cisco's website to set it up.

denstjames Tue, 04/24/2012 - 05:35

Thank you for the reply but when I try to bridge the wlan-ap0 interfae it says it does not support bridging. This is the command I used:

bridge-group 1

This isthe output I get

wlan-ap0 does not support bridging

Any other ideas?

jos.moonen Sat, 06/02/2012 - 01:29

You need to create a vlan en BVI interface in you're config

!

ip dhcp pool LAN-WiFi

import all

network 192.168.0.0 255.255.255.0

dns-server 194.109.6.66 194.109.9.99

default-router 192.168.0.1

domain-name WORKGROUP

lease 7

!

.....

!

interface wlan-ap0

ip unnumbered BVI1

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

no cdp enable

bridge-group 1

hold-queue 100 out

!

interface Vlan1

no ip address

bridge-group 1

!

interface BVI1

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

!

and do not forget

bridge 1 protocol ieee
bridge 1 route ip

in you're AP config you can set both ( 2.4 and 5Ghz ) to the vlan1

now the LAN and WLAN have the same IP range.

Actions

Login or Register to take actions

This Discussion

Posted April 23, 2012 at 10:38 AM
Stats:
Replies:4 Avg. Rating:
Views:794 Votes:0
Shares:0
Tags: wireless, 1941w, 1941
+

Related Content

Discussions Leaderboard

Rank Username Points
1 14,997
2 8,150
3 7,720
4 7,078
5 6,723
Rank Username Points
175
80
60
59
55