×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 1941W really basic configuration

Unanswered Question
Apr 23rd, 2012
User Badges:

Ok, I am replacing a cisco linksys router with a 1941w.


I have the 0/0 accepting a DHCP from the ISP then I have 0/1 going to a switch and hosting a dhcp server.


Where I have an issue is:


A) Finding a way to turn on the wireless and make it use the same DHCP as wired and setting up a user name/wep password


B) Turning on the GUI that is supposed to be embedded on this.


C) Finding a way to make the DNS point to the default gateway so that I don't have to set the address everytime we move the box.


Here is my current configuration, and with it I can get onto the wired network and get to the internet.


Current configuration : 4712 bytes

!

! No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname GWwireless

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 5 $1$rM0I$vA2.k0k2KgEXgCsfwTPnA/

!

no aaa new-model

!

memory-size iomem 10

clock timezone CST -5 0

service-module wlan-ap 0 bootimage autonomous

!

no ipv6 cef

ipv6 spd queue min-threshold 30

ipv6 spd queue max-threshold 31

ip source-route

no ip icmp rate-limit unreachable

no ip icmp rate-limit unreachable DF

ip cef

!

!

!

ip dhcp excluded-address 192.168.0.1 192.168.0.21

!

ip dhcp pool DHCP_POOL

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 192.168.254.254

domain-name ciscolab.local

!

!

ip domain name yourdomain.com

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2933970575

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2933970575

revocation-check none

rsakeypair TP-self-signed-2933970575

!

!

crypto pki certificate chain TP-self-signed-2933970575

certificate self-signed 01

license udi pid CISCO1941W-A/K9 sn FTX161281R7

hw-module ism 0

!

!

!

username admin privilege 15 secret 5 $1$DGu6$CVE6S3f5GVoy6JED4kzAx/

username wind privilege 15 password 0 cisco

username goldwind privilege 15 secret 5 $1$aOqP$9oyOrr8ROP8pJ35tP0vAB1

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered GigabitEthernet0/0

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/1

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

hold-queue 32 in

!

interface Wlan-GigabitEthernet0/0

description Internal switch

no ip address

!

interface Vlan1

ip address 10.1.1.1 255.240.0.0

ip virtual-reassembly in

!

interface Vlan20

ip address 172.16.20.1 255.240.0.0

ip virtual-reassembly in

!

interface Vlan21

no ip address

ip virtual-reassembly in

!

ip forward-protocol nd

!

no ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

ip nat inside source list 10 interface GigabitEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 0.0.0.0 0.0.0.0 192.168.254.254 254

ip route 0.0.0.0 0.0.0.0 192.168.254.254 254

!

access-list 1 permit 10.0.0.0 0.15.255.255

access-list 10 permit 192.168.0.0 0.0.0.255

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

!

!

!

!

control-plane

!

!

banner exec ^CC

% Password expiration warning.

-------e username and password you want to

use.


--------------------------------OWN

CREDENTIALS


Here are the Cisco IOS commands.


username <myuser>  priv

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.


YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS


Here are the Cisco IOS commands.


username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco


Replace <myuser> and <mypassword> with the username and password you want

to use.


IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.


For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

exec-timeout 30 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 67

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

access-class 23 in

exec-timeout 30 0

privilege level 15

password test3

login

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Stephen Rodriguez Tue, 04/24/2012 - 14:36
User Badges:
  • Purple, 4500 points or more

In order to configure the AP module you need to first do a session into the WLAN-AP0 service module.


Once you get into that the Ap should pull an address in VLAN 1, which the gig interface belong to by default.


From then, you should be able to hit the web page using the address the module pulls.


Steve


Sent from Cisco Technical Support iPhone App

tigers692 Wed, 04/25/2012 - 20:54
User Badges:

I am not too sure how to do that, I've never configured a wireless cisco router. what do I enter on my terminal service?


Thanks

Stephen Rodriguez Thu, 04/26/2012 - 08:36
User Badges:
  • Purple, 4500 points or more

from the router it should be service-module wlan-ap0 session.


Steve

andrewokri Thu, 05/31/2012 - 04:18
User Badges:

I have just cracked open a brand new 1941 box. For reason unknown to me, it has arrived without any manuals or CD or instruction on how to configure this device. This is the 1st time to use this device or any device from Cisco. I find myself in exactly the same position as the author of this thread. I have also found the answers given to his question to be unclear and has not helped me undersatnd how to get started. Please would anyone be willing to give us a dummy's guide to getting started with the 1941. What are the ways to interface with this device to configure it from a laptop? Or any other way for that matter? Thank you in advance. 

tigers692 Thu, 05/31/2012 - 07:47
User Badges:

I find it very odd that no seems to be able to help, if you purchase an inexpensive linksys router it has an easy to use embedded web interface. With this you have to use a cisco console cable that doesn't come with the unit and use hyperterminal. Seems overly complicated, but I am trying to do a very simple task and can't even get help.

andrewokri Thu, 05/31/2012 - 08:05
User Badges:

This is what l have discovered so far:-

1. Getting a connection to the Router see

http://www.cisco.com/en/US/docs/routers/access/1900/hardware/installation/guide/19cable.html#wp1057624


2. Configuring the router, check out this thread for tips:-

https://supportforums.cisco.com/thread/2028286?tstart=0#3123587


I shall update further as l get along.




Configuring Hostname and Password

http://www.cisco.com/en/US/docs/wireless/mwr_1941/software_configuration/current_scg/DCNcfg.html?referring_site=smartnavRD#wp1096124



This link contains info for configuring the ethernet port GE 0/0 and GE0/1 also.


3. Configuring Wireless LAN

http://www.cisco.com/en/US/docs/routers/access/1900/software/configuration/guide/wlan.html

Actions

This Discussion

Related Content