eBGP using admin distance 200?

Answered Question
Apr 25th, 2012

Hi,

#sh ip protocols | begin bgp

Routing Protocol is "bgp 65005"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  IGP synchronization is disabled

  Automatic route summarization is disabled

  Neighbor(s):

    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap

    15.15.12.5                                          LOCAL_PREF

    15.15.13.5                                          LOCAL_PREF

    10.24.35.12                                       

  Maximum path: 1

  Routing Information Sources:

    Gateway         Distance      Last Update

    15.15.12.5          20           3d07h

   15.15.13.5         200          3d08h                                            <<<<<<<<<<<<<why is the admin distance 200? This is my ebgp peer?

    10.24.35.12        200          3d07h

  Distance: external 20 internal 200 local 200

#sh ip bgp summary | begin Neighbor

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

15.15.12.5    4          152 1835547 1963240     5854    0    0 45w3d          39

15.15.13.5    4          152   28627   30410     5854    0    0 4d22h          39 <<<<<<<<<<<<<<<<<<<<<<ebgp

10.24.35.12    4        65005  662657  662384     5854    0    0 1y7w           48

router bgp 65005

neighbor 15.15.13.5 remote-as 152 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<ebgp

So why am I getting eBGP distance 200 for 15.15.13.5 when I use #sh ip protocols | begin bgp????

I have this problem too.
0 votes
Correct Answer by John Blakley about 1 year 11 months ago

Can you post these policy maps?

LOCAL_PREF

And can you post (masking public addresses) the bgp config?

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
kunal-united Wed, 04/25/2012 - 06:50

  here you go

#sh ip bgp neighbors 15.15.13.5

BGP neighbor is 15.15.13.5,  remote AS 152, external link

Description: Telus MPLS Secondary Peer

  BGP version 4, remote router ID 24.25.24.181

  BGP state = Established, up for 4d22h

  Last read 00:00:00, last write 00:00:10, hold time is 45, keepalive interval is 15 seconds

  Configured hold time is 45, keepalive interval is 15 seconds

  Minimum holdtime from neighbor is 0 seconds

  Neighbor sessions:

    1 active, is not multisession capable

  Neighbor capabilities:

    Route refresh: advertised and received(new)

    Four-octets ASN Capability: advertised

    Address family IPv4 Unicast: advertised and received

    Multisession Capability: advertised

  Message statistics:

    InQ depth is 0

    OutQ depth is 0

                         Sent       Rcvd

    Opens:                  1          1

    Notifications:          0          0

    Updates:               49        248

    Keepalives:         30417      28438

    Route Refresh:          7          0

    Total:              30474      28687

  Default minimum time between advertisement runs is 30 seconds

For address family: IPv4 Unicast

  Session: 15.15.13.5

  BGP table version 5854, neighbor version 5854/0

  Output queue size : 0

  Index 6

  6 update-group member

  Inbound path policy configured

  Incoming update prefix filter list is ACCEPTED_NETS

  Outgoing update prefix filter list is ADVERTIZED_NETS

  Route map for incoming advertisements is LOCAL_PREF

                                 Sent       Rcvd

  Prefix activity:               ----       ----

    Prefixes Current:               4         39 (Consumes 2028 bytes)

    Prefixes Total:                27        322

    Implicit Withdraw:             22        276

    Explicit Withdraw:              0          7

    Used as bestpath:             n/a          0

    Used as multipath:            n/a          0

                                   Outbound    Inbound

  Local Policy Denied Prefixes:    --------    -------

    prefix-list                         273        178

    Bestpath from this peer:              3        n/a

    Invalid Path:                         8        n/a

    Total:                              284        178

  Number of NLRIs in the update sent: max 10, min 0

  Address tracking is enabled, the RIB does have a route to 15.15.13.5

  Connections established 2; dropped 1

  Last reset 4d22h, due to BGP Notification received of session 1, hold time expired

  Transport(tcp) path-mtu-discovery is enabled

  Graceful-Restart is disabled

Connection state is ESTAB, I/O status: 1, unread input bytes: 0           

Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1

Local host: 15.15.13.6, Local port: 61462

Foreign host: 15.15.13.5, Foreign port: 179

Connection tableid (VRF): 0

Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x8607CA760):

Timer          Starts    Wakeups            Next

Retrans         30478         43             0x0

TimeWait            0          0             0x0

AckHold         28514      27740             0x0

SendWnd             0          0             0x0

KeepAlive           0          0             0x0

GiveUp              0          0             0x0

PmtuAger            1          1             0x0

DeadWait            0          0             0x0

Linger              0          0             0x0

ProcessQ            0          0             0x0

iss: 2947749338  snduna: 2948329445  sndnxt: 2948329445     sndwnd:  15339

irs:   56652898  rcvnxt:   57208441  rcvwnd:      15814  delrcvwnd:    570

SRTT: 300 ms, RTTO: 303 ms, RTV: 3 ms, KRTT: 0 ms

minRTT: 0 ms, maxRTT: 340 ms, ACK hold: 200 ms

Status Flags: active open

Option Flags: nagle, path mtu capable, md5

IP Precedence value : 6

Datagrams (max data segment is 1440 bytes):

Rcvd: 58571 (out of order: 0), with data: 28520, total data bytes: 555542

Sent: 58561 (retransmit: 43, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 30436, total data bytes: 580106

Packets received in fast path: 0, fast processed: 0, slow path: 0

fast lock acquisition failures: 0, slow path: 0

Correct Answer
John Blakley Wed, 04/25/2012 - 07:04

Can you post these policy maps?

LOCAL_PREF

And can you post (masking public addresses) the bgp config?

kunal-united Wed, 04/25/2012 - 07:16

router bgp 65005

no synchronization

bgp log-neighbor-changes

neighbor 15.15.12.xxx5 remote-as 152

neighbor 15.15.12.xxx5 timers 15 45

neighbor 15.15.12.xxx5 prefix-list ACCEPTED_NETS in

neighbor 15.15.12.xxx5 route-map LOCAL_PREF in

neighbor 15.15.13.xxx5 remote-as 152

neighbor 15.15.13.xxx5 timers 15 45

neighbor 15.15.13.xxx5 prefix-list ACCEPTED_NETS in

neighbor 15.15.13.xxx5 route-map LOCAL_PREF in

neighbor 10.24.35.12 remote-as 65005

neighbor 10.24.35.12 next-hop-self

no auto-summary

#sh route-map

route-map LOCAL_PREF, permit, sequence 10

  Match clauses:

  Set clauses:

    local-preference 80

  Policy routing matches: 0 packets, 0 bytes

route-map LOCAL_PREF, permit, sequence 20

  Match clauses:

  Set clauses:

  Policy routing matches: 0 packets, 0 bytes

The public ip's and AS# are all false.

John Blakley Wed, 04/25/2012 - 07:21

I don't see anything that jumps out as the reason that you're getting that. It's treating this neighbor as iBGP it seems (AD-wise anyway). Can you post "sh ip bgp "?

So if the route 192.168.1.0 goes through this neighbor, post "sh ip bgp 192.168.1.0" and "sh ip bgp regex ^152"

John Blakley Wed, 04/25/2012 - 07:34

No that's locally generated. They can change the metric that you receive though.

kunal-united Wed, 04/25/2012 - 07:39

Could it be that the ISP is using "BGP backdoor"?

If I dont have anything in my configuration then it looks like the ISP is doing something?

Please advise.

John Blakley Wed, 04/25/2012 - 07:45

A backdoor allows a route from another routing protocol with a higher distance to be used instead of the lower AD from eBGP. In other words, it allows say EIGRP learned route of 192.168.1.0/24 and eBGP learned route of 192.168.1.0/24 to use the EIGRP learned route instead of the eBGP learned one.

Can you post "sh ip bgp "?

So if the route 192.168.1.0 goes through this neighbor, post "sh ip bgp 192.168.1.0" and "sh ip bgp regex ^152"

kunal-united Wed, 04/25/2012 - 07:46

Hi,

I got it ....It is actually the ISP set it on their side and I am seeing it.

It is not what I set ...I still treat it as 20.

Thanks for looking into it

Actions

Login or Register to take actions

This Discussion

Posted April 25, 2012 at 6:37 AM
Stats:
Replies:10 Avg. Rating:5
Views:360 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard