Apple-TV (airplay) on WLC 5508

Unanswered Question
Apr 25th, 2012

hello, we have a working wireless network managed by a 5508 WLC and nearly a hundred AP in different buildings. We want to integrate several apple-tv in different WLAN. We enable global multicast mode and igmp snooping on the WLC. When clients connect to these wlan airplay functionnality operates for 2 or 3 minutes max and after the airplay icon disappears on iDevices. If i want airplay to work again i need to reboot the Apple-TV but again it can't work for more than 2-3 minutes. Any ideas why it doesn't work

Sent from Cisco Technical Support iPhone App

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Scott Fella Wed, 04/25/2012 - 14:59

Try enabling broadcast forwarding. Others had good luck using that.

Thanks,

Scott Fella

Sent from my iPhone

denverelway Thu, 04/26/2012 - 05:50

unfortunately it's not working here

Sent from Cisco Technical Support iPhone App

dmilam@clhnt.com Wed, 04/17/2013 - 07:41

Bernard were you ever able to get this to function properly.  We are running into the same issue.

Manannalage ras... Wed, 04/17/2013 - 13:34

Hi

What is the WLC code you are running this on ? ( I Assume it is on 7.4.100.0) Here is the deployment guide of mDNS for this software code

http://www.cisco.com/en/US/docs/wireless/technology/bonjour/Bonjour_DG_Guide.pdf

"AirTunes" services also need to be added under mDNS service list in order to AppleTV to work properly for latest IOS (6.0.x) devices. If it is not correctly configured you cannot see AirPlay icon at all.

I have trialed this AppleTV keeping it on a wired network & did not have this sort of issue. worth trialing this if that suits your environment. Here is quick overview of my deployment.

http://mrncciew.com/2013/03/27/configuring-mdns-on-wlc-7-4/

HTH

Rasika

dmilam@clhnt.com Wed, 04/17/2013 - 13:50

We are at version 7.3

We had to downgrade the WLC from 7.4.100 because of a problem with 1142n access points locking up.  Do I have to be at version 7.4.100?

Manannalage ras... Wed, 04/17/2013 - 14:01

I think you can still run this on 7.3 & then you have to refer the 7.3 configuration guide. But in 7.4 Cisco added full Bonrjour gateway functionality onto WLC & mDNS deployment is really straigt forward.

About 1142 AP issue (I hope you refer to CSCud97983 -http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?caller=pluginredirector&method=fetchBugDetails&bugId=CSCud97983), I think cisco said it is fixed on 7.4.100.1 code which I am trying to upgrade (from 7.4.100.0) since I am facing that issue in this AP model in my environment. In my environment manjority APs are 3602 which does not have this issue.

HTH

Rasika

dmilam@clhnt.com Thu, 04/18/2013 - 05:32

Yes that is the bug

Glad to here they may a fix for this bug I will give the code a try then use your config instructions to give it a try.

Thank you for your help

Scott Fella Thu, 04/18/2013 - 05:42

If your current deployment is with 7.3 and your Apple TV and iPads are on the same subnet, you need to make sure you have multicast also enabled on the subnet that the AP's are on and also on the WLC subnet. This has worked well for me in the past. v7.4 still has some issue with bonjour that crashes the WLC. This should be fixed on the 7.4 MR1. The v7.5 beta seems to work better with bonjour but all in all, you need to make sure that multicast is enabled properly in the wired side. I have used the bonjour gateway when on v7.3 and that worked like a charm.

Sent from Cisco Technical Support iPhone App

Actions

Login or Register to take actions

This Discussion

Posted April 25, 2012 at 2:43 PM
Stats:
Replies:8 Avg. Rating:
Views:3571 Votes:0
Shares:0
Tags: 5500_wlc, 1140_ap
+

Related Content

Discussions Leaderboard