ISDN E1 problems

Unanswered Question
Apr 25th, 2012

Hi for some reason our ISDN dialout is not working. Any help would be greatly appreciated :

brussel3#sh run

Building configuration...

Current configuration : 6804 bytes

!

! Last configuration change at 08:18:01 NFT-1DF Thu Apr 26 2012 by ppp

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yyyy

!

boot-start-marker

boot system flash c3725-ipbasek9-mz.124-11.XW7.bin

boot system tftp c3725-i-mz.122-13.T9.bin 255.255.255.255

boot-end-marker

!

logging buffered 10000

no logging console

enable secret 5 $1$qFs5$Ez01V2kTc9OZLx24SG/Iy1

!

aaa new-model

!

!

aaa group server radius AUTHEN

server 193.202.69.1 auth-port 1645 acct-port 0

server 193.202.68.161 auth-port 1645 acct-port 0

!

aaa group server radius ACCOUNT

server 193.202.68.173 auth-port 0 acct-port 1646

!

aaa authentication login default local group tacacs+

aaa authentication login NO_AUTHENT none

aaa authentication ppp default local group AUTHEN

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization exec NO_AUTHOR none

aaa authorization network default local group radius

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group ACCOUNT

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

!

aaa session-id common

clock timezone NRT 1

clock summer-time NFT-1DFT recurring last Sun Mar 1:00 last Sun Oct 1:00

network-clock-participate wic 2

ip cef

!

!

!

!

no ip domain lookup

ip address-pool local

multilink bundle-name authenticated

async-bootp dns-server 172.17.49.102 193.202.69.2

isdn switch-type primary-net5

isdn voice-call-failure 0

!

chat-script offhook "" "ATH1" OK \c

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

!

!

!

!

username xxx secret 5 xxx

archive

log config

  hidekeys

!

!

controller E1 0/0

pri-group timeslots 1-31

description VZB

!

controller E1 1/0

shutdown

clock source internal

!

controller E1 1/1

shutdown

framing NO-CRC4

!

!

!

!

interface FastEthernet0/0

ip address 172.17.51.252 255.255.240.0

ip access-group 101 out

speed 100

full-duplex

!

interface Serial0/0:15

description VZB-Dial-xxx-0224545454

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

no snmp trap link-status

isdn switch-type primary-net5

isdn incoming-voice modem

no peer default ip address

no cdp enable

ppp callback permit

ppp authentication ms-chap-v2 ms-chap chap

ppp multilink

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer in-band

dialer idle-timeout 180

dialer-group 1

no snmp trap link-status

peer default ip address pool GVBpool

no cdp enable

ppp callback permit

ppp authentication ms-chap chap callin

ppp multilink

!

interface Group-Async1

physical-layer async

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer in-band

dialer idle-timeout 1800

dialer-group 1

no snmp trap link-status

async mode interactive

peer default ip address pool GVBpool

ppp callback permit

ppp authentication ms-chap chap

!

ip local pool GVBpool 172.17.55.1 172.17.55.32

ip route 0.0.0.0 0.0.0.0 172.17.51.250

!

no ip http server

no ip http secure-server

!

ip sla responder

logging trap debugging

logging facility local2

logging 193.202.68.219

access-list 11 permit 10.132.133.73

access-list 20 permit 193.202.68.0 0.0.0.255

access-list 20 permit 193.210.201.192 0.0.0.31

access-list 20 permit 172.17.48.0 0.0.15.255

access-list 101 permit tcp host 172.17.56.8 host 193.202.68.62 eq 3389

access-list 101 permit tcp host 172.17.56.8 host 193.202.68.62 eq www

access-list 101 deny   ip host 172.17.56.8 any log

access-list 101 permit tcp host 172.17.56.10 host 193.202.68.62 eq 3389

access-list 101 permit tcp host 172.17.56.10 host 193.202.68.62 eq www

access-list 101 permit ip host 172.17.56.10 host 193.202.68.248

access-list 101 permit ip host 172.17.56.11 host 193.202.68.248

access-list 101 deny   ip host 172.17.56.11 any log

access-list 101 permit ip any any

access-list 2001 permit ip any host 172.17.49.105

access-list 2002 permit ip 172.17.55.0 0.0.0.255 host 172.17.49.106

access-list 2003 permit ip 172.17.55.0 0.0.0.255 host 172.17.66.27

access-list 2004 permit tcp 172.17.55.0 0.0.0.255 10.132.224.0 0.0.0.255 eq telnet

access-list 2005 permit ip 172.17.55.0 0.0.0.255 host 193.202.68.249

access-list 2006 permit ip 172.17.55.0 0.0.0.255 host 193.202.68.105

access-list 2007 permit ip 172.17.55.0 0.0.0.255 host 193.202.68.139

access-list 2007 permit ip 172.17.55.0 0.0.0.255 host 193.202.72.65

access-list 2008 permit ip 172.17.55.0 0.0.0.255 10.132.224.0 0.0.0.255

access-list 2009 permit tcp 172.17.55.0 0.0.0.255 host 193.202.68.249 eq telnet

access-list 2009 permit tcp 172.17.55.0 0.0.0.255 gt 1023 host 172.17.18.5 eq ftp

access-list 2009 permit tcp 172.17.55.0 0.0.0.255 gt 1023 host 172.17.18.5 eq ftp-data established

access-list 2010 permit ip 172.17.55.0 0.0.0.255 10.132.194.0 0.0.0.255

access-list 2011 permit tcp 172.17.55.0 0.0.0.255 host 193.53.47.100 eq telnet

access-list 2012 permit ip 172.17.55.0 0.0.0.255 host 193.202.69.39

access-list 2013 permit ip 172.17.55.0 0.0.0.255 host 193.202.68.62

dialer-list 1 protocol ip permit

snmp-server community xxx RO 10

snmp-server community xxxd RW 11

snmp-server trap-source FastEthernet0/0

snmp-server contact xxx

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps envmon

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps frame-relay multilink bundle-mismatch

snmp-server enable traps frame-relay

snmp-server enable traps frame-relay subif

snmp-server enable traps hsrp

snmp-server enable traps rsvp

snmp-server enable traps ipsla

snmp-server host 172.17.51.1 xxx  config snmp

snmp-server host 193.210.201.195 xxx  envmon config snmp

snmp-server host 193.210.201.221 xxx  tty frame-relay isdn x25 config hsrp

tacacs-server host 10.132.133.50

tacacs-server directed-request

tacacs-server key xxxx

radius-server key ******** xxxx

!

control-plane

!

banner login ^C

----------------------------------------------------------

xxxx ! ! !

Authorized access only (TACACS)!

Disconnect IMMEDIATELY if you are not an authorized user ! ! !

----------------------------------------------------------

^C

banner motd ^xxxx GROUP^C

!

line con 0

exec-timeout 0 0

logging synchronous

line 65 76

line aux 0

line vty 0 4

exec-timeout 0 0

!

ntp clock-period 17180512

ntp server 193.202.68.173

!

end

DEBUG

Apr 26 05:31:58.993: ISDN Se0/0:15 EVENT: UserIdle: callid 0x8002 received ISDN_CALL (0x0)

Apr 26 05:31:58.993: ISDN Se0/0:15 EVENT: process_pri_call: call id 0x8002, number 0224545454, Guid 00B115C06267, speed 64, call type DATA, redial No, CSM call No, pdata No

Apr 26 05:31:58.993: ISDN Se0/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Called num 0224545454

Apr 26 05:31:58.993: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=37 nr=37

Apr 26 05:31:58.993: ISDN Se0/0:15 Q931: SETUP pd = 8  callref = 0x0081

        Bearer Capability i = 0x8890

                Standard = CCITT

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

        Called Party Number i = 0x81, '0224545454'

                Plan:ISDN, Type:Unknown

Apr 26 05:31:59.005: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=38

Apr 26 05:31:59.121: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=37 nr=38

Apr 26 05:31:59.121: ISDN Se0/0:15 Q931: CALL_PROC pd = 8  callref = 0x8081

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

Apr 26 05:31:59.121: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=38

Apr 26 05:31:59.121: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x8002 calltype 1 CALL_PROCEEDING

Apr 26 05:31:59.273: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=38 nr=38

Apr 26 05:31:59.273: ISDN Se0/0:15 Q931: SETUP pd = 8  callref = 0x1ABF

        Bearer Capability i = 0x8890

                Standard = CCITT

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18381

                Preferred, Channel 1

        Calling Party Number i = 0x00A3, N/A

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xA1, '224545454'

                Plan:ISDN, Type:National

        Sending Complete

Apr 26 05:31:59.273: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=39

Apr 26 05:31:59.273: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x20 calltype 1 CALL_INCOMING

Apr 26 05:31:59.273: ISDN Se0/0:15 EVENT: call_incoming: call_id 0x0020, Guid = 00FFFFFFFFFF

Apr 26 05:31:59.277: ISDN Se0/0:15 EVENT: UserIdle: callid 0x20 received ACCEPT_CALL (0x13)

Apr 26 05:31:59.277: %LINK-3-UPDOWN: Interface Serial0/0:0, changed state to up

Apr 26 05:31:59.277: %ISDN-6-CONNECT: Interface Serial0/0:0 is now connected to N/A N/A

Apr 26 05:31:59.277: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=38 nr=39

Apr 26 05:31:59.277: ISDN Se0/0:15 Q931: CALL_PROC pd = 8  callref = 0x9ABF

        Channel ID i = 0xA98381

                Exclusive, Channel 1

Apr 26 05:31:59.277: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=39 nr=39

Apr 26 05:31:59.277: ISDN Se0/0:15 Q931: CONNECT pd = 8  callref = 0x9ABF

        Channel ID i = 0xA98381

                Exclusive, Channel 1

Apr 26 05:31:59.285: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=39

Apr 26 05:31:59.289: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=40

Apr 26 05:31:59.317: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=39 nr=40

Apr 26 05:31:59.317: ISDN Se0/0:15 Q931: CONNECT_ACK pd = 8  callref = 0x1ABF

Apr 26 05:31:59.321: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=40

Apr 26 05:31:59.321: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x20 calltype 1 CALL_PROGRESS

Apr 26 05:31:59.569: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=40 nr=40

Apr 26 05:31:59.569: ISDN Se0/0:15 Q931: CONNECT pd = 8  callref = 0x8081

Apr 26 05:31:59.569: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=41

Apr 26 05:31:59.569: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x8002 calltype 1 CALL_CONNECT

Apr 26 05:31:59.569: %LINK-3-UPDOWN: Interface Serial0/0:30, changed state to up

Apr 26 05:31:59.569: %ISDN-6-CONNECT: Interface Serial0/0:30 is now connected to 0224545454 N/A

Apr 26 05:31:59.569: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x8002 calltype 1 CALL_PROGRESS

Apr 26 05:31:59.573: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=40 nr=41

Apr 26 05:31:59.573: ISDN Se0/0:15 Q931: CONNECT_ACK pd = 8  callref = 0x0081

Apr 26 05:31:59.581: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=41

Apr 26 05:32:05.278: %ISDN-6-CONNECT: Interface Serial0/0:0 is now connected to N/A N/A

Apr 26 05:32:05.570: %ISDN-6-CONNECT: Interface Serial0/0:30 is now connected to 0224545454 N/A

Apr 26 05:32:09.583: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=41

Apr 26 05:32:09.587: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=41

Apr 26 05:32:19.588: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=41

Apr 26 05:32:19.592: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=41

Apr 26 05:32:19.724: ISDN Se0/0:15 EVENT: UserIdle: callid 0x8002 received ISDN_HANGUP (0x1)

Apr 26 05:32:19.724: ISDN Se0/0:15 EVENT: isdn_hangup: Hangup call to call id 0x8002 ces = 1

Apr 26 05:32:19.724: %ISDN-6-DISCONNECT: Interface Serial0/0:30  disconnected from 0224545454 , call lasted 20 seconds

Apr 26 05:32:19.724: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=41 nr=41

Apr 26 05:32:19.724: ISDN Se0/0:15 Q931: DISCONNECT pd = 8  callref = 0x0081

        Cause i = 0x8090 - Normal call clearing

Apr 26 05:32:19.732: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=42

Apr 26 05:32:19.968: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=41 nr=42

Apr 26 05:32:19.968: ISDN Se0/0:15 Q931: RELEASE pd = 8  callref = 0x8081

Apr 26 05:32:19.972: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=42

Apr 26 05:32:19.972: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x8002 calltype 1 CALL_CLEARED

Apr 26 05:32:19.972: %LINK-3-UPDOWN: Interface Serial0/0:30, changed state to down

Apr 26 05:32:19.972: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=42 nr=42

Apr 26 05:32:19.972: ISDN Se0/0:15 Q931: RELEASE_COMP pd = 8  callref = 0x0081

Apr 26 05:32:19.980: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=43

Apr 26 05:32:20.020: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=42 nr=43

Apr 26 05:32:20.024: ISDN Se0/0:15 Q931: DISCONNECT pd = 8  callref = 0x1ABF

        Cause i = 0x8090 - Normal call clearing

Apr 26 05:32:20.024: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=43

Apr 26 05:32:20.024: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x20 calltype 1 CALL_DISC

Apr 26 05:32:20.024: %ISDN-6-DISCONNECT: Interface Serial0/0:0  disconnected from unknown , call lasted 20 seconds

Apr 26 05:32:20.024: %LINK-3-UPDOWN: Interface Serial0/0:0, changed state to down

Apr 26 05:32:20.024: ISDN Se0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=43 nr=43

Apr 26 05:32:20.024: ISDN Se0/0:15 Q931: RELEASE pd = 8  callref = 0x9ABF

Apr 26 05:32:20.032: ISDN Se0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=44

Apr 26 05:32:20.068: ISDN Se0/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=43 nr=44

Apr 26 05:32:20.068: ISDN Se0/0:15 Q931: RELEASE_COMP pd = 8  callref = 0x1ABF

Apr 26 05:32:20.072: ISDN Se0/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=44

Apr 26 05:32:20.072: ISDN Se0/0:15 EVENT: process_rxstate: ces/callid 1/0x20 calltype 1 CALL_CLEARED

Apr 26 05:32:30.073: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=44

Apr 26 05:32:30.077: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=44sh isdn

yyyy#sh isdn ac

yyyy#sh isdn active

--------------------------------------------------------------------------------

                                ISDN ACTIVE CALLS

--------------------------------------------------------------------------------

Call    Calling      Called       Remote  Seconds Seconds Seconds Charges

Type    Number       Number       Name    Used    Left    Idle    Units/Currency

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

yyyy#sh isdn his

yyyy#sh isdn history

Apr 26 05:32:40.078: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=44

Apr 26 05:32:40.082: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=44

--------------------------------------------------------------------------------

                                ISDN CALL HISTORY

--------------------------------------------------------------------------------

Call History contains all active calls, and a maximum of 100 inactive calls.

Inactive call data will be retained for a maximum of 15 minutes.

--------------------------------------------------------------------------------

Call    Calling      Called       Remote  Seconds Seconds Seconds Charges

Type    Number       Number       Name    Used    Left    Idle    Units/Currency

--------------------------------------------------------------------------------

In    ---N/A---    224545454                    20

Out   ---N/A---   0224545454                    20                      0

In    ---N/A---    224545454                    20

Out   ---N/A---   0224545454                    20                      0

--------------------------------------------------------------------------------

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Richard Burts Sat, 04/28/2012 - 11:44

I believe that this line gives a good clue about what is going on:

Apr 26 05:32:19.724: ISDN Se0/0:15 EVENT: UserIdle: callid 0x8002 received ISDN_HANGUP (0x1)

What I think we can see in the debug is that the call was completed, that the call lasted 20 seconds (the same amount of time as the several preceding calls that show up in the history), and that the other side sent a hangup. So the question becomes why did the other side send a hangup?

Do you have any information from the device on the other side? Are there any error messages or debug outputs available from the other side?

HTH

Rick

Actions

Login or Register to take actions

This Discussion

Posted April 25, 2012 at 11:34 PM
Stats:
Replies:1 Avg. Rating:
Views:988 Votes:0
Shares:0
Tags: isdn, debug, 3725, e1
+

Related Content

Discussions Leaderboard