TMS Appliance Upgrade

Answered Question
Apr 27th, 2012

Hi all,

I have a TMS appliance. Its version is 13.0. And I want to upgrade it to the version 13.1.2. First of all, I want to learn if it is possible or not. If it possible, how can I do that? I tried to upgrade by running TMS 13.1.2 exe, and I had an error saying "It is harmful operation" and it didn't allow me to install it. What do you think is the problem?

Regards,

Tufan 

I have this problem too.
0 votes
Correct Answer by Magnus Ohm about 1 year 10 months ago

Hi Tufan

Look at the HTTP exception by clicking it. Does it say that it cannot find any phonebooks? Try creating some users and enable access to the phonebooks in phonebook management under access control. Do you still see the error after a full synchronization?

/Magnus

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (6 ratings)
Magnus Ohm Fri, 04/27/2012 - 07:25

Hi yes this is definately possible and should not be harmful. Do you have antivirus installed or is it added to a domain?

/Magnus

Sent from Cisco Technical Support iPhone App

Magnus Ohm Fri, 04/27/2012 - 07:51

Could we get a screenshot of the error?

Sent from Cisco Technical Support iPhone App

tufan.kabacioglu Thu, 05/03/2012 - 22:43

Hi,

I upgraded the TMS now. But now I have a problem about provisioning. I was completing all configuration step by step according to the "Provisioning Deployment Guide". But I stuck while enabling TMS agent for the VCS on TMS. When I try to enable TMS agent, I get the error message on activity logs "Unable to enable replication for vcs. A DNS lookup of the TMS hostname on this VCS doesn't match the TMS ip address". Actually I installed the DNS role on the TMS appliance because I don't have another server. But I see it solves DNS addresses. What should I check on TMS or VCS. You can see activity status below.

Best regards,

Tufan

Jens Didriksen Sun, 05/06/2012 - 22:39

Heh, I had exactly the same error when upgrading from 13.1.2 to 13.2 (not an appliance), but only with one VCS-C, despite all addresses being correct - changed address of the primary DNS server on the offending VCS-C to one of our other 4 servers and all was good again.Never seen that behaviour before.

/jens

tufan.kabacioglu Thu, 05/03/2012 - 23:01

The problem has been solved changing TMS Agent settings on the TMS. I changed TMS address.

Thanks

Magnus Ohm Thu, 05/03/2012 - 23:05

Hi Tufan

Please have a look in this document, it might help.

https://supportforums.cisco.com/servlet/JiveServlet/previewBody/23654-102-1-58501/Cisco_TMS_Agent_Troubleshooting_Procedures.pdf

If you still have the issue and you cannot enable replication i advise you to open a TAC case.

I also recommend that you upgrade to 13.2 and utilize the new provisioning model. However the TMS appliance only supports a small provisioning deployment due to its lack of resources.

Please see this thread for more info and documentation + downloads.

https://supportforums.cisco.com/thread/2145898?tstart=0

Sent from Cisco Technical Support iPhone App

Magnus Ohm Thu, 05/03/2012 - 23:06

Hi

Great that it was solved!

/Magnus

Sent from Cisco Technical Support iPhone App

Martin Koch Fri, 05/04/2012 - 02:46

Btw, just a short remark in general regards the appliance.

Like seen here and described by Magnus it is not an issue to upgrade the TMS appliance.

One thing what can become a bit of an issue is the 15GB partition.

It might be quite useful to clean up upfront an upgrade.

Also the RAM and the CPU is not so performant, so at least be aware of that :-)

tufan.kabacioglu Fri, 05/04/2012 - 04:34


Thanks for all your interests.

I get over a problem and face another problem. At last I faced registering problem on Cisco Jabber, and I saw that the TMS couldn't replicate with the VCS. Somehow the VCS control has dual network interface option (btw I thought this option was valid for VCS expressway only not valid for VCS control). And the TMS was trying to connect the ip address of the second ethernet port of the VCS. So I deleted the option. And I tried re-enabling TMS agent for the VCS. But now it hasn't worked.

Actually they are demo systems and my colleauges used them in different customers. It is difficult to find the causes of the problems. So I want to restore the TMS and the VCS. Can you explain the procedure of restoring the TMS?

Best regards, 

Magnus Ohm Fri, 05/04/2012 - 04:40

Correct, you should not have Dual NIC option on the VCS-C it can create problems with replication. This is supported now sorry for the confusion.

So these are tests systems which many people are using and re-configuring? Do you want to reset everything to scratch or do you just want to re-install the TMS and/or the VCS software?

Even though you cannot enable replication on the VCS. Did you reboot the VCS after you removed the Dual NIC option? What is the error you are experiencing when you try to enable replication?

You could try to rebuild the TMSAgent database. Please look in this document: https://supportforums.cisco.com/servlet/JiveServlet/previewBody/23654-102-1-58501/Cisco_TMS_Agent_Troubleshooting_Procedures.pdf as it contains a lot of common issues and how to resolve them.

/Magnus

tufan.kabacioglu Thu, 05/10/2012 - 05:14

Hi,

I tried to reboot the VCS. It is the same. How can I restore the TMS to factory default?

Regards,

Tufan

Martin Koch Thu, 05/10/2012 - 07:11

In general you can remove the TMS application, remove opends if its there, purge the SQL databse and install the TMS application again.

Maybe just purging the VCS from the TMS might also be a good start.

tufan.kabacioglu Fri, 05/25/2012 - 01:54

Hello again,

I uninstalled the old TMS app and installed the latest release (13.2). Now I am trying to complete provisioning between TMS and VCS. For that I installed new Provisioning app in the same server with TMS. But while trying to provision I had an error about phone books. And I can not change Provisioning Mode from legacy one to the new method. You can see the error below.

Best regards,

Tufan

Correct Answer
Magnus Ohm Fri, 05/25/2012 - 01:59

Hi Tufan

Look at the HTTP exception by clicking it. Does it say that it cannot find any phonebooks? Try creating some users and enable access to the phonebooks in phonebook management under access control. Do you still see the error after a full synchronization?

/Magnus

tufan.kabacioglu Wed, 05/30/2012 - 00:50

Hello,

Again me I nearly completed the provisioning but still have some problems.

-I selected "treat as authenticated" on VCS zone configuration. In that case, I can login but I have problem with presence update on Jabber.

-When I select "check credentials" on the same configuration, it doesn't accept my login attempt. It says "wrong password/username" although they are right. I see it gets the users from the AD.

also I have a question:

-What exactly should I enter for phonebook URL and provisioning URL on the configuration templates? I think I can not enter IP address only. Could you please me an example?

Regards,

Tufan

Magnus Ohm Wed, 05/30/2012 - 01:09

Hi Tufan

Did you integrate your VCS with Active Directory? If not even though if the users are imported from AD to the provisioning directory the password is generated. By changing the password of one of the users in the directory in TMS you might be able to log in with this. If the VCS is setup correctly you can log in using the AD credentials but there is additional work to set this up.

For the phonebook it depends if you want to get the phonebook from the VCS or the TMS. Usually jabber gets this from the VCS. You then activate the Phonebook Server URI in the config template and type in: phonebook@.

You have to log out and log in once these settings has been applied for them to work.

Did you activate presense server on the VCS? Presence must be authenticated so either check credentials and log in with valid password and username or treat as authenticated.

For the presence server it is: presence@.

/Magnus

tufan.kabacioglu Wed, 05/30/2012 - 04:05

Hi,

Actually I don't understand exactly. I integrated the TMS with AD. Still do I need to integrate the VCS with AD?

Regarding phonebook, I asked the question Jabber and the other endpoints which can be provisioned. In case of both situaition (using TMS or VCS as phonebook server) do I need to enter the same URL?

Regards,

gubadman Wed, 05/30/2012 - 05:12

It depends on where you are getting your passwords for the user accounts you imported to TMS. If you created passwords in TMS for the users, or you want your users to use their AD credentials to sign in to Jabber. If you do want users to log in with AD credentials, VCS should be integrated with AD

There is more information here -

http://www.cisco.com/en/US/docs/telepresence/infrastructure/vcs/config_guide/Cisco_VCS_Authenticating_Devices_Deployment_Guide_X7-1.pdf

jabber will need to be at least 4.2

tufan.kabacioglu Wed, 05/30/2012 - 07:18

I want users login with AD credentials. So I don't need to integrate the VCS with AD directly. Actually TMS gets the users from AD. I think it is able to get users' credentials as well. Do I need to also create passwords on TMS for the users imported from AD? If so, can you please show me how to do? Because I see imported users only in "Systems-> Provisioning->Users". I don't see the imported users on TMS under "Adminisrative Tools -> User Administration -> Users". Is it normal?

tufan.kabacioglu Wed, 05/30/2012 - 07:30

Anyway, I integrated the VCS with AD. So the registration problem was solved. But still I have the presence problem. I selected authentication setting to "check credentials" but it gives "failed to update presence".

gubadman Wed, 05/30/2012 - 07:35

That's odd. Is the "Check Credentials" on the Default Zone, Default SubZone, or any other subzone that the Jabber is put in to?

tufan.kabacioglu Wed, 05/30/2012 - 07:46

Ok it was solved. I missed Default Subzone. But it is interesting that I don't see Default Subzone in the Zones. I reached it via the Links. Thanks all again.

gubadman Wed, 05/30/2012 - 07:50

No problem. For reference the default subzone is reachable from: VCS configuration > Local Zone > Default Subzone menus.

Actions

Login or Register to take actions

This Discussion

Posted April 27, 2012 at 5:10 AM
Stats:
Replies:23 Avg. Rating:5
Views:1911 Votes:0
Shares:0

Related Content

Discussions Leaderboard