This discussion is locked

TMS 13.2 + Provisioning extension is out

Answered Question
Apr 27th, 2012

The software we all been waiting for is now released

http://www.cisco.com/cisco/software/release.html?mdfid=283613664&catid=280789323&softwareid=280886992&release=13.2&relind=AVAILABLE&rellifecycle=&reltype=latest

Can be dowloaded here. The provisioning extension is also released side by side with 13.2.

Found here

http://www.cisco.com/cisco/software/release.html?mdfid=284330317&catid=280789323&softwareid=280886992&release=1.00&relind=AVAILABLE&rellifecycle=&reltype=latest

Enjoy

Sent from Cisco Technical Support iPhone App

I have this problem too.
0 votes
Correct Answer by Martin Koch about 1 year 10 months ago

Hi Juergen!

Ah, yes, forgot to give a feedback here :-)

For me the fix was that I specified the port manually in the address field like:

127.0.0.1:1433

or what ever you have set up as the ip/port it listens to on TCP.

I also had disabled named pipes:

Addon: if I remember it right you also see a syn to 1434 or something like that, so not sure why the instller behaves like that)

Good success and please rate the message using the stars below!

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (9 ratings)
mikesouders Mon, 04/30/2012 - 09:34

When is 14.0 coming out?  This looks to me llike nothing more than a maintenance release.  I am very disappointed to say the least with this.  I was really looking forward to the next version.  Currently running 13.1.2 and looks like it's not worth it to upgrade because it would break more things than it fixes.

darren.lapierre Mon, 04/30/2012 - 09:37

there are definitely some more functionality surrounding the provisioning agent. Alot of back-end went into developing a more robust provisioning experience. The old LDAP opends was sometimes flakey and very in-consistant.

But yes, if you dont experience any issues, i would suggest waiting til TMS 14.0.

Magnus Ohm Mon, 04/30/2012 - 15:11

Hi Michael

Indeed the 13.2 is a minor release which has introduced some minor fixes/changes to TMS it self. The most important thing with TMS 13.2 is the new provisioning model TMSPE (Provisioning Extension) which is a major upgrade in terms of stability and scalability for the provisioning part of TMS.

This is the main reason that TMS 13.2 has been a version many have been waiting for because it introduces support for the new provisioning model as Darren is mentioning above.

Is there anything specific the TMS 13.2 will break compared to TMS 13.1.2?  Any functionality you are waiting for in particular for TMS 14.x?

/Magnus

Jens Didriksen Mon, 04/30/2012 - 15:38

Hi Magnus,

TMSPE Deployment Guide says

Prior to installation and deployment of Cisco TMSPE, we recommend upgrading all endpoints to the latest software version available.

which is fair enough, however, I will most probably have a number of users still on JV 4.2 when I implement TMSPE next week-end - will this cause provisioning problems for these users?

/jens

Nick Halbert-Li... Mon, 04/30/2012 - 17:09

I have a similar question to Jens above;

We do not currently use TMS Agent provisioning, but we are looking at rolling out Jabber/Movi.  I was waiting until TMS 13.2 came out so I could use provisioning extension mode;  can I continue to use templates etc for my video endpoints (many of which are on old software) while I use TMSPE for Jabber/Movi only?

Magnus Ohm Tue, 05/01/2012 - 00:55

Hi Nick

You are talking about the configuration templates for the video endpoints? If so then yes you can continue using the configuration templates along side with the Jabber using the TMSPE.

Just so I have not misunderstood you here is a screenshot of the feature I think you are talking about:

/Magnus

Magnus Ohm Tue, 05/01/2012 - 00:50

Hi Jens

You will be able to login with JV 4.2 with the new provisioning extension yes. But you need to have a 4.2 configuration template installed.

/Magnus

Martin Koch Tue, 05/01/2012 - 04:16

Jens / Nick: like I wrote before, test it upfront you deploy it do better understand which impact

it might have on your deployment. The major showstopper for me is the missing user level configuration

and the changed capability to inherit settings to child folders and that you might end up with way

to many configuration templates which then get out of sync.

There are some clear benefits of the new model, like better scaling (not a full-mesh replication anymore).

If you had multiple vcs with the provisioning agent running (also multiple clusters) then you might know

what I am talking about. The replication of specific sub levels to a vcs or different provisioning phonebooks

based on groups.

Jens: you can still use the same xml device templates you had used before, so the movi/JV version

itself is not an issue. In addon what Magnus said, you could also log in with a Jabber 4.4 profile.

Nick: the devices which can be provisioned did not change and also the old style  "System Navigator"

incl "the provisioning templates" (not to be mixed up with the provisioning directory) still exist in 13.2-

Its  the provisioning directory backend and its user-frontend which is new.

TMS13.2 will work with the old style open-ds provisioning as well, so at least there is no force to use TMSPE.

If you don't have enormous trouble with the old provisioning and you are not dependent on new functionality

then it might make sense just to wait what other new functionality will be introduced with the next version.

Nick/Jens: whats the reason why you "desperatly" want to upgrade to it?

Michael: what are the features you were hoping to see?

Nick Halbert-Li... Tue, 05/01/2012 - 15:49

Thanks Martin/Magnus.

The reason I want to upgrade;

We currently don't have any Movi/Jabber users but we want to roll this feature out.  Up until now, we haven't used provisioning, but it was enabled however not working properly (like that since before I started here).  There seem to be lots of issues with the way our old provisioning/TMS agent configuration that seemed like more hassle than it was worth to fix it as I had no users or anything to migrate anyway, so I decided to wait for TMSPE.

Jens Didriksen Tue, 05/01/2012 - 18:28

Hi Martin,

Oh, I don't "desperately" want to upgrade to it as the  existing provisioning method doesn't give us too many problems in  general.

Having said that, Cisco recommends the upgrade  to fix an outstanding TAC case we have which involves JabberVideo 4.3  and 4.4 not playing nice on Macs running L...n 7.3 (can't spell it out as the Cisco spam filter then blocks post) - and as we are  getting more and more L...ns prowling our network, it needs to get fixed  sooner rather than later.

After a lot of testing, log  traces etc - Cisco believes our issue is caused by the current  provisioning method and we should not see it with TMSPE.

Upgrading  from 13.1.2 to 13.2 doesn't worry me at all, it was the TMSPE that I  wasn't too sure about. However, seeing that I can turn off TMSPE and go  back to TMS Agent should I need to, and the fact I can still use the old  templates for the few users I still have on 4.2, makes me feel a lot  better about it.

/jens

Martin Koch Fri, 05/04/2012 - 03:57

Ok, yes, thats not good. Interesting, did not notice Mac issues here.

Yes, you can go back, but then you loose the changed data.

You can only migrate data from OpenDS to TMSPE but not reverse, so be aware of that.

Jens Didriksen Sat, 05/05/2012 - 22:54

Martin Koch wrote:

The major showstopper for me is the missing user level configuration

and the changed capability to inherit settings to child folders and that you

might end up with wayto many configuration templates which then get out of sync.

Yup, not having the user level configuration is not good at all - don't really understand the thinking behind not having that in this release.

I import all of our users from AD, which is divided into groups based on ORG, which is Faculties, Shools, Disciplines, Services etc - and I have some users within some ORGs where I have to provision max and default b/w as 512kbps, whereas all other users are provisioned with 4Mbps. Not sure how I can easily achieve this with TMSPE.

I've upgraded to  13.2 but had to go back to the legacy TMS Agent as I'm having some comms issues between VCS-C/TMSPE and the TMS server,

I'll look at it again when back at work on Tuesday.

(See Martin; open/close - inside joke )

/jens

Martin Koch Sat, 05/05/2012 - 23:08

Guess I would go with AD groups like ORG1-512kbit, ORG1-4MBit, ... and then map

them to specific folders/templates/importfilters in the TMSPE.

If you or somebody else finds an easier way (besides using the old provisioning :-P ) please post it here!

Jens Didriksen Sun, 05/06/2012 - 00:45

Martin Koch wrote:

Guess I would go with AD groups like ORG1-512kbit, ORG1-4MBit, ... and then map

them to specific folders/templates/importfilters in the TMSPE.

If you or somebody else finds an easier way (besides using the old provisioning :-P ) please post it here!

Won't work as we would then have to add these to AD itself each time we need one within a specific ORG, it just ain't going to happen.

Each ORG is unique and is determined by where they sit in the organisational structure, i.e. a top level for a Faculty, then a sub-level for School within this faculty, then another sub-level for Discipline within this School etc.

And we have a lot of these, and since they are all within specific ORGs based on the above and not on their geographical location, and as we have a number of locations..well...it would get real messy very quickly.

/jens

Martin Koch Sun, 05/06/2012 - 07:06

I fully acknowledge what you say and I would assume that many TMS admins will not have

AD admin access to even be capable of moving users / groups by that.

And am also  sceptic if we end up double up groups for TMSPE for each unique setting parameter

we will most likely run out of sync of our configurations, ...

There definitely will be use cases where the new TMSPE will be an exact fit and makes admin life much more

easy, but at least not for the two of us, ...

So I guess its just hope and wait for the next release(s) of TMSPE and stick with OpenDS.

Jens: did you see my private message?

Jens Didriksen Mon, 05/07/2012 - 00:05

Heh - if I went to our Computing Systems & Architecture Manager and told him we need to make changes to the AD structure because TMS can't do certain things, then I would be told to sober up and come back when I have a real problem...

Might still have to go ahead with TMSPE though as it should fix our Mac problem, and if it does that, then that's more important to get fixed than provisioning issues with some users at some remote sites - which I then will have to see if I can get around somehow by other means.

Was so nice and simple - and quick - being able to that by using individual user settings. /sigh

/jens

mikesouders Thu, 05/03/2012 - 06:21


Thanks Magnus - I would love to see better integration between TMS and the Codian products.  Also, if the TMS messages could appear on the displays rather than the T3 touch panels.  I've had calls timeout because they can't see the warnings, especially if there is content.

Magnus Ohm Thu, 05/03/2012 - 06:30

Hi Michael

Are you talking about the extend conference? There is a new feature for this in TMS 13.2 which extends the conference automatically until it cannot be extended any longer.

This can at least work around the problem with the conferences timing out.

When you say better integration between TMS and the Codian products it's not very specific could you point at some features your not satisfied with?

Best Regards

Magnus Ohm

Kjetil Ree Thu, 05/03/2012 - 07:25

That's a feature request you have to raise against the T3 people. All TMS does is to send the notification, TMS does not control where it is displayed.

Regards,

Kjetil

Sent from Cisco Technical Support iPhone App

duyvinhdao Wed, 05/16/2012 - 06:38

Auto-Extended Feature.
  Im very excited about this new feature as it's could be the fix for no "end conference" notification from the Codian when intergrate with TMS.  Documentation says this can be extended upto 16 15-minute sessions.  Is there a way to just default to only 1 15-minute session?  Thanks

Michael Boscia Mon, 05/07/2012 - 06:30

How do I determine the SQL Instance Name so that I can continue installing TMSPE?

Kjetil Ree Mon, 05/07/2012 - 06:38
How do I determine the SQL Instance Name so that I can continue installing TMSPE?

Check the SQL Server Configuration Manager on your database server. Go to "SQL Server Services", and you'll see the instance name next to the "SQL Server" service.

-Kjetil

Michael Boscia Mon, 05/07/2012 - 06:47

OK, that seems to have worked.

Unfortunately, now it is telling me:

"Unable to establish SQL connection through Java runtime. Check your SQL protocol settings."

Also, how do I set the user privilege db_owner as required in the deployment guide when the SQL database is not on the same box as the TMS application itself?

darren.lapierre Mon, 05/07/2012 - 07:15

You would most likely require access to your SQL server (but you might not have credentials). If you are pointing your TMS to a SQL cluster, speak to your SQL admin, and set the same permissions on your tmsng database as your tmspe.

Michael Boscia Mon, 05/07/2012 - 08:04

I don't mean to be rude, but shouldn't the guide assume that the person installing it knows nothing about SQL?

I would suggest that this section of the guide should have a step-by-step guide for how to do this.

I say this because my "SQL Admin" tells me that his SQL server experience is from the 1990s, and you can't always assume that the customer is going to have the expertise to assist with these installation tasks.

With this, as with other Cisco products, the customer expects us to come to the table with a complete, step-by-step set of instructions to deploy these services, and it really doesn't help when we get a somewhat vauge set of guidelines and a basic requirement to get an expert of whatever discipline is needed to deploy the technology.

Having said that, most times the customer does have competent people to assist us from their side, but when they do no, we as the vendor are expected to bring all expertise required to execute on the assigned tasks.

Magnus Ohm Mon, 05/07/2012 - 07:43

Hi Michael

I don't know if you are hitting this but it might be worth checking.

From the deplyment guide:

Windows Server

If using the Named Pipes protocol for database connection, the following security updates/hotfixes to Windows Server are required : n

Windows Server 2003: http://support.microsoft.com/kb/958687

n

Windows Server 2008 R2: http://support.microsoft.com/kb/2194664 and http://support.microsoft.com/kb/2194664

Note that the default connection protocol is TCP/IP. If this protocol is used, no hotfixes are required.

/Magnus

Magnus Ohm Tue, 05/08/2012 - 05:45

Was in a webex with Michael and the "Unable to establish SQL connection through Java runtime. Check your SQL protocol settings." error that he was experiencing seems to have resolved after we turned on the SQL browser service. I did not confirm if the SQL server was listening to a custom port but the browser will help resolve that port anyhow and make a successful connection.

So if you see this error / check if the SQL browser is running, if not try to enable the service and try again.

At least this got us past this error.

/Magnus

Jens Didriksen Tue, 05/08/2012 - 15:17

Looks like I'll have to open a TAC case to get TMSPE to work;

installed fine, no problems at all, but it won't talk to the VCS-C properly; getting "connection refused", "error 111" on the TMSPE config page on the VCS-C itself for the services such as users, phonebooks etc.

/jens

Martin Koch Tue, 05/08/2012 - 15:33

I assume you followed:

http://www.cisco.com/en/US/docs/telepresence/infrastructure/tmspe/install_guide/Cisco_TMSPE_Deployment_Guide_1-0.pdf ?

Can I assume correct that you still have not added https support to your TMS?

(think I pointed that out some time ago on an other case :-)

Check out page 26, "Setting up communication between Cisco TMS and Cisco VCS". Could this be what hits you?

If you do not have https=TLS, try "off" instead of TLS and see if you are more lucky afterwards.

If not, provide a screenshot where you see your error, or like you said open a TAC case.

Martin

Jens Didriksen Tue, 05/08/2012 - 16:28

VCS-C is talking to TMS in general, it's just the TMSPE side which doesn't - turning off TLS doesn't make any difference at all.

I've reverted back to TMS Agent, so screenshots below from VCS-C with TMSPE disabled, however, the errors are the ones I get with TMSPE enabled.

Martin Koch Tue, 05/08/2012 - 16:33

You are still pointing to 443 which is https. You need to point it to 80 which is http without encryption.

Jens Didriksen Tue, 05/08/2012 - 16:42

Well, doh!

Never thought about that "little" detail.....

I'll give that a try tomorrow morning as I only have a couple of hours every morning to try test this before the traffic starts. Really wish I didn't have to do this on a live box, but there you go...

If it works with port 80, then I'll at least have something to take back to our firewall/security admin as I was assured there was nothing blocking TLS between VCS-C and TMS server when I checked with him yesterday.

/jens

Martin Koch Tue, 05/08/2012 - 16:46

There is most likely nothing blocking as you get a connection refused, this looks more like you just

do not have https enabled on the IIS of the TMS, ...

I would more recommend that you use your and the security guys time to see that you get https up and running

on the TMS!

Jens Didriksen Tue, 05/08/2012 - 18:30

Mmm, that made me think...the 13.2 install guide states

"At the end of the install/upgrade procedure a message appears stating that HTTPS is not enabled for Cisco TMS, and asks if you would like to enable it." etc etc.

I was never presented with that option, so don't know what happened there, but that's something I'll have to look at.

/jens

Jens Didriksen Tue, 05/08/2012 - 19:13

Our current production box is 2003, also in process of moving across to a VM, and just installed TMS 13.2 on that which is running 2008 r2, neither of these gives me the option of turning on https at the end of install.

Edit: Hmm, looks like this option is only for 2008, so that would at least explain why I didn't get it in 2003...

Anyways, enabled it on the 2008 r2 VM box since that's where everything will be moved to in the very near future.

Meanwhile, I'll be happy if I can get TMSPE to work on the 2003 box for now - even without https and tls, so I can test to see if TMSPE resolves our outstanding Mac JV issue. Guess I'll find out in the morning.

/jens

darren.lapierre Tue, 05/08/2012 - 16:48

Jens,

Check your PM.

I did run this through in my lab (TMSPE), but when it came time for my production server, it all went south over the weekend. I did manage to get everything up an going. A lot of what was mentioned, I did go through and was eventually able to resolve (port 80 was one of them when in non-TLS mode, as well as the VCSC wasn’t actively turning on TMSPE, and I had to force it on from the TMS Extension Page on the VCSC).

If you want a second set of eyes to look at it, let me know. I am free for a bit tomorrow.

D.

Jens Didriksen Wed, 05/09/2012 - 00:31

All good now - found an hour where I wouldn't upset too many users...and went through the whole lot again in the peace and quiet of my lounge room with no interruptions - what would I do without VPN and RDP...

So it's now working using http, after initially refusing that connection too, giving me 403.

Turned out it didn't like the user account I was using for authentication, despite this being member of Site Admins, so I'll have to get that one fixed by our AD manager.

I'll be looking at https tomorrow, and there was an issue there as well with the original box having ended up in the wrong zone in the Palo Alto, so TLS was being refused. Been some strange things happening with that box lately, late last week it lost its domain overnight, and nobody have been able to explain how that happened.

Now that TMSPE is working, I found to my delight that I can indeed get most of my "low b/w" users provisioned with lower b/w than the rest, so it's looking up.

/jens

Jens Didriksen Wed, 05/09/2012 - 19:59

I spoke too soon - not getting phone books now all of a sudden...so off I go to TAC...

Jens Didriksen Thu, 05/10/2012 - 20:48

3 hours on Webex with Cisco engineer - and I'm pleased to say TMSPE is now finally working as it should - yay

ppatel131 Wed, 05/09/2012 - 04:44

Hi All,

Does the VCS need to be added into TMS before you can install TMSPE?

I just finished a clean install of TMS 13.2 on a 64 bit server and want to get TMSPE installed before killing off the current Movi installation.

I get an error at the end of the TMSPE installation (in the attachment), but the logs don't really pinpoint the problem.

Thanks

ppatel

Magnus Ohm Wed, 05/09/2012 - 07:07

Yea you can install tmspe and have the legacy provisioning model running. That should be no issue. It does not change unless you flip the switch in tms and on the vcs.

Is this the only message you see or do you get a popup error before this?

In the logs do you see anything related to named pipes? If you do please look a few post up in this thread as you might miss the security updates from microsoft.

Since we are getting close to a log reading scenario a TAC case would be the best next step if there is nothing obvious to go after here.

Sent from Cisco Technical Support iPhone App

ppatel131 Wed, 05/09/2012 - 07:50

Hi Magnus,

Thanks for your response.

We have a completely new install i.e. there are no endpoints/VCS on the TMS 13.2 server at the moment. In the documentation is states that you need to add a "Cisco TMS Provisioning Extension option key". I didn't obtain that from the partner when requesting all option keys/release keys for TMS.

I don't get any other error messages to suggest something has gone wrong, it looks all good until the last dialogue box which then shows the message in the screenshot above.

I believe we are using TCP/IP for connection to the database and the logs for TMSPE show a successful connection:

Property(C): TMSMAJORVERSION = 13

Property(C): TMSMINORVERSION = 2

Property(C): TMSBUILDVERSION = 0

Property(C): LOGPROP = TMSPE (DEBUG): Sql Connection closed successfully

Property(C): SQLPROTOCOL = TcpIp

Property(C): SqlConnectionStatus = OK

Property(C): ConfigDBCompatible = YES

I tried to install the Microsoft Hotfix anyway, and that failed stating "The update is not applicable to your computer". We're running Microsoft Windows Server 2008 R2 Standard.

I've reached out to our partner to get TAC involved so let's see what they find in the logs.

Thanks

Regards

ppatel

Magnus Ohm Mon, 05/14/2012 - 09:34

Hey Pinkesh

Did you got your problem resolved yet?

/Magnus

ppatel131 Wed, 05/16/2012 - 06:02

Hi Magnus,

The issue hasn't been resolved yet..

i'm going to upgrade one of our VCS's to X7.1 and then try to install provisioning extensions.

Thanks

Pinkesh

Magnus Ohm Wed, 05/16/2012 - 07:29

There is no way to set a fixed numbers of 15 minute extends as far as I know. You either select extend to get prompted to extend the meeting or auto extend. If you select to get prompted to extend the meeting the user can accept one extend and decline the next promot to accomplish what you say here.

Sent from Cisco Technical Support iPhone App

Actions

Login or Register to take actions

This Discussion

Posted April 27, 2012 at 7:41 AM
Stats:
Replies:75 Avg. Rating:5
Views:8261 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard