3500XL v 12.0(5)

Answered Question
Apr 28th, 2012

I have a POE switch running 12.0(5).  I have port 24 connected as a trunk connected to the main switch.  I need to add an ip address on vlan 21 which is where the network vlan is.  I created it but I can not seem to enable it.  I have issued the no shut command several times, but doing "sh ip int brief" it keeps showing up as administively down.

[code]

poeswitch#sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname poeswitch

!

!

!

!

!

!

spanning-tree uplinkfast

!

ip subnet-zero

no ip domain-lookup

!

!

!

interface FastEthernet0/1

switchport access vlan 21

switchport voice vlan 10

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 10

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

no ip directed-broadcast

no ip route-cache

!

interface VLAN10

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN21

ip address 10.105.21.250 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

!

!

line con 0

logging synchronous

transport input none

stopbits 1

line vty 0 4

logging synchronous

login local

transport input telnet

line vty 5 15

login

!

end

[/code]

I have this problem too.
0 votes
Correct Answer by glen.grant about 1 year 11 months ago

  Does it let you shutdown the vlan 1 SVI and then do a no shut on the vlan 21 SVI ?  You won't be ablle to ping it unless the vlan 21 is in  a admin up state. 

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Reza Sharifi Sat, 04/28/2012 - 12:20

Did you also create layer-2 vlan?

vlan 21

name test

also you need to add this vlan to the trunk port

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

this way all vlan are part of the trunk

HTH

Reza Sharifi Sat, 04/28/2012 - 12:40

Is anything connected to interface interface FastEthernet0/1?

can you post "sh ip int bri fa0/1"?

ciscohite Sat, 04/28/2012 - 12:45

true... The VLAN interface wont come up until you have something connected to some port in that VLAN. atleast 1 port in that vlan has to be up.

Regards,

Pawan Sharma

http://www.ebrahma.com

glen.grant Sat, 04/28/2012 - 13:28

   The SVI  should be up if the layer 2 vlan was actually created seeing that you have all vlans allowed across the trunk . Please post a show vlan  and a show ip int brief . Also do a shutdown on the vlan 1 SVI and a no shut on the Vlan 21 SVI .  You can only have a single SVI active on a Layer 2 only switch , this address is to manage the switch only and has no function in any routing , I assume there is another device doing the routing for vlan 21. If you have a device on F0/1 it should be able to get outside if the trunk is up and active , you just won't be able to manage the switch as long as the SVI for  for vlan 21 is in a shutdown state.

zerobitsolutions Sat, 04/28/2012 - 13:46

there is a device plugged into fa0/1 but it can not connect anywhere.  also that port is part of vlan21 and vlan 21 is still down. even after issuing no shut

[code]

poeswitch#sh vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5,

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,

                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,

                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,

                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,

                                                Fa0/22, Fa0/23, Gi0/1, Gi0/2

10   VOICE                            active

21   NETWORK/SERVERS                  active    Fa0/1

30   WORKSTATIONS                     active

40   QA                               active

[/code]

glen.grant Sat, 04/28/2012 - 13:48

What is the pc default gateway set as ?  It should be the address of whatever device is doing the routing for vlan 21 .  Has all the configuration for the routing for vlan 21 been completed on the device that is doing the routing? If you do a show int trunk does it show vlan 21 as being allowed acros the trunk ?

zerobitsolutions Sat, 04/28/2012 - 13:58

the switch does not have sh int trunk command.  yes the pc has the default gw set on it, but it wont matter if vlan21 is administratively down.

glen.grant Sat, 04/28/2012 - 14:08

  Your assumption is not correct that SVI can be down and it still should be able to get out if the trunk is working ok . That has nothing to do with routing on the 3500 , it is being routed elsewhere , it is for switch management only so you can telnet to the switch.  Your pc gateway should not be pointed at the address on the 3500 ..  What happens if you do a shutdown on vlan 1 and then a no shutdown on vlan 21 ?  Vlan1 has to be shutdown first before doinmg a no shut on vlan 21.   That is a very old switch and one of the first that cisco ever created and they work a little different than current IOS switches.   It's possible that being so old that vlan 1 can only be used to manage the switch but that should not keep you from having a device in vlan 21 trunked out to the  L3 or router that is doing the routing for vlan 21.

zerobitsolutions Sat, 04/28/2012 - 14:08

all vlans are down down except for vlan1 which i dont want to use

[code]

poeswitch#sh ip int brief

Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol

VLAN1                      unassigned      NO  unset  up                    up

VLAN10                     unassigned      YES unset  administratively down down

VLAN21                     10.105.21.250   YES manual administratively down down

VLAN30                     unassigned      YES unset  administratively down down

FastEthernet0/1            unassigned      YES unset  up                    up

FastEthernet0/2            unassigned      YES unset  up                    up

FastEthernet0/3            unassigned      YES unset  up                    up

[/code]

zerobitsolutions Sat, 04/28/2012 - 14:12

Now I can get out to the internet on fa0/1 but i can not ping the 21.250 ip which is need in order to telnet/ssh into the switch.

Correct Answer
glen.grant Sat, 04/28/2012 - 14:14

  Does it let you shutdown the vlan 1 SVI and then do a no shut on the vlan 21 SVI ?  You won't be ablle to ping it unless the vlan 21 is in  a admin up state. 

Actions

Login or Register to take actions

This Discussion

Posted April 28, 2012 at 12:12 PM
Stats:
Replies:13 Avg. Rating:5
Views:682 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 14,997
2 8,150
3 7,725
4 7,083
5 6,732
Rank Username Points
175
84
70
59
55