Remote Desktop/Access shared files over PPTP VPN

Answered Question
Apr 29th, 2012

Hello,

I just bought the RV180W so I can connect to my office computer from anywhere as a VPN client. The two things I need to do while I am connected as a VPN client is to be able to access my files on my office desktop and be able to remote desktop to it as well. I have Win7 on all of my computers. Ideally, I would like to do that over PPTP VPN connection but if that is not possible I can try Cisco QuickVPN software.

I enabled PPTP on my router and created a user account. I was also able to successfully establish the connection remotely. While I was connected as a PPTP VPN client, I was able to access the Internet and my router setup page which is telling me that the connection is good. However, I was not able to either discover my office PC under my network tab in Win7 nor I was able to remote desktop. I keep my office PC on all the time and it never go to sleep. I did not create any connection policy but maybe this is the problem. Please let me know if you know of a solution.

Thanks!

I have this problem too.
0 votes
Correct Answer by davidagu about 2 years 10 months ago

Hello Mustafa,

It looks like your tunnel is working. To answer your questions:

-Microsoft naming, or NetBIOS, does not go across the tunnel. This is why you need to use the IP address of your computer and cannot see it in Network Places.

-Unless you have, and can configure, a DNS server on your local network, you will need to use IP addresses in order to access resources when connected with our small business routers. Therefore, SSL would be the same way.

Let me know if you have any other questions.

Correct Answer by davidagu about 2 years 10 months ago

Greetings Mustafa,

Thank you for writing.

Were you accessing the router configuration using the public IP address or the local IP address when you were connected to the PPTP tunnel? You can test the tunnel by connecting and then pinging the local IP address of the router or a computer.

You will want to ensure that the addresses you configure for the PPTP users do not conflict with your DHCP addresses. You do not need to configure any policy with PPTP.

Also, in order to access files across the tunnel, you need to map the drive using the IP address. For example, \\192.168.1.101\MyFiles

Once we verify your tunnel, access issues can then be troubleshooted. If you have further problems, consider giving us a call at 1-866-606-1866. We will be happy to assist you.

Regards,

-David Aguilar

Cisco Small Business Support Center

1-866-606-1866

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Correct Answer
davidagu Sun, 04/29/2012 - 21:37

Greetings Mustafa,

Thank you for writing.

Were you accessing the router configuration using the public IP address or the local IP address when you were connected to the PPTP tunnel? You can test the tunnel by connecting and then pinging the local IP address of the router or a computer.

You will want to ensure that the addresses you configure for the PPTP users do not conflict with your DHCP addresses. You do not need to configure any policy with PPTP.

Also, in order to access files across the tunnel, you need to map the drive using the IP address. For example, \\192.168.1.101\MyFiles

Once we verify your tunnel, access issues can then be troubleshooted. If you have further problems, consider giving us a call at 1-866-606-1866. We will be happy to assist you.

Regards,

-David Aguilar

Cisco Small Business Support Center

1-866-606-1866

mustafa.homs Mon, 04/30/2012 - 20:31

Hi David,

Thank you for the response.

I was able to access the router configuration using the local IP address (in my case 192.168.1.1). I don't think I would have been able to access it using the public IP address since I have the router remote management feature disabled.

Now after reading your email, I was finally able to remote desktop and access shared files through a PPTP VPN connection. Here is what I did:

1- I separted the PPTP VPN IP address range from my DHCP range (in my case, PPTP VPN range is 192.168.1.200 to 210 and my DHCP range is from 192.168.1.100 to 199)

2- I assigned my office desktop PC that I am trying to remote desktop to a fixed IP address (192.168.1.20)

3- For remote desktop, I had to type the IP address (192.168.1.20). Typing the PC name (officepc) or searching for was not working.

4- For shared files, I had to map a network drive as //192.168.1.20/My Pictures for example. I couldn't find my PC when searched for it under Network.

After doing all that, I was able to do kinda what I wanted. Ideally, I would have liked to avoid using fixed IP addresses and be able to access computers by their name and see them under the Network tab. Is their a way to do this? I noticed that RV220W offers SSL VPN, would that help me?

I would appreciate it if you could answer my last two questions.

Thanks!

Mustafa

Correct Answer
davidagu Tue, 05/01/2012 - 13:12

Hello Mustafa,

It looks like your tunnel is working. To answer your questions:

-Microsoft naming, or NetBIOS, does not go across the tunnel. This is why you need to use the IP address of your computer and cannot see it in Network Places.

-Unless you have, and can configure, a DNS server on your local network, you will need to use IP addresses in order to access resources when connected with our small business routers. Therefore, SSL would be the same way.

Let me know if you have any other questions.

Actions

Login or Register to take actions

This Discussion

Posted April 29, 2012 at 7:22 AM
Stats:
Replies:3 Avg. Rating:5
Views:5679 Votes:0
Shares:0

Related Content

 

Discussions Leaderboard