OSPF neighbourship

Answered Question
Apr 30th, 2012

HI,

I have maintaining point to point radio and fiber connectivity and just installed a new radio point to point connection, i am facing problem as ospf neighbour ship of new connection continously goes down and up.

I try to trouble by debug hello massages on both routers and saw that one router cant able to recive hello masages in timely manner.

Kindly help in this regards.

Regards,

Arshad

I have this problem too.
0 votes
Correct Answer by Nandan Mathure about 1 year 11 months ago

Configuration looks fine. Is there a possibilty of multicasts getting blocked / dropped somewhere? 

lets check what others think as well.

Nandan Mathure

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Giuseppe Larosa Mon, 04/30/2012 - 06:41

Hello Arshad,

check with an extended ping test if you have connectivity issues on the new radio link.

if you get losses on the ping test you may need some work done on the radio link.

Increasing the OSPF timers could lead to a stable OSPF adjacency, but if the link has an high error rate user traffic is likely to be affected.

Hope to help

Giuseppe

arshadkhan2006 Wed, 05/02/2012 - 03:47

Hi Giuseppe,

Extended point to point ping working fine on both end, as i observed one router act as DR and other act as DROTHER on this specific WAN connection where as routers ospf priorities are default i-e "1".

Kindly advice.

Regards,

Arshad Ahmed

Bharat Negi Wed, 05/02/2012 - 05:09

Hi Arshad

Seems you have connected radio link on ethernet interface.  If yes, please add "ip ospf network point-to-point" command under interface on both end routers.  It will change the state of neighborships from DR/DROTHER to Full/-.

For neighborships flaps, you need to further troubleshoot and share debugs.

Regards

Bharat

arshadkhan2006 Thu, 05/03/2012 - 02:18

Dear All,

I am sharing you debug results as one router succussfully recieve HELLO massages and remain OSPF neighbour ships while other router not properly recieve hello massages and hence its dead time become expire and after expiration of few seconds its again make OSPF neighbour ships.

Regards,

Arshad Ahmed

Nandan Mathure Thu, 05/03/2012 - 21:56

Hi Arshad,

Could you paste configs and debug output on both ends? thanks,

Nandan.

arshadkhan2006 Fri, 05/04/2012 - 21:50

Hi Nandan,

Mention below are aggregation Layer 3 switch configuration which sucessfully maintain ospf neighbour ship.

interface Vlan960

ip address 192.168.3.73 255.255.255.248

ip ospf cost 50

int fa 0/5

switchport access vlan 960

switchport mode access

router ospf 10

router-id 2.2.2.2

log-adjacency-changes

network 192.168.3.0 0.0.0.255 area 0

show ip ospf neighbour

Neighbor ID     Pri   State           Dead Time   Address         Interface

192.168.1.18      1   FULL/DR         00:00:32    192.168.3.77    Vlan960

Mention below are Far End Router configuration which continues to decrease its dead times till its end and hence ospf neighbour ship become flap

interface Vlan960

ip address 192.168.3.77 255.255.255.248

ip ospf cost 50

int fa 6

switchport access vlan 960

switchport mode access

router ospf 10

router-id 192.168.1.18

log-adjacency-changes

network 192.168.3.72 0.0.0.7 area 0

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   FULL/DROTHER    00:00:24    192.168.3.73    Vlan960

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   FULL/DROTHER   00:00:01    192.168.3.73    Vlan960

Neighbor ID     Pri   State           Dead Time   Address         Interface

Correct Answer
Nandan Mathure Sat, 05/05/2012 - 04:03

Configuration looks fine. Is there a possibilty of multicasts getting blocked / dropped somewhere? 

lets check what others think as well.

Nandan Mathure

arshadkhan2006 Sun, 05/06/2012 - 04:06

Hi Nandan,

I have also terminate links on two separate routers and applied same configuration on routers with out any access control lists so i think ospf multicast not gonna block..

If u think multicast gonna block so kindly tell me where they gonna block .

Regards,

Arshad Ahmed

mohsin-raza Sun, 05/06/2012 - 07:02

I heard about some radio links which come with ethernet links and their native vlan is enabled. here is what i suggest.

- Try to make the fa0/5 on first router ad fa0/6 on second router trunk links. Clear the OSPF process and see the neighbor ship.

Alternate solution could be

You mentioned you have 2 seperate routers, try to use a routed port, i.e. assigning the ip directly on the interface.

If you could check with your radio link provider if the vlans are same on both sides of radio link, if there are any.

If this does not solve the problem, then please share the output of "debug ip ospf events" from the router that is getting timed out.

Please rate if this helps.

regards,

Mohsin

arshadkhan2006 Sun, 05/06/2012 - 23:17

Hi mohsin,

Vlans are not tagged in radios so they are running on native vlan and i have also tested by terminated both links on routers layer 3 ports and faced same flaping issue.

Regards,

Arshad Ahmed

Giuseppe Larosa Mon, 05/07/2012 - 02:43

Hello Arshad,

in order to understand if there is an issue with link local multicast packets on the radio link you should configure the two routers in such a way that they move to unicast OSPF hello packets.

This can be done by using an appropriate OSPF network type like non-broadcast or point-to-multipoint non-broadcast in interface configuration mode. Neighbor commands under router ospf are needed because multicast discovery is disabled.

interface vlan 960

ip ospf network non-broadcast

router ospf

network

neighbor x.x.x.x

where x.x.x.x is the IP address of the other router at the other end of the radio link

You have to configure in similar way on the other router

if OSPF still flaps the link has impairments, if OSPF becomes stable the problem was with multicast hello packets not propagated in one direction causing the flapping.

Hope to help

Giuseppe

arshadkhan2006 Mon, 05/07/2012 - 05:40

Hey,

Problem has been solved by enbleing mutlicast traffic on radio links.

Thanks all of you for responding.

Regards,

Arshad Ahmed

Actions

Login or Register to take actions

This Discussion

Posted April 30, 2012 at 12:30 AM
Stats:
Replies:14 Avg. Rating:5
Views:1368 Votes:0
Shares:0
Tags: ospf
+

Related Content

Discussions Leaderboard