cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4602
Views
0
Helpful
2
Replies

IPV6 and IPV4 ACLs

bryantsteve
Level 1
Level 1

                   As we begin  deployment  IPV6 we are going to be in a mixed IPV4/6 environment - we have required access lists  implemented for IPV4 and must applty the same ACL defined for  for IPV6. Is it possible to apply IPV4 and IPV6 access lists concurrently on an interface or is a single access list containing both IPV4 and IPV6 addresses called for?

1 Accepted Solution

Accepted Solutions

stmillet
Cisco Employee
Cisco Employee

You will need to have concurrent ACLs applied to an interface.

The access lists are address familiy specific in their syntax and features so they cannot be mixed. An indicative example is shown below.

!

interface Ethernet1/1

ip access-group test-v4 in

ipv6 traffic-filter test-v6 in

!

ip access-list extended test-v4

permit ip any host 1.1.1.1

deny   ip any any

!

ipv6 access-list test-v6

permit ipv6 any host 2001:DB8::1

deny ipv6 any any

!

View solution in original post

2 Replies 2

stmillet
Cisco Employee
Cisco Employee

You will need to have concurrent ACLs applied to an interface.

The access lists are address familiy specific in their syntax and features so they cannot be mixed. An indicative example is shown below.

!

interface Ethernet1/1

ip access-group test-v4 in

ipv6 traffic-filter test-v6 in

!

ip access-list extended test-v4

permit ip any host 1.1.1.1

deny   ip any any

!

ipv6 access-list test-v6

permit ipv6 any host 2001:DB8::1

deny ipv6 any any

!

bryantsteve
Level 1
Level 1

Thanks that was what I was looking for as I was worried about having two inbound access lists applied to the same interface

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: