Macbook takes long time to get IP address from UC540

Unanswered Question
Apr 30th, 2012

We have installed a UC540 at a client site and everything is working fine.


However, sometimes when the client plugs his Macbook into the network using an ethernet cable, it takes up to 25-50 seconds before the OS recognizes that it is plugged in and starts the DHCP process.  If the cable is unplugged and replugged again, it will sometimes be recognized immediately and then get an IP address.


The client tried the Macbook at home and it worked normally - found connection and started DHCP immediately.

Is there anything on the UC540 that could be preventing the laptop from connecting immediately?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
iroehm Tue, 05/01/2012 - 12:16

Hello,

What is the topology of the network? Is there a switch in betweent the Mac Book and the UC540? If so what switch is it?

Isaac

ensemblecustom Tue, 05/01/2012 - 18:41

Yes, sorry, that's important information.  Duh.

The Macbook is plugged into a Cisco SF200-24  switch, which is connected to the expansion port of the UC540.

I'm thinking maybe it's a delay in the spanning tree setup.  I know how to configure portfast using CLI,  maybe there is an equivalent way to do it using the GUI of the SF200 - honestly I just thought of this and have not had a chance to try it out.

Thanks for the help.

iroehm Wed, 05/02/2012 - 07:49

I would check in CCA and make sure that the Smartports are configured properly on the UC. Configure>Switching>Smartports. Make sure the Expansion port is set to Switch, the Native VLAN is 1 and the configuration is applied and saved. Also check in the Web GUI for the switch under Smartport>Interface Settings that when the laptop is plugged in the Smartport Type is set to Default (which is desktop/laptop VLAN 1). I set it up at my desk with my MacBook Pro and it took just a few seconds for it to recognize it. However, I have had your issue on other networks so it may be something with the MacBook. If you try the other settings could you try plugging the laptop directly into the UC? (Make sure the Smartport type for that port is set to Desktop or IP Phone/Desktop).

Actions

Login or Register to take actions

This Discussion

Posted April 30, 2012 at 10:01 PM
Stats:
Replies:3 Avg. Rating:
Views:657 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard