VRF 'default'

Unanswered Question
May 1st, 2012

Hi All,

I'm looking to create a Vendor VRF on one of my 3945E routers. I have my 'default' VRF running eigrp with all my branches. I have created a subinterface to my WAN, and assigned the interface to the vrf VENDOR.

I have EIGRP running across my default routing table and EIGRP running across the VRF. This part I don't have a problem with.

I am wondering how I can get routes from my VENDOR vrf into the 'default' vrf on the router. I know I can accomplish this via route-target importing / exporting via the VRFs, but since I'm using the default vrf on the router, how can I get routes from my VENDOR vrf into my regular VRF? I have control of the router at the vendor location, I just want to keep is seperated 'just in case'.

Router in question: 2x 3945E 15.2-2

Remote 'vendor site' router: 1921, 15.2

3900 Config:

ip vrf VENDOR

rd 10:1000

interface FastEthernet0/1.96

bandwidth 100

description Vendor WAN VLAN

encapsulation dot1Q 96

ip vrf forwarding VENDOR

ip address 192.168.96.1 255.255.255.0

ip summary-address eigrp 10 0.0.0.0 0.0.0.0 5

router eigrp 10

passive-interface default

no passive-interface FastEthernet0/0

no passive-interface FastEthernet0/1.95

no passive-interface FastEthernet0/1.96

network 192.168.95.0 0.0.0.127

network 192.168.100.8 0.0.0.3

no auto-summary

!

address-family ipv4 vrf VENDOR

  network 192.168.96.0

  no auto-summary

  autonomous-system 10

exit-address-family

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Sergey Fer Sun, 05/06/2012 - 04:23

route-targets are simply BGP communities, therefore you need to have MP-BGP set up to exchange routes between VRFs through RTs. Another method is to use PBR but this method is restricted to only static routes. For EIGRP you simply need to remove VRFs and use route filtering through distribute-lists, route-maps or something else.

Actions

Login or Register to take actions

This Discussion

Posted May 1, 2012 at 9:32 AM
Stats:
Replies:1 Avg. Rating:
Views:1085 Votes:0
Shares:0
Tags: eigrp, vrf
+

Related Content

Discussions Leaderboard

Rank Username Points
1 14,997
2 8,150
3 7,720
4 7,078
5 6,723
Rank Username Points
175
80
60
59
55