WAP4410N - Understanding roaming, WDS, repeater, bridge

Unanswered Question
Apr 30th, 2012

Router: Cisco WRVS4400N secured with WPA2
WAP: Cisco WAP4410N

Router was working well but signal too weak in distant rooms.

So, purchased a WAP4410N but am unsure about AP configuration. From reading the docs, I understand these to be the relevant choices:

1) Access Point -- Wired connection through built-in Ethernet port. (Not Desired)

2) Wireless WDS Repeater

3) Wireless Client / Repeater (What is difference from WDS Repeater?)

4) Wireless WDS Bridge

Desired Result:
Simply extend the network. As a laptop is carried from room to room, laptop should switch to the strongest signal seamlessly, without user doing anything manually. No matter where I am, laptop should see entire network. Also, I prefer that the WAP not require a wired Ethernet connection (that is, I would like the WAP to receive/repeat the router's wireless signal No Ethernet Cable Required).

1. Which of the above 4 settings is best for achieving desired outcome?

2. What should the SSID be on the WAP? Same as on the router?

3. Should both the router and WAP be on the same channel? (I suspect not, but included docs sound like they should be..?)

4. Should both the router and the WAP have the same wireless security setting (WPA2) and passphrase?

5. On the router, under the Wireless menu --> WDS submenu there is a checkbox: "Allow wireless signal to be repeated by a repeater".  I assume this must be checked?

6. I understand that Microsoft's built-in Wireless Zero Configuration service does not disambiguate APs which share the same SSID and may not always roam with the strongest signal.*** We need to move from area to area and seamlessly retain the network signal. Is this still a problem in Windows7? Is there a workaround for XP's WZC deficiencies?

Is there anything else I should know?

*** http://www.wi-fiplanet.com/tutorials/article.php/3628576

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
rocater Tue, 05/01/2012 - 14:48

Hello bcmitsupport,

I am glad to hear you got it working. I did notice though that you said the WAP4410N was wired. If the repeater is working correctly you should not have to have it wired.

If you do have the option of using a wired connection then I would recommend the following-

AP mode is AP

Same SSID

Same Security

Different wireless channel (1, 6, 11 are the non overlap channels)

This provides the strongest signal and speed between both wireless points.

If you are interested in trying the repeater mode still I recommend the following-

AP mode is WDS repeater

Same SSID

Same Security

Same wireless channel

On the router enable 'allow this signal to be repeated'

Make sure you are using both wireless MAC addresses for the wireless *NOTE: the MAC listed on the router is not always the wireless MAC. this can be found in the wireless section of both devices.

Here is the key part, if you are using both as a repeater and the AP is wired, you will know it is working when your network goes down. This is because the AP is repeating the signal back to the router over the wire and getting it repeated back out over the wireless until the network goes down.

To further answer your orginal question-

WDS mode provides a better connection as both devices are 'aware' of each other and is more of a switched connection. When using client/repeater, the AP is actually acting like a client to the orginal signal and simply relaying messages across as if it was from the AP.

WDS bridge is simply a way to configure a wireless bridge. A bridge is not designed for clients to connect wirelessly but to create a 'wireless cable' so you can connect your wired computer wirelessly.

Ultimately the best connection is a wired one as it does not diminish the signal. A repeater has half the range and half the speed as it has to repeat both in and out.

bcmitsupport Thu, 05/03/2012 - 12:50

Thank you very much for your reply and for clarifying the advantage of a wired WAP over a wireless WDS.

Initially, did attempt to configure the connection as a WDS, and configured it as you specified above:

  • WAP AP Mode: configured as WDS repeater
  • WAP AP Mode: used the SITE SURVEY button to add the MAC address of the router
  • Router WDS menu: Enabled "allow signal to be repeated"
  • Router WDS menu: Manual
  • Router WDS menu: used SITE SURVEY button to add the MAC address of the WAP
  • Same SSID on both
  • Same Channel on both

1. As configured above, could not get laptops to "jump" over to the WAP.  That is:

  • Connected to wireless network at router (main AP).
  • Walked away from router (diminishing signal) toward WAP. Signal continued getting weaker.
  • Walked past WAP. Signal weaker still.
  • Signal never "jumps" over to WAP.

Tried manual disconnect/reconnect, but signal strength remained weak suggesting laptop was still connecting via the main router. Can you see anything I missed?

2. I did not understand this. Could you please simplify? (And aren't both units APs?)

>Here is the key part, if you are using both as a repeater and the AP is  wired, you will know it is working

>when your network goes down. This is because the AP is repeating the signal back to the router over

>the wire  and getting it repeated back out over the wireless until the network  goes down.

Thank you.

rocater Thu, 05/03/2012 - 13:07

I have drawn up a diagram. Please forgive me for the horrible picture but it should help demonstrate what I am referring too.

Packet is broadcast from a wireless client and it hits the AP. From there it follows the path of going out the port at 1 and gets to the router. The router then broadcasts the packet out over the wireless at 2. The AP gets the wireless broadcast and repeats it out 1 as though it came from a wireless source. This flow can of course happen in reverse as well.

This loop continues until all you have are a ton of broadcasts being sent over and over. I hope this further explains what I was talking about.

If you are having an issue with getting the repeater working, then I would suggest giving our support center a call. Before doing that, make sure all devices are on the latest firmware.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

bcmitsupport Tue, 05/01/2012 - 14:08

Got it working, but it was a bit of an effort to make WDS roaming work correctly. Here's what worked for me:


  1. Same SSID on Router/AP and WAP
  2. Different channel on each (otherwise a laptop's wireless NIC won't switch over to the WAP)
  3. Same security and password (I used WPA2 Personal, successfully)
  4. I had to give the WAP a hard-wired Ethernet connection. My  preference was to simply repeat the wireless signal, but I was  unsuccessful getting that to work.
  5. On my router (WRVS4400N), I had to enable a setting called "Allow  wireless signal to be repeated by a repeater." (Found under Wireless  menu, WDS submenu)
  6. My WAP (WAP4410N) has a menu called AP MODE. The setting that worked  is "Wireless WDS Repeater" and it requires that I specify the MAC  address of the router/AP.
  7. I should also note that under Setup menu --> Advanced submenu, I enabled "Force LAN Port Speed to 100M" as per other posts


Phases: Initially, I set the WAP to use a different channel and  different SSID and got that working. In this config, I had to manually  disconnect from the Router SSID, and connect to the WAP one. But it  worked, and it proved I was getting Internet access through the WAP, via  the router/AP. Only then did I set them to the same SSID and have  successful roaming.


Final Result: As I move from area to area, I watch the main router's  wireless signal grow weaker, until it automatically jumps over to the WAP and goes to 5  bars.

Actions

Login or Register to take actions

This Discussion

Posted April 30, 2012 at 2:40 PM
Stats:
Replies:4 Avg. Rating:
Views:3687 Votes:0
Shares:0
Tags: No tags.