Clear type ahead buffer in VXML - Call Studio 8.5

Answered Question
May 3rd, 2012

Hi,

I'd like to take control of the type ahead buffer within my VXML script developed in Call Studio.

So far the only thing I could find about it is a reference to a VXML prompt attribute, but nothing about how it can be set in Call Studio. Has someone successfully used this? If yes, can this be set within Call Studio?

Thanks,

Attila

http://www.cisco.com/en/US/docs/ios/voice/vxml/developer/guide/refgde1.html#wp1049198 says:

"cisco-typeaheadflush Attribute for <prompt>

The default value of cisco-typeaheadflush is false. A false value means that the typeahead buffer is not flushed after the prompt plays out. If the prompt is bargeinable, the digit which barges in is not flushed.

"

I have this problem too.
0 votes
Correct Answer by geoff@hp.com about 1 year 11 months ago

So you could just insert an audio element with a short WAV file of silence that is bargeable to swallow the type-ahead and then they cannot barge in on the special audio element that you want them to hear in entirety.

Regards,

Geoff

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
geoff@hp.com Thu, 05/03/2012 - 04:25

Type ahead is what most callers want. This means they can navigate through a menu tree to child nodes by typing a couple of digits at the top level.

"The VoiceXML specification does not provide information on explicit control over the type-ahead buffer. The type-ahead buffer is always enabled when a call comes in. "

But it does seem that Cisco provide the ability to do this in the IOS Voice Browser. So set the VXML property "com.cisco.typeaheadflush" to "true" on the audio element.

Regards,

Geoff

adancso Thu, 05/03/2012 - 05:20

Thanks Geoff,

I'll give it a go.

The use case is when optional (bargeable) prompts are played to the caller and are followed by an important message (non bargeable). Without clearing the buffer the non bargeable prompt is just skipped.

Attila

geoff@hp.com Thu, 05/03/2012 - 06:04

OK, I understand. I hope this works - I have never tried that VXML property.

Regards,

Geoff

adancso Thu, 05/03/2012 - 06:45

I have tried it saving as Element Data and as Session Data. Neither of those worked. I guess because they are vxml properties and not prompt attributes.

According to the VXML dev docs it should be a prompt level attribute, just like the barge in statement.

bargeable prompt

I guess the generated VXML should look like:

bargeable prompt

The problem is that the only option at that level in Call Studio is the barge setting.

I know this can be achieved using micorapps using a microapp config parameter... I'm just looking for a way of doing the same in VXML.

adancso Thu, 05/03/2012 - 09:15

I've tried configuring it in the settings tab just like you had on the screenshot with both com.cisco.typeaheadflush and the cisco-typeaheadflush too.

Unfortunately the non bargeable prompt is still skipped after a bargeable prompt having those set.

Shall I be thinking of writing my custom Audio element for this?

This is the generated VXML by the way:

http://www.w3.org/2001/vxml" version="2.1" application="/CVP/Server?audium_root=true&calling_into=Barge_Test" xml:lang="en-GB">

 

 

 

   

     

     

     

   

 

 

   

      bargeable prompt

     

     

   

 

Correct Answer
geoff@hp.com Thu, 05/03/2012 - 11:15

So you could just insert an audio element with a short WAV file of silence that is bargeable to swallow the type-ahead and then they cannot barge in on the special audio element that you want them to hear in entirety.

Regards,

Geoff

adancso Thu, 05/03/2012 - 11:43

Yes, I think without custom code the only way doing this is adding a Silent Menu/Form with a 1 sec timer. Not great, I'll keep looking.

Actions

Login or Register to take actions

This Discussion

Posted May 3, 2012 at 1:32 AM
Stats:
Replies:8 Avg. Rating:5
Views:1089 Votes:0
Shares:0

Related Content

Discussions Leaderboard