WLC5508 with LAP1142N ignoring Radio Policy

Unanswered Question
May 3rd, 2012

Hi..

I've got a weird problem with the WLC5508 and LAP1142Ns..

We have a few WLANs using all radios.. And also one that is set to only use 802.11g.. however.. a lot of clients using that WLAN are shown as using 802.11a for connection.. (Apple iPad2 devices).. some use g, but most of them go in with a.

why?

I tried rebooting the iPad.. turning off and on the WiFi.. resetting the LAP that it was connected to.. resetting the Networksetting on the iPad..

all the things I could think of where a dormant setting might have hidden..

it just doesn't care.. always in the client list with protocol 802.11a...

help.. I want the iPads on g...

Thank you..

  Thomas

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (6 ratings)
grabonlee Thu, 05/03/2012 - 08:14

Hi

On the controller, could you confirm what Radio policy is enabled under the WLAN SSID.

humelectronics Thu, 05/03/2012 - 09:02

Thank you for replying..

Yes.. positively set.. see screenshots..

and the Client Monitor..

don't understand that at all..

Stephen Rodriguez Thu, 05/03/2012 - 09:08

Go and look at that mac from the client summary, and double check what AP and radio the device is on.

There is the possibility that it's being reported/shown on the wrong radio, if the iPad had been on another WLAN and just moved to this one.

Steve

humelectronics Thu, 05/03/2012 - 09:17

The iPad is configured to only connect to this WLAN..

Client summary says it's connected to an "AP Type: 802.11a"

Another weird thing: I have WMM disabled on the QoS of the WLAN.. but the Summary says: "Power Save Mode: ON"

had that set before resetting Networkconfiguration and reconnect to WiFi with the iPad.. also before doing a reset on the LAP..

It's like settings are ignored?

Thomas

grabonlee Thu, 05/03/2012 - 13:22

Thomas,

What code version are you using? Could you do the following one after the other and report what happened.

1. Under RRM, set 11Mbps data rate to disable or supported and set the 18Mbps rate to Mandatory. Note this will make all 802.11b clients not to connect to the AP.

2. disable 802.1a from the command using config 802.11a network disable.

If the above works, you can create RF profiles and map them to AP groups so that 11g clients can connect to certain APs.

humelectronics Fri, 05/04/2012 - 00:34

Unfortunately I can't do that atm.. many other WLANs on the WLC.. can't interrupt service..

for now I can only do "surgical" changes to the mentioned AP and WLAN.. no general settings, esp. not things that would cause downtime to clients.

I will try that adjustment when I can.. will probably be a while, though..

Leo Laohoo Thu, 05/03/2012 - 14:56

Under the client summary, can you post the iPad's MAC address?  I want to make sure.

Steve,

This wouldn't have anything in related to the Apple Sticky Mac authentication bug?

Leo Laohoo Fri, 05/04/2012 - 02:14
I can't see a reason to post a MAC address??

I want to make sure the clients that you are seeing are INDEED MACs and not someone who's accidentally getting the password to the SSID.

Don't know with you but alot of us just want to verify everything. 

tglaser Tue, 05/08/2012 - 00:03

hi

i have the same problem with my wlc5508 and air-lap1142n-e-k9 since upgrade to 7.2.103.0.

wlan 6 is configured "g-only":

>show wlan 6

WLAN Identifier.................................. 6

..................

Radio Policy..................................... 802.11g only

but a lot of clients are connected by 11a radio:

>show client summary

Number of Clients................................ 84

MAC Address       AP Name           Status        WLAN/GLAN/RLAN     Auth Protocol         Port Wired

00::xx                xxx-AP1142-6-2    Associated                        Yes  802.11g          13   No

00::xx                xxx-AP1142-1-5    Associated    6                      Yes  802.11g          13   No

00::xx                xxx-AP1142-6-3    Associated    6                      Yes  802.11a          13   No

00:xx                xxx-AP1142-6-3    Associated    6                      Yes  802.11g          13   No

00::xx                xxx-AP1142-5-3    Associated   6                      Yes  802.11a          13   No

00:xx                xxx-AP1142-5-1    Associated    6                      Yes  802.11a          13   No

00::xx                xxx-AP1142-1-5    Associated    6                      Yes  802.11a          13   No

00::xx                xxx-AP1142-1-6    Associated    6                      Yes  802.11a          13   No

00:xx                xxx-AP1142-1-7    Associated    6                      Yes  802.11g          13   No

is there any solution for this problem?

thanks tom

grabonlee Tue, 05/08/2012 - 01:06

Hi Thomas Glaser, l made some suggestions above about disabling dot11a and setting dot11g rates which the other guy didn't confirm if it worked. Could you please do the same and see if it works.

humelectronics Tue, 05/08/2012 - 01:39

Hi Osita..

"The other guy" couldn't confirm if it worked yet..   I had to temporarily leave the facility and will not be back there to test for about two weeks..

However.. it's interesting that Thomas Glaser posted his softwareversion.. as I have exactly the same.. (7.2.103)

At least I'm not alone..

Cheers,

  Thomas

tglaser Tue, 05/08/2012 - 02:08

hi

i have already 12mbit as mandatory speed to block 11b clients.

11a radio cannot be disabled because on the same controller/accesspoints there is a second  wlan configured

11a-only for voice clients.

greetings

tom

grabonlee Tue, 05/08/2012 - 07:22

Hi

I decided to create the same set up with 1131 and 1141 and found no problem connecting with the specified radio type. My controller is also on 7.2.103. Please take a look below. In my opinion probably there is an issue with 1142 APs, which is strange as the AP downloads its code and WLAN config from the Controller. Secondly, I would suggest that you take a look at the wireless adapter configuration of the client to ensure that it's radio type is set to Auto and not default to dot11a, b, or g.

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.2.103.0
Bootloader Version............................... 1.0.1
Field Recovery Image Version..................... 6.0.182.0

(Cisco Controller) >show wlan 2


WLAN Identifier.................................. 2

Radio Policy..................................... 802.11g only


(Cisco Controller) >show client summary

Number of Clients................................ 21

MAC Address       AP Name           Status        WLAN/GLAN/RLAN Auth Protocol         Port Wired
----------------- ----------------- ------------- -------------- ---- ---------------- ---- -----


00:1f                    xx-03             Associated   2              Yes  802.11g          13   No


Would you like to display more entries? (y/n) 

              
(Cisco Controller) >show ap config general xx-03


AP Model......................................... AIR-LAP1141N-E-K9 

(Cisco Controller) >show client summary

Number of Clients................................ 22

MAC Address       AP Name           Status        WLAN/GLAN/RLAN Auth Protocol         Port Wired
----------------- ----------------- ------------- -------------- ---- ---------------- ---- -----


00:1f                  AP0007.xxx.xx04  Associated    2              Yes 802.11g          13   No


(Cisco Controller) >show ap config AP0007.xx.xx04


AP Model......................................... AIR-LAP1131AG-E-K9 

(Cisco Controller) >show wlan 2


WLAN Identifier.................................. 2

Radio Policy..................................... 802.11a only


(Cisco Controller) >show client summary

Number of Clients................................ 24

MAC Address       AP Name           Status        WLAN/GLAN/RLAN Auth Protocol         Port Wired
----------------- ----------------- ------------- -------------- ---- ---------------- ---- -----

00:1f:xx         AP0007.xxxx.xx04  Associated    2              Yes  802.11a          13   No

00:40:xx        AP0007.xxxx.xx04  Associated    2              Yes  802.11a          13   No

humelectronics Wed, 05/30/2012 - 23:51

Osita..

Thank you very much for your effort, really appreciated. I have not been able to do more testing on that site as things have changed a lot and the restriction is not needed any longer.

However, from your results and both our experiences I do think it's a fairly safe assumption that the 1142N has problems with the 7.2.103.0 software.

Cheers,

Thomas

grabonlee Thu, 05/31/2012 - 02:08

Thomas,

Before we conclude that there is a problem with 1142 and 7.2.103 software, there might be another logical explanation why some clients show 802.11a protocol instead of the enforced 802.11g protocol on the WLC.

Recall that 1142N is a dual band radio i.e 2.4GHz and 5GHz. Most wireless devices scan the 5.4GHz freq range before scanning the 2.4GHz. 802.11a works on 5GHz  while 802.11g works on 2.4GHz. However, both protocols use the same modulation scheme (OFDM) and support the same data rates 6,9,12,18,24,36,48, and 54Mbps.

Bearing the above in mind, apart from frequency difference, 802.11a and 802.11g are basically the same. Hence, I would suggest as a final test that you should disable the 5GHz freq on the 1142N AP and see if the clients shift to 11g protocol. If that works then there is no problem with the 1142N and 7.2.103 WLC.

Cheers

humelectronics Thu, 05/31/2012 - 03:17

Osita..

Of course, if I disable the 5GHz antenna, all clients are going to connect with g (well, b/g/n), there's no other choice.. I did that as a workaround, but it naturally had an impact on the desired network structure (for the other WLANs)..

That is where the policy for the radios should have come into play, but was ignored.

Before the software update, things worked for the other thomas. So there must be a connection with the version.. and since your two different WAPs don't show the problem, a compatibility issue between the 7.2.103 software and 1142N WAP seems to be the plausible explanation..

Cheers,

  Thomas

saravlak Sun, 06/03/2012 - 23:57

#Are you using AP group

#Did you recently update the code that triggered this issue.

tglaser Mon, 06/11/2012 - 23:43

hello

in my case i use ap groups and the problem exists since upgrade from 7.0.98.0 to 7.2.103.0

greetings

tom

saravlak Tue, 06/12/2012 - 10:51

Can you take off an affected AP from AP group and see that makes a difference. if so then you're hitting

CSCty61970. Move to latest 7.2 that has fix for it.

WLC>show wlan apgroups

Do you see 'none' instead of 'G-only' for Radio policy, if so use the workaround to fix it for now.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCty61970

workaround:-

WLC>config wlan apgroup radio-policy 802.11g-only

tglaser Sat, 06/16/2012 - 04:57

hello

i had to delete and reconfigure all apgroups showing  radio policy "ALL"

works fine now

thanks a lot

greetings

tom

tdennehy Sun, 10/21/2012 - 06:41

Thomas,

When you had to delete and reconfigure all ap groups showing radio policy of ALL, did you have to take each AP and remove the AP Group from it first?

I am running into this same problem, and it has taken six weeks to get someone to admit there was a problem.  Now that I have found your post, I know I'm not crazy!

I was thinking that it might be easier to create a new AP Group with a new name and just move the APs to it.  I did move some APs to the default group and then back again, but that did not rectify the issue.

saravlak Sun, 10/21/2012 - 10:00

This behavior is different for old and new version, since do not know what wlc version you're using try - When you delete the AP group if it warns to remove APs, then yes it expects to remove the APs to different group. If no warning then those APs will be moved to default group and deletes the name.

Issue affects the AP group profile, so bouncing the AP btw groups won't help here.

humelectronics Tue, 06/19/2012 - 05:29

I was also using AP Groups.. since then, though the whole network has been changed and the AP Groups have been removed.. also the need to have a radio policy in place has become obsolete..

I believe that your post would have solved my problem then, too..

Thank you very much..

Thomas

saravlak Mon, 06/18/2012 - 19:43

don't think it is 1140 specific issue.

do you've rf profile configured?

to isolate the confusion, Use one 1142 & other N AP that is not 1142.

Use inssider or netstumbler on A/G capable client and see whether the ssid in question broadcasting or not.

saravlak Mon, 06/18/2012 - 19:52

1141 is single band g/n, a-radio client can't connect.

1130 might connect client on a-radio since that wlan is mapped to a-radio only which is not the config case with 1142.

njstoops@anl.gov Tue, 04/02/2013 - 12:27

I have the exact same problem using the AIR-CT5508-K9 controller (7.3.101.0 version) and 115 LAP1142N AP's.  They all report the client protocol using 802.11an even though the radio policy is set to "802.11g only" on the SSID.  Anyone have any additional as to why?

Actions

Login or Register to take actions

This Discussion

Posted May 3, 2012 at 7:48 AM
Stats:
Replies:27 Avg. Rating:5
Views:3410 Votes:0
Shares:0

Related Content

Discussions Leaderboard