Help on Redirection from Port to Port for RDP

Unanswered Question
May 3rd, 2012

Hi - I have a ASA which I will post the config down below.

Basically everything is working as normal however I have just been told we have another server at host 10.10.1.3 which needs to be accessed over the external IP through RDP on port 3399 which then redirects to Port 3389 if that makes sense.

So currently I have the ASA internal IP 10.10.1.1 and outside let say 5.5.5.5 - I have a Server at host 10.10.1.2 which works perfect for RDP on port 3389 when I connect through 5.5.5.5 but since I now need to RDP to a second server 10.10.1.3 through 5.5.5.5 I need to be able to tell the user to connect to 5.5.5.5:3399 which then will connect to 10.10.1.3:3389 and that would leave the normal 5.5.5.5 connecting to 10.10.1.2 on the normal 3389

Hope that makes sense - I have replaced a old DLINK which basically redirected anything on 5.5.5.5:3399 to 10.10.1.3:3389

Result of the command: "sh conf"

:
!
ASA Version 8.4(2)
!
hostname asa03

names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif webserve
security-level 100
ip address 10.10.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 5.5.5.5 255.255.255.248
!
boot system disk0:/asa842-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
name-server 24.92.226.11
name-server 24.92.226.12
object network SigmaCareTest1
host 38.121.224.242
description SigmaCareTest1
object network SigmaCareTest2
host 64.52.47.2
description SigmaCareTest2
object network a-10.10.1.2
host 10.10.1.2
object service a-http
service tcp source eq www
object service tcp-80
service tcp source eq www
object network InsideNat
subnet 0.0.0.0 0.0.0.0
object network WebServeNat
subnet 0.0.0.0 0.0.0.0
object service RDP-3389
service tcp source eq 3389
object network Testrdp
host 24.97.114.162
object service ftp-20
service tcp source eq ftp-data
object service ftp-21
service tcp source eq ftp
object network ser-rdp
host 10.10.1.3
object service rdp-3399
service tcp source eq 3399
object-group network obj_any
object-group network DM_INLINE_NETWORK_2
network-object object Testrdp

network-object object SigmaCareTest1
network-object object SigmaCareTest2
object-group service DM_INLINE_SERVICE_1
service-object object ftp-20
service-object object ftp-21
access-list outside_in extended permit tcp object-group DM_INLINE_NETWORK_2 host 10.10.1.2 eq 3389

pager lines 24
logging enable
logging asdm informational
mtu webserve 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (webserve,outside) source static a-10.10.1.2 interface service tcp-80 tcp-80
nat (webserve,outside) source static a-10.10.1.2 interface service RDP-3389 RDP-3389
nat (webserve,outside) source static a-10.10.1.2 interface service ftp-21 ftp-21
nat (webserve,outside) source static a-10.10.1.2 interface service ftp-20 ftp-20

!
object network WebServeNat
nat (webserve,outside) dynamic interface
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 5.5.5.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 10.10.1.0 255.255.255.0 webserve
no snmp-server location
no snmp-server contact
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp authenticate
ntp server 64.90.182.55 source outside prefer
webvpn

class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:1b8599ddfd217044ab2dbdc7e63febbd

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mayrojas Thu, 05/03/2012 - 21:13

Go it!

Here,

nat (webserve,outside) source static a-10.10.1.2 interface service rdp-3399 RDP-3389

access-list outside_in extended permit tcp any host 10.1.1.2 eq 3389

Try it out, if it doesnt work send us the packet tracer output

packet-tracer input outside tcp 4.2.2.2 1025 5.5.5.5 3399

Mike

Actions

Login or Register to take actions

This Discussion

Posted May 3, 2012 at 10:32 AM
Stats:
Replies:1 Avg. Rating:
Views:477 Votes:0
Shares:0
Tags: rdp, redirection
+

Related Content

Discussions Leaderboard

Rank Username Points
1 7,866
2 6,140
3 3,170
4 1,473
5 1,446