3524XL Voice Vlan odd issue

Unanswered Question
May 3rd, 2012

I have an odd one:

I'm setting up my CCIE lab, I get my CUCM and CME working no issues with IPC.

Then I get to the second portion, add a CME with a couple of 7940's, they won't get DHCP? So I try everything and finally remove the switchport voice Vlan command and then they start working.

CDP is enabled, I can ping the CME / DHCP server and it's not on a subdot1Q because I got frustrated and flattend the network . Checked spanning tree (Or what passed as spanning tree on this switch).. Check all sorts.

Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Tim Smith Thu, 05/03/2012 - 15:26

Hi,

So if you flattened it then you do not need a voice vlan.

If you want to set it up with a voice vlan, best to share your original config of router and switch.

You should have .1q trunk between rtr and sw. Are your dhcp scopes on the rtr? If not then you need helper addresses.

Config is slightly different on those older switches. I think you actually need to set the port as a trunk as well.

Cheers,

Tim

Sent from Cisco Technical Support iPhone App

wilson-danny Thu, 05/03/2012 - 16:22

Hey Tim,

It was kind of obvious I wouldn't need voice vlan once I flattend it, I did try a trunk,

Config was just standard stuff I've done hundered's of times, just got the 3524XL today. I suppose I've been pampered in the work place with 3750's and Catk 6 / 4K's.

I had a 1760, Vlan DB on both (Vlan 100) subdot1Q fa0/0.100 (encapsulation dot1q 100) on the 1760 with an IP address. From this I could ping everywhere (PC etc.), the basic setup is switch and router with a router on stick config with DHCP set up. Nothing more, I tried switchport voice vlan 100 and still nothing more. Switchport voice vlan and dot1p is part of Cisco official documentation, after I flattend the network just testing I tried dot1p as well. Oh I also had an IP helper, used the native switch IP DHCP server command etc. etc.

Luis Gustavo Al... Thu, 05/03/2012 - 16:32

If you set the port to access on the voice vlan and connect a PC do you get an IP on the voice network?

What CDP version are you running?

Luis A.

acampbell Fri, 05/04/2012 - 02:11

Danny,

3524 switches are nearly as old as me  

You need to use the "vlan data" command to create vlans etc

Here is a wee sample

!

vlan data

vlan 11 name DATA

vlan 511 name VOIP

exit

!

conf t

!

hostname MY3524

!

enable secret CISCO

!

enable password CISCO

!

ip subnet-zero

!

udld enable

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 11

switchport mode trunk

switchport voice vlan 511

switchport priority extend cos 0

spanning-tree portfast

no shut

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 11

switchport mode trunk

switchport voice vlan 511

switchport priority extend cos 0

spanning-tree portfast

no shut

!

The config/admin guide is at this link

http://www.cisco.com/en/US/docs/switches/lan/catalyst2900xl_3500xl/release12.0_5_wc5/swg/scg.html

HTH

Alex

Please rate useful posts

Ayodeji oladipo... Fri, 05/04/2012 - 02:22

+5....Spot on Alex. I have one of those oldies..and they only work with the trunk configs as you stated..

Actions

Login or Register to take actions

This Discussion

Posted May 3, 2012 at 1:43 PM
Stats:
Replies:5 Avg. Rating:5
Views:843 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,036
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
116
105
98
66
62