RV110W Port Forwarding Still Broken in Firmware

Unanswered Question
May 4th, 2012
User Badges:

I installed firmware version a couple weeks ago after seeing in the release notes that the port forwarding bug where clients would get 'no route to host' was resolved (one of the original posts found here: https://supportforums.cisco.com/message/3512354).

After installing the firmware and confirming it's running I've seen no improvement. I still must reboot my router 2-3 times daily so clients can access the ports that are defined in the port forwarding module.

Please take another look at this - the issue is not resolved and as far as I can tell it hasn't even been improved. Please also let me know of any beta firmwares - anything to put this issue to bed. It's been going on far too long.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
itcconcepts Sat, 05/05/2012 - 08:49
User Badges:

We have had the same experience, RV110W now back in its box.

chchapma Mon, 05/07/2012 - 16:30
User Badges:
  • Cisco Employee,

When you upgraded the firmware from to did you perform a full factory reset using the hardware reset button on the back of the router?  If you have not performed a hard reset of the RV110W after upgrading to v1.2.0.9, it is strongly recommended that you reset the device by holding down the reset button for 10 seconds to ensure the device is completely reset.  This will ensure the configuration is erased and you are working from the default config based on the new firmware image.  We have tested the RV110W against this issue and we have routers running for the last 30+ days with port forwarding working correctly.  If you cannot get it working consistently after the hard reset then please open a case with the SBSC TAC so we can begin the process of getting all of you network topology and router information.  Please keep us posted on your progress.

blwright Mon, 05/07/2012 - 18:03
User Badges:

Instead of configuring port forwarding rules, configure Access Rules. Once the setting has saved you will see your new rule under port forwarding.

Blake Wright

Cisco SBSC Network Engineer

Bruce halco Wed, 06/13/2012 - 08:57
User Badges:

I'm also having this problem, even after upgrading to  I lose Remote Management at the same time, so I always have to call the site to have someone restart the router.

I'm trying the Access Rules approach now.  The lack of response  from chchapma to the last post makes me think it took care of things for him. I'm wondering if it will cure the Remote Management failure also?

blwright Wed, 06/13/2012 - 09:55
User Badges:


What port are you using for remote management? If you are using a non-standard port for remote management this could cause a problem. Typically the routers are managed on 443, 60443, 80, or 8080. If are using one of the 4 ports previously mentioned and are still having problems, I would suggest calling 1.866.606.1866 to open a support ticket.

Blake Wright

Cisco SBSC Network Engineer

Bruce halco Mon, 06/18/2012 - 06:19
User Badges:

Yes, I generally use a different port to reduce exposure to port

scanning. Is this related to the port-forwarding bug?


xtravirt666 Sun, 06/24/2012 - 02:29
User Badges:

Is anyone from Cisco actually working on this ? I'm fed up with rebooting the router every hour, and doing so for the last 2 months is not helping me being any less frustrated. I would really appreciate if someone at least replied to a post in over a year. And no, access rules are not a resolution to a fix you implemented in the router and is not working like it should. I did not buy this router to change rdp ports on 25 workstations. It's really a shame because everything else on the router is working perfectly and i'm really happy with it....just let people know you're either working on it or can't fix it so we can return the faulty gear and move to something that actually works.



chchapma Mon, 06/25/2012 - 11:10
User Badges:
  • Cisco Employee,

From my previous post from 5/7/12:

"When you upgraded the firmware from to did you perform a  full factory reset using the hardware reset button on the back of the  router?  If you have not performed a hard reset of the RV110W after  upgrading to v1.2.0.9, it is strongly recommended that you reset the  device by holding down the reset button for 10 seconds to ensure the  device is completely reset.  This will ensure the configuration is  erased and you are working from the default config based on the new firmware image.  We have tested the RV110W against this issue  and we have routers running for the last 30+ days with port forwarding  working correctly.  If you cannot get it working consistently after the  hard reset then please open a case with the SBSC TAC so we can begin the  process of getting all of you network topology and router information.   Please keep us posted on your progress."

Bruce halco Mon, 06/25/2012 - 14:53
User Badges:

Actually I did a hard reset *before* the firmware upgrade.  Following the upgrade I restored the configuration from a backup file.

Additionally, using a defined Access Rule without the corresponding Port Forward results in no port forwarding at all.   Use of both together has had me running for 2+ weeks now.  Promising, but not yet conclusive.

xtravirt666 Mon, 07/09/2012 - 07:42
User Badges:

Yes i did perform a full factory reset using the button at the back of the device. Tried to define access rules (which don't allow me to configure different external ports to same internal ones), and it doesnt work either. I'm planning on replacing the router with a linksys WRT160N with dd-wrt firmware which allows me do what i want and works like it should.

itcconcepts Mon, 07/09/2012 - 07:54
User Badges:

Recently tried the 110W again (it was the only box I had available).

A hardware reset, followed by simple configuration with static IP and 5 port forwarding rules - ran for 4 days before SMTP communication on port 25 stopped. A reboot bought it back to life.

Back in its box, again.


Bruce halco Sat, 07/14/2012 - 07:04
User Badges:

Following up: I have had two boxes running for a month with no problem. One is as described above with, but the other still has with the same configuration that gave me trouble in the first unit.  The one common change I made to the two was to change the remote management port from a high port to 443.  Seems like the non-standard remote management port uses port forwarding internally, and triggers the firmware bug somehow.

Bruce halco Wed, 08/08/2012 - 05:22
User Badges:

Further followup - a few days ago the problem occurred on the system.  So it was some 6-7 weeks between problems.

These two installations were the pilot locations for a larger rollout.  Unfortunately they have failed the pilot test and I now have to find a suitable alternate.

mattmicci Wed, 12/26/2012 - 11:42
User Badges:

Have you talked to Cisco and are they in works on a firmware update for this model. I have issues with being able to get email inbound and remote management working with and have done a factory reset after reconfiguring.  It seems my device needs rebooted every 6 weeks and nothing appears in the logs.  I am about to just tell my client ASA5505 is the way to go.  Small Business support has already replaced the unit and i am convinced it is a bug in the firmware.  I do have about 4 other clients with these devices and no problems and they also run SBS 2008 and 2011 servers.

Bruce halco Fri, 12/28/2012 - 06:37
User Badges:

Cisco seems to be of the opinion that there is no problem with their product.

I have been dragging my feet on a number of installations because I'd really like to use this router, but I just can't trust it yet. I have 7 of them out there, and honestly only one is giving me trouble. That one happens to be behind a DSL modem,  the others are on T1 lines.  So I'm tempted to blame it on DSL somehow, except that it takes a router reset to recover.  Resetting the DSL modem does nothing.

I had opportunity to install another RV110W in a DSL system about a month ago, and so far no problem, but it's too soon to draw a conclusion.  The new one is AT&T DSL, the older one is Frontier (previously Verizon).  I'm waiting and watching on that one.

wrongdriver Mon, 09/17/2012 - 00:25
User Badges:

We are using port forwarding for running a security cameras.

I configured everything as you recommend it this post, but it will work from an hour to two days, then fails. (until reboot)

When will the new RV110W firmware be released?


Bruce halco Thu, 08/22/2013 - 08:19
User Badges:

I know it's been a while, but I decided to follow the suggestion to  call 1.866.606.1866 and open a support ticket (I held off because frankly, my  expectations are low).

When I get to the point of being transferred to a person, I get a error message telling me "The number was not recognized".  What do I need to do to open a support ticket?

Alex_aka_Lupo Wed, 08/01/2012 - 07:10
User Badges:

Dear mr.Blake Wright,

Thanks a lot for your tip, even if there is not exactly like you said ))

When I tried to create Access Rule device offered to create Service first. And after creating Service and Access Rule I didn't "see my new rule under port forwarding" - I had to create it there too.

Anyway, to make working port forwarding, you must follow these three steps:

1) create Service, describing used port range and type of traffic;

2) create Access Rule that allow traffic for this Service;

3) create Port Forwarding Rule for each IP and port you need.

And, imho, it's better to reboot device after all of that

aautomate Wed, 01/16/2013 - 06:10
User Badges:

Is Cisco ever going to fix their firmware?   We had two of these ship from the reseller with the latest firmware already installed.  After a couple days the port forwarding fails.  Solution is to reboot.  Cisco support has been very difficult to deal with and they seam to think that this is not a problem. 

I have the same problem with this router. We did the firmware update, then factory reset and rebuilt our configuration. I still find the port forwarding failing every couple of days - in fact this morning, it failed twice within a few hours.

This is unacceptable. There is obviously a problem with this model and its firmware. Do I have to buy a different brand of product to fix this issue?

Gene O'Brien

Technology Service of Long Island

I do face the same problem with four of these same devices, each one sits behind a ViaSat satellite modem and I also

need to reboot them 2-3 times daily so clients can access the ports that are defined in the port forwarding module.

Its really annoyning when something so basic as port forwarding its not a standard for all expensive Cisco products

Stelios Neroladakis

Technical Administrator


Simon Yelfimov Mon, 04/22/2013 - 07:46
User Badges:

I have the same exact issue and have performed all troubleshooting steps from this forum. Still, the router needs a reboot every week.

I followed every piece of advice, every possible remedy, every fix I could find, and it still kept losing the configuration. I was at a point where I was getting phone calls from my end user nearly every day that he couldn't access his network remotely, and the cause was broken port forwarding. I would reboot the router remotely (I have a different remote access tool), and it would all start working again.

I wound up replacing the router with a different brand. Guess what - it's worked flawlessly for about a month now.

The RV110W is just not a very good router. Simple enough.

Gene O'Brien
Technology Service of Long Island

Simon Yelfimov Mon, 04/22/2013 - 08:29
User Badges:

At this pace I may end up eating router price and replce with something else (and never use it again, probalby would go back to using DD-WRT firmware with homegrade routers). However, I've put in some changes just now trying to find where the programmers F**k up is. So far my debugging process:

- Made all the port labels match b\w Access rules and Firewall

- Removed redundant port forwards b\w Single and port Range

- Removed all Logging from Access rules

I'll let everyone know if there are any changes.

Matthew Ritchie Tue, 12/10/2013 - 12:51
User Badges:

Similar issue. The router continues to do NAT translation and allows outbound and inbound traffic. The PROBLEM is:

Port Forwarding Rules fail randomly. In my case the failure occurs almost every 50-60 days in operation. The only solution is to reboot the box, then everything bis back to normal.  This is now December 2013 and I notice Cisco has not put out any additional firmware to correct this issue?

Cisco:  You cant ONLY provide support to people who buy your top of the line equipment. Those are the same people who encourage customers to put small business products in too, and when we see them fail miserably, it then makes us questions your top line equipment for use in our client networks.  I would encourage you to provide a full resolution to this issue, for the sake of people who use your equipment on a regular basis.

Zhaoqiang Wang Tue, 12/10/2013 - 20:40
User Badges:
  • Cisco Employee,

Hi, if anyone meet this issue, please open a case to L2 support who will deliver you a new firmware. The port forwarding codes are redesigned in the new firmware. Thanks.

Bruce halco Thu, 12/12/2013 - 13:51
User Badges:

Do you have a way to contact Cisco Product Support?

The Cisco website says "1-866-606-1866 Small Business Support Center", but that number is not in service.

Bruce halco Fri, 12/13/2013 - 04:37
User Badges:

Right. That page gives the same out-of-service phone number for the United States.

cindy toy Fri, 12/13/2013 - 11:40
User Badges:
  • Gold, 750 points or more

Hi Bruce,

I just tested the numbers for the United States and they are working. Where are you calling from?

Cindy Toy
Cisco Small Business Community Manager
for Cisco Small Business Products
twitter: CiscoSBsupport

Bruce halco Fri, 12/13/2013 - 15:15
User Badges:

Calling from Cleveland, Ohio. The number is working now, but definitely gave me a not-in-service message this morning. I tested just now with redial to make sure I hadn't misdialed earlier.

I've had previous occasion to call that number, and got auto-transferred to some other non-workling number, so I assumed the worst.

I did go through a Cisco Live Chat this morning, and I'm expecting to be contacted by L2 support regarding firmware.

Jeff Gandy Mon, 12/16/2013 - 15:05
User Badges:

Same issue as the others.  Product installed about 14 months ago, VPN accounts, port forwarding for 80.  Product worked until a few weeks ago when we installed a security system requiring the opening of two additional ports.  Product would completely lock out all incoming requests every 3-5 days.  No VPN, no remote management, no port forwarding.  Only solution is a hard reset or reboot from the interface on the LAN.

Contacted Cisco per the instructions above.  33 minutes on the phone with two different people, finally I have been promised this will escalate to L2 and they will call me back.....?

This is a known problem, the firmware should be available for download.  I have had a lot of Cisco products and have been a loyal customer for many years, but this product has cured me.  The wireless performance was so bad I could not connect at 40 feet in clear line of sight, but an additional access point fixed that issue.  The port forwarding problem is critical and I can only wait a day or so before replacement.

Jeff Gandy Thu, 12/19/2013 - 11:10
User Badges:

Firmware was received and flashed yesterday.  After it was installed I let it run till today and went over to do a full reset and then reconfig.  For now there are only 3 ports being forwarded.  VPN was not reconfigured, just the basic LAN/WAN settings until I can see if this will solve the issue.

Jeff Gandy Sat, 12/28/2013 - 09:51
User Badges:

Update:  After approximately 10 days the unit has continued to function normally with the basic settings.  Sometime after New Years I will take the time to complete the full configuration and see if it will continue to work without error.

Zhaoqiang Wang Wed, 01/01/2014 - 21:42
User Badges:
  • Cisco Employee,

Dear all, A new RV110W firmware is online. Please check out.

AndrewGrDMS Mon, 02/17/2014 - 11:34
User Badges:

Dear Zhaoqiang Wang,

thank you for your update!

I noticed new firmware version ( and already cheked it on my RV110W.

I can inform that - Single Port Forwarding is not working!

My steps were:

1. Flash new firmware

2. Reset to factory defaults

3. Set it up again from scratch

Single port forwarding was not able to operate.

After several tries and resets - I had to flash back the firmware version.

P.S. Port range forwarding looks like can forward connections...

Any ideas what is wrong with Single Port Forwarding?

UPDATED: after some efforts we figure out what was wrong.

mpyhala Mon, 02/17/2014 - 15:00
User Badges:
  • Gold, 750 points or more


According to the release notes, Port Forwarding should be fixed in this version (long term). Certainly it should work in the short term. Did you test it immediately after you upgraded the firmware or did you factory default the router and reconfigure it right away? I have not seen any reports of port forwarding failing since the new firmware was released.

I recommend that you upgrade the firmware and test without changing the configuration. If it fails to work properly, open a support case so our engineers can take a look: www.cisco.com/go/sbsc

- Marty

Zhaoqiang Wang Mon, 02/17/2014 - 21:00
User Badges:
  • Cisco Employee,

Hi Andrew

Can you check your private messages box? I sent a message to you. Thanks.

AndrewGrDMS Tue, 02/18/2014 - 04:35
User Badges:

Hi all,

after some efforts from Zhaoqiang Wang we found out that actually Single Port Forwarding is operating properly.

Only behaviour of port forwarding is changed a little bit in fw in comparison to previous one when accessing Single Port Forwarding resources from internal vlans (like vlan1 - default).

From external network - everything works fine!

Thanks to Zhaoqiang for support! )

mpyhala Tue, 02/18/2014 - 07:29
User Badges:
  • Gold, 750 points or more


Thanks for the update!

- Marty

Bruce halco Tue, 03/11/2014 - 04:28
User Badges:
I applied to 17 routers and have had no problems for two months now. It appears that the problem may at long last actually be fixed.
ddavis883 Wed, 06/04/2014 - 07:34
User Badges:

Hate to re-open an older topic, but I have installed, I did a factory reset afterward and reconfigured the router. It seemed to go away for a while, but I'm still having issues with ports closing up.

Since Cisco had already acknowledged a problem by creating, I would be curious to know the details of the fix, as in what were they doing to cause this to happen? This is important because I may be able to apply it to my usage of the router and determine if there is anything I can do with my traffic to avoid the condition.

Nobody else is still having issues?


Aleksandra Dargiel Wed, 07/02/2014 - 23:18
User Badges:
  • Silver, 250 points or more

Hi Dan,

I am sorry to hear that you are still having problem. The scenario when the issue was recreated it is related to the IP settings of the host (static IP or DHCP reservation). It would be quite interesting to see your network packet capture  when problem occurs. You might install Wireshark (or any other packet sniffer) on the server during the time it is not accessible and run when there is a problem. If you would like any advise on the packet capture please feel free to email me in private message

Or perhaps open support case with our Small Business Center engineer. For your reference contact list: 








This Discussion

Related Content