CME: Issue with calls from Polycom IP 7000 to IP phone over H.323 VoIP trunk

Answered Question
May 7th, 2012

Hi team,

I have a Polycom IP 7000 registered to Call manager express using SIP. This Call manager express in our branch office is integrated with  Call manager (in central site) via H.323 trunk. The required dial-peers from CME to Call manager have been configured. I am able to call other CME SCCP phones from the IP 7000 and vice versa.

Also, I am able to call the IP 7000 from an IP phone registered to Call manager via H.323. However, I am not able to call an IP phone registered to call manager from the IP 7000 (registered to CME) i.e., when I call an SCCP IP phone registered to Call manager from the IP 7000 (registered to CME using SIP) over the H.323 VoIP trunk, the call is ringing on the Call manager phone, but even if I answer that call on the call manager phone, the call keeps ringing on the IP 7000. The IP 7000 is not detecting that the call has been answered by the call manager phone.

If I use SIP VoIP trunk between CME and CUCM instead of H.323, then calls are working fine between CME phone and CUCM phone in both directions. Attaching the “sh version” and “running-config” of the CME (in cme-ver-runn.txt” file)  and the debugs of “debug ccsip calls’ and “debug cch323 all” collected during call from IP 7000 to CUCM phone (which is not working) in the file ip7000-debugs.txt.

Could you please help me fix this issue? Please let me know if you need more details here.

Regards,

Swati

I have this problem too.
0 votes
Correct Answer by marmugam about 1 year 11 months ago

Hello Swati,

Call is hitting this dial-peer102  to CCM. I thik you have removed the "voice -class h323 1"  as it is configured for slow start, if not please remove there.

//

dial-peer voice 102 voip

preference 1

max-conn 3

destination-pattern 7[49]...

session target ipv4:149.77.224.210

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

voice class h323 1

  h225 timeout tcp establish 3

  call start slow

!

// And release complete is coming from CCM with the casue code 47. (Resources unavailable). And for some reason, I dont see h245 asn1 messages. Did you enable "debug h245 asn1".

//  I am still thinking Gateway is using slow start, as in fast start 245 messages will be exchanged much earlier. But here CCM is instructing the Gateway, about the h245 TCP port address in "Connect Message".

May 12 11:44:07: //119/9BED78C2805F/H323/validate_crv:

May 12 11:44:07: H225.0 INCOMING ENCODE BUFFER::= 22C0060008914A000500954DE0D2DD6422C0B50000120F436973636F43616C6C4D616E616765720031009BED78C29B5E11E1805FEDC5CBCE81C61D0C0011009BED78C29B5E11E18061EDC5CBCE81C60100010010A00100120140B50000120B8204020004000103000100

May 12 11:44:07:

May 12 11:44:07: H225.0 INCOMING PDU ::=

      {

        h323-message-body connect :

        {

          protocolIdentifier { 0 0 8 2250 0 5 }

          h245Address ipAddress :

          {

            ip '954DE0D2'H

            port 56676

          }

++ Can you please make sure h245 asn1 was enabled, and also make sure call start slow is removed from voice class h323.

// If you have already done that,  then enable the following debugs one morre time; (included some new debugs)

From GW:-

++ debug ccsip message

++ debug h225 asn1

++ debug h245 asn1

++ debug voip ccapi inout

++ debug cch323 all.

++ debug h245 events

++ debug h225 q931

++ debug h225 events

++ debug voip ipipgw

CCM:-

Detailed CCM logs from all the nodes.

Thanks,

Murali

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (5 ratings)
Adrian Saavedra Mon, 05/07/2012 - 21:17

Hi,

This could be due to the use of SIP Early offer and Fast start not configured on H.323 gw (Device -> Gateway) in UCM. SIP CME phones defaults to SIP early offer and early offer to slow start is not supported. You can try checking Enable Fast Start in the H.323 gateway defined in UCM (Device -> Gateway).

Hope it helps, please rate if it does.

Regards,

- Adrian.

swati-singh Mon, 05/07/2012 - 21:47

Hi Adrian,

I have tried enabling "Enable Inbound FastStart" in the H.323 gateway config of our Call manager., but call from SIP IP 7000 to call manager phone is still not working. Same issue mentioned in my first update.

Do I need to make any changes to the CME config? I have uploaded it in the 1st update.

Regards,

Swati

Luis Gustavo Al... Mon, 05/07/2012 - 21:40

Ok. The disconnect cause is 47 = resource unavailable which normally is a codec negociation issue. It looks like your prefer codec coming from Polycom is G.729 and you prefer codec to CUCM is G.711.

When you call from Polycom to CME phone what codec are they talking?

When you call from CME phone to CUCM phone what codec are they talking?

Easy test, just make all of them use the same codec.

- Luis A.

swati-singh Mon, 05/07/2012 - 23:00

Luis,

From the debugs "debug cch323 all" and "debug ccsip all", it looks like in both cases, the negotiated codec is g711ulaw.

I have attached the debugs. The file cme-to-cme-debugs is call from CME IP 7000 SIP phone 77180 to CME phone 77131.

The file cme-to-h323 is call from CME IP 7000 SIP phone 77180 to CUCM phone 79381 (over H323).

Could you please check these once?

Regards,

Swati

Adrian Saavedra Mon, 05/07/2012 - 23:21

Hi Swati,

Return your CME to fast start (e.g. no call start). And check Enable Inbound Fast Start in your h.323 gw in UCM.

Test a call again.

Regards,

- Adrian.

swati-singh Mon, 05/07/2012 - 23:50

Adrian,

It is still not working. I have configured voice service voip ->h323-> call start fast in CME and checked the Enable inbound FastStart in CUCM. Please let me know if I am missing something.

Regards,

Swati

Adrian Saavedra Tue, 05/08/2012 - 07:24

Hi Swati,

Try unchecking Wait for Far End H.245 Terminal Capability Set in the h323 gw in UCM and let's see what happen. Remember to delete everything regarding call start slow from your CME.

Regards,

- Adrian.

marmugam Tue, 05/08/2012 - 09:30

Hello Swati,

++ Make a test call and capture the following debugs

++ debug ccsip message

++ debug h225 asn1

++ debug h245 asn1

++ debug voip ccapi inout

++ debug cch323 all.

Thanks,

Murali

marmugam Tue, 05/08/2012 - 12:23

Hello Swati,

I had the same symptoms when I didn't select inbound fast start in CCM. As IP-IP GW doesnt support SIP EO to H323 SS.  When selected the inbound fast start in h323, it started to work again. So make sure you remove "call start slow" from the configuration and enable inbound fast start in h323, save and reset the GW. In the above thread you mentioned, you have already done that, so the above debugs from GW will shed more light and if needed we can check CCM tarces too once we isolate the issue is from CCM.

HTH,

Murali

swati-singh Sat, 05/12/2012 - 04:46

Hi Murali,

For some other purpose, I have now upgraded CME  version from 8.6 to 9.0. I have removed "call start slow" from the CME  config and enabled "Inbound fast start" in CCM GW config. Still, I am  seeing the same issue.

Could you please help here? I have attahed the required CME debugs. The extension of IP 7000 registered to CME is 77180 and the extension of CUCM phone is 79381.

Please let me know what debugs we need from the CCM?

Regards,

Swati

swati-singh Sat, 05/12/2012 - 05:03

Hi Adrian,

I just saw your update asking me to disable the "Wait for Far End H.245 Terminal Capability Set" in CUCM GW. I have done this and observed a difference. Call from CME IP 7000 (x77180) to CUCM phone (79381) is now getting established i.e., if I answer the call on CUCM phone, the IP 7000 stops the dial-tone; basically call is getting established. However, voice trasfer is not happening between the 2 phones and the call is getting automatically disconnected in a few seconds.

Attaching the debugs.

Please suggest.

Regards,

Swati.

Correct Answer
marmugam Sat, 05/12/2012 - 05:58

Hello Swati,

Call is hitting this dial-peer102  to CCM. I thik you have removed the "voice -class h323 1"  as it is configured for slow start, if not please remove there.

//

dial-peer voice 102 voip

preference 1

max-conn 3

destination-pattern 7[49]...

session target ipv4:149.77.224.210

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

voice class h323 1

  h225 timeout tcp establish 3

  call start slow

!

// And release complete is coming from CCM with the casue code 47. (Resources unavailable). And for some reason, I dont see h245 asn1 messages. Did you enable "debug h245 asn1".

//  I am still thinking Gateway is using slow start, as in fast start 245 messages will be exchanged much earlier. But here CCM is instructing the Gateway, about the h245 TCP port address in "Connect Message".

May 12 11:44:07: //119/9BED78C2805F/H323/validate_crv:

May 12 11:44:07: H225.0 INCOMING ENCODE BUFFER::= 22C0060008914A000500954DE0D2DD6422C0B50000120F436973636F43616C6C4D616E616765720031009BED78C29B5E11E1805FEDC5CBCE81C61D0C0011009BED78C29B5E11E18061EDC5CBCE81C60100010010A00100120140B50000120B8204020004000103000100

May 12 11:44:07:

May 12 11:44:07: H225.0 INCOMING PDU ::=

      {

        h323-message-body connect :

        {

          protocolIdentifier { 0 0 8 2250 0 5 }

          h245Address ipAddress :

          {

            ip '954DE0D2'H

            port 56676

          }

++ Can you please make sure h245 asn1 was enabled, and also make sure call start slow is removed from voice class h323.

// If you have already done that,  then enable the following debugs one morre time; (included some new debugs)

From GW:-

++ debug ccsip message

++ debug h225 asn1

++ debug h245 asn1

++ debug voip ccapi inout

++ debug cch323 all.

++ debug h245 events

++ debug h225 q931

++ debug h225 events

++ debug voip ipipgw

CCM:-

Detailed CCM logs from all the nodes.

Thanks,

Murali

swati-singh Sun, 05/13/2012 - 06:13

Thanks a lot, Murali. I will make the suggested changes tomorrow and will update the status.

Regards,

Swati

swati-singh Sun, 05/13/2012 - 22:49

Hi Murali,

I have just removed the "Call start slow" from voice class h323 1 and verified that the issue got fixed.

However, video between any CME phone (Cisco IP phone) and CUCM phone stopped working after I removed the "call start slow".

Even Cisco documentation says "The call start fast feature is not supported with an H.323 video connection. You must configure call start slow for H.323 video".

So, if I remove "call start slow", the issue with IP 7000 is completely fixed, but video between CME phone and CUCM phone is not working.

Could you please suggest here?

Regards,

Swati.

Adrian Saavedra Mon, 05/14/2012 - 07:31

Hi Swati,

Video calls between Polycom and UCM phones work through a SIP trunk?

Regards,

- Adrian.

marmugam Mon, 05/14/2012 - 09:58

Hello Swati,

My expertise in Video is 0, however looking at the documentation, I think h323 fast start is not supported. Or I am not sure,  you we are running into internetworking limitation in IP-IP Gateway itself.

So I think you are running into a design limitation. As sip eo-h323 ss is also not supported. You can check witht he Video telephony forum.

If Polycom end device supports sccp, configure line side to be sccp(telephony-service ) if not and if it is allowed then change the trunk side to sip and check.

Thanks,

Murali

marmugam Mon, 05/14/2012 - 10:41

And we cannot disable SIP EO in CME. So we are running out of gas in this setup.

swati-singh Tue, 05/15/2012 - 22:32

Hi Murali,

I have worked around this issue by configuring in such a way that different outbound dial-peers will be selected for calls from IP 7000 and for other calls between CME and CUCM. The outbound dial-peer related to IP 7000 calls will have "call start fast" and the outbound dial-peer related to other IP phone calls will have "call start fast". So, this fixes our issue.

Thanks a lot for your help here. This issue is now fixed.

Murali, I have actually asked a question related to CME LPCOR in another thread and I did not get any reply. Could you please check https://supportforums.cisco.com/message/3629705#3629705 once and let me know if you know how to achieve this?

Regards,

Swati

Actions

Login or Register to take actions

This Discussion

Posted May 7, 2012 at 8:25 PM
Stats:
Replies:18 Avg. Rating:4
Views:2238 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
159
95
75
66
55