A Basic question on First Hop Redundancy Protocols.

Unanswered Question
May 8th, 2012

Hi Experts,

This may sound to be a very basic question but just came across when surfing through the website.

1. can we configure mutliple Virtual IP's in VRRP / HSRP / GLBP ? if so how many?

2. Any use case for configuring Multiple virtual IP's ?

-Vijay

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Sergey Fer Tue, 05/08/2012 - 05:13

1. Yes, you can configure all of them simultaneously.

2. VRRP and HSRP do not have embedded load-balancing. You may use multiple virtual IPs to load balance traffic in these protocols.

vijay.swaminathan Tue, 05/08/2012 - 05:26

Hi Sergey,

Thanks for your response. sorry if my question wasn't clear.

I meant to ask....

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

standby 1 ip 10.10.10.121

standby 1 ip 10.10.10.122 secondary

standby 1 ip 10.10.10.123 secondary

standby 1 priority 150

standby 1 preempt

here 122 and 123 are secondary Virtual Ip's Just curious to know what could be the purpose of this? and how many like this we could configure?

-Vijay

Message was edited by: Vijay Swaminathan

Sergey Fer Tue, 05/08/2012 - 05:37

Sorry for my miunderstanding...

This thing is analogue of secondary IP not more, not less. What if you have a number of addresses assigned to interface (VLAN, subif, ...) and need to make them redundant? It is for that case.

Sergey Fer Tue, 05/08/2012 - 10:42

Sure. Imagine you have a router and it is configured like this

interface g0/0

     ip address 10.10.10.121 255.255.255.0

     ip address 10.10.10.122 255.255.255.0 secondary

     ip address 10.10.10.123 255.255.255.0 secondary

and all these IPs are default gateways for somebodies.

Next, you wish to create HSRP for acieving redundancy. What to do? Well... You create HSRP with secondaries and voila

Actions

Login or Register to take actions

This Discussion

Posted May 8, 2012 at 5:09 AM
Stats:
Replies:5 Avg. Rating:
Views:328 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,745
4 7,088
5 6,747
Rank Username Points
140
80
78
69
40