Full custom web page on WLC? Not possible?

Answered Question
May 8th, 2012

Hello Guys!

I created a custom web authentication page, and successfully loaded this page on the WLC.

This is working fine

  • But ... when the user press "submit" button and authenticates, the "Default WLC Web Authentication" Pop-up shows up!  "You are now logged in now ... and so on".
  • And if you configure user policy, to let just one user to login at the same time, the second user fails to log in, and is redirected directly to the WLC's Internal Web Authentication page.

Is it possible to disable these pages?

I have this problem too.
0 votes
Correct Answer by Stephen Rodriguez about 1 year 11 months ago

for the first issue.  did you copy in the java script from the test bundle?  Or you can pull it from the default page, right click, view source.  etc.

HTH,
Steve

-----------------------------------------
Please remember to rate useful posts, and mark questions as answered

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
Stephen Rodriguez Tue, 05/08/2012 - 06:57

for the first issue.  did you copy in the java script from the test bundle?  Or you can pull it from the default page, right click, view source.  etc.

HTH,
Steve

-----------------------------------------
Please remember to rate useful posts, and mark questions as answered

EvaldasOu Tue, 05/08/2012 - 07:01

Oh

I think I edited the main internal controller web page that's why.

By the way, Stephen, your answer was so fast! I am stunned!

Stephen Rodriguez Tue, 05/08/2012 - 07:02

you have to be fast around here, otherwise, Scott, George, Leo and Blake get all the answers. 

HTH,
Steve

-----------------------------------------
Please remember to rate useful posts, and mark questions as answered

EvaldasOu Tue, 05/08/2012 - 07:07

Thanks, I will try to find where is a problem in that Javascript , why it tries to do bring up " successfull login" popup.

And what about second user, with username/password that's already in use? I can manage this to function properly too?

blakekrone Tue, 05/08/2012 - 07:14

You could possibly do something with the return codes, look at the ksink example, to not show the login page again.

As for the popup, honestly, most everyone has popup blockers so they never see it anyways!

Scott Fella Tue, 05/08/2012 - 07:16

Is your wlc on version 7.2.103.0 by chance.

Thanks,

Scott Fella

Sent from my iPhone

EvaldasOu Tue, 05/08/2012 - 07:19

Yes, WLC 2504 with this version of code.

We will use two of them ( one for redundancy, if a failure occurs anytime )

Scott Fella Tue, 05/08/2012 - 07:22

Yeah... The JavaScript has some issues. If you type in the credentials and you hit enter button, not the submit, does it default to the Cisco default login page?

Thanks,

Scott Fella

Sent from my iPhone

EvaldasOu Tue, 05/08/2012 - 07:30

No, nothing happens

I can see this : when I am connected to the Access Point, and type the url ( www.google.com) I am redirected to the custom web authentication page, and to the internal authentication login page ( Because this internal page, I get an "succesfull login page" after login). ( Ofcourse at first, I can see just my custom page )

https://1.1.1.1/fs/customwebauth/login.html?switch_url=https://1.1.1.1/login.html&ap_mac=f4:ea:67:63:d9:00&client_mac=00:16:6f:24:94:7d&wlan=SSID&redirect=www.google.com/

Scott Fella Tue, 05/08/2012 - 08:13

This is what I was seeing on the 5508 running 7.2

  • And if you configure user policy, to let just one user to login at the same time, the second user fails to log in, and is redirected directly to the WLC's Internal Web Authentication page.

When you hit the enter key, did you have your cursor in the password input field?

Can you attach your login.tar file?

Scott Fella Tue, 05/08/2012 - 13:44

Well that is an issue with the 7.2. You probably should open a tac case on that, because you shouldn't be redirected to the internal webauth page, and then if you just hit enter, you get redirected back to your custom page.

EvaldasOu Wed, 05/09/2012 - 07:44

Hi guys,

I got some valuable information from cisco TAC today:

"After searching about the option that you want,  I found that the WLC 7.2.103.0 seems to have this new option at CLI:

(Cisco Controller) >config custom-web logout-popup ?

Enable/Disable the Web Authentication logout popup window.

But for versions before this, this feature was not supported."

Scott Fella Wed, 05/09/2012 - 08:00

You get any info on the redirect to the internal page?

Thanks,

Scott Fella

Sent from my iPhone

EvaldasOu Thu, 05/10/2012 - 02:53

As they say, we can't fully disable internal web page right now

Actions

Login or Register to take actions

This Discussion

Posted May 8, 2012 at 6:56 AM
Stats:
Replies:16 Avg. Rating:5
Views:2072 Votes:0
Shares:0
Tags: wlc, web, full, not, page, custom
+

Related Content

Discussions Leaderboard