×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Routing two different networks over one interface using an HWIC on a 2811

Unanswered Question
May 8th, 2012
User Badges:

hello below is my configuration for my router. I have enabled ip routing as well and rebooted my router.


Here is what I can do.


1) I can ping the 10.0.33.x network from the 192.168.123.x network

2) I can get out to the internet using 192.168.123.x network VIA fa 0/2/0


What  I CAN NOT do

1) get out to the internet from 10.0.33.x network. using GW 192.168.123.253?

2) also is it possible to somehow keep this config and route my 10.0.33.x network out int fa 0/0.34 if I put it on a sub interface?




!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/2/0

description to firewall

switchport access vlan 123

no ip address

!

interface FastEthernet0/2/1

description to PC Netowrk 2960 switch fa 47

switchport access vlan 123

no ip address

duplex full

speed 100

!

interface FastEthernet0/2/2

description to PC Network 2960 switch fa 48

switchport access vlan 123

no ip address

duplex full

speed 100

!

interface FastEthernet0/2/3

description to server network

switchport access vlan 33

no ip address

duplex full

speed 100

!

interface Vlan1

no ip address

!

interface Vlan33

description server network

ip address 10.0.33.2 255.255.255.0

no ip-redirects

!


interface Vlan123

description PC network

ip address 192.168.123.1 255.255.255.0

no ip-redirects

!

router ospf 100

log-adjacency-changes

network 10.0.33.0 0.0.0.255 area 0

network 192.168.123.0 0.0.0.255 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.123.253

ip http server

!

!

access-list 101 permit icmp any any

access-list 101 permit icmp any any echo

access-list 101 permit icmp any any echo-reply

access-list 101 permit icmp any any source-quench

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
p.mcgowan Tue, 05/08/2012 - 08:12
User Badges:
  • Bronze, 100 points or more

do you have a route back to 10.0.33.0/24 from your gateway/firewall?


make sure you have a route in your gateway which will point to the 10.0.33.0/24 network, something like this;


ip route 10.0.33.0 255.255.255.0 192.168.123.1

j.pewarski Tue, 05/08/2012 - 08:21
User Badges:

Yes I do believe I have a route back


when I enter the static route

ip route 10.0.33.0 255.255.255.0 192.168.123.1

%Invalid next hop address (it's this router)


should I try my gateway .253 which is my firewall? instead of .1


shouldent OSPF handle this since I have both networks enabled on OSPF?

j.pewarski Tue, 05/08/2012 - 08:30
User Badges:

Are you talking about putting the ip route statement

ip route 10.0.33.0 255.255.255.0 192.168.123.1

in the firewall?

p.mcgowan Tue, 05/08/2012 - 08:32
User Badges:
  • Bronze, 100 points or more

yes, the firewall needs to have a route back to the 10.0.33.0/24 network

Actions

This Discussion

Related Content