It is possible in BGP?

Unanswered Question
May 8th, 2012

Hi,

In my location we have one cisco 1841 router with two ISP(BSNL&Tulip) is connected.

  Both links are mpls and configured in BGP protocol.

  LAN IP : 10.10.110.0/23

  WAN IP : 192.168.3.56/30(Bsnl Link)

   WAN IP : 10.237.69.36/30(Tulip Link)

   Now all systems are working through Tulip link.there is one DVR connectivity and we configured one IP is 10.10.110.111

   My Requirement:

   We want all traffic should go to Tulip Link and DVR traffic should go to BSNL link only.

    In my HO router i given reverse traffic for DVR to BSNL link.

    My configuration:

interface FastEthernet0/0

description ***** Branch-LAN *****$ETH-LAN$

ip address 10.10.110.100 255.255.254.0

duplex auto

speed auto

keepalive 1000

!

interface FastEthernet0/1

description $$TULIP-WAN$$

bandwidth 512

ip address 10.237.69.36 255.255.255.252

ip accounting output-packets

duplex auto

speed auto

!

interface BRI0/0/0

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Serial0/1/0

description #### BSNL WAN 2MBPS ####

ip address 192.168.3.56 255.255.255.252

ip accounting output-packets

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip virtual-reassembly

encapsulation ppp

load-interval 30

no fair-queue

!

router bgp 68001

no synchronization

bgp log-neighbor-changes

network 10.10.110.0 mask 255.255.254.0

neighbor 10.237.69.35 remote-as 65500

neighbor 10.237.69.35 description ***TULIP WAN***

neighbor 10.237.69.35 soft-reconfiguration inbound

neighbor 192.168.3.57 remote-as 9829

neighbor 192.168.3.57 soft-reconfiguration inbound

no auto-summary

  it is possible in BGP??

  If possible means kindly tell me how to configure??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Sergey Fer Tue, 05/08/2012 - 22:30

You need to advertise your more specific DVR route to BSNL and not advertise it to Tulip. It is for traffic incoming to your DVR location. Another direction must be controlled by PBR for example. Or you may use OER/PfR.

Sergey Fer Wed, 05/09/2012 - 03:58

I'll try.

First of all you need to create static IP route for your DVR like this:

ip route 10.10.110.111 255.255.255.255 Fa0/0

We need it to be in BGP table to advertise.

Next. Add network statement into BGP.

router bgp 68001

     network 10.10.110.111 mask 255.255.255.255

Then you need to filter this network out of advertising to Tulip.

ip prefix-list DVR 10.10.110.111/32

route-map TO_TULIP deny 10

     match ip address prefix DVR

route-map TO_TULIP permit 20

router bgp 68001

     neighbor 10.237.69.35 route-map TO_TULIP out

And softly reset Tulip session (like clear ip bgp * out). Now your DVR is announced through BSNL but not through Tulip. Your HO router will get routes and choose the most specific one (/32), which comes from BSNL.

Next stage. You need to send DVR's traffic to BSNL.

ip access-list standard DVR

     permit host 10.10.110.111

route-map PBR

     match ip access-group DVR

     set ip next-hop 192.168.3.57

interface Fa0/0

     ip policy route-map PBR

Now your DVR's traffic will come to BSNL. Hope this helps and hope I didn't forget something importaint.

Actions

Login or Register to take actions

This Discussion

Posted May 8, 2012 at 10:26 PM
Stats:
Replies:4 Avg. Rating:
Views:298 Votes:0
Shares:0
Tags: No tags.
Categories: Routers
+

Discussions Leaderboard