×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP Routing -- Need Help

Answered Question
May 8th, 2012
User Badges:

  BGP Lab

=========


Hello friends



I just started with eBGP & and I have configured this LAB. In Lab there are four Routers R1,R2,R3 & R4.


R1 & R2 (AS 1600)are iBGP neighbors, also R1 is having EBGP peer with R3 (AS 1700) & R2 is having EBGP peer with R4 (AS 1800).


All the router are configured with some loopbacks & all loops are adverted in BGP process.


Now R1 can see loopbacks on R4 but can not ping R4 routes, same with R2 it can see R3 loops but not able to ping. R3 can not see routes on R4 & vice verse.


I am attaching Lab pic & putting running config so you may see what I have configured & please tell me where i am wrong & what need to be done


Thanking you in advance..



bgp.png


===========

Running Config

===========

R1

===========


interface Loopback1

ip address 172.16.10.1 255.255.255.255

!

interface Loopback2

ip address 172.16.11.1 255.255.255.0

!

interface Loopback3

ip address 172.16.12.1 255.255.255.0

!

interface Loopback4

ip address 172.16.13.1 255.255.255.0

!

interface Loopback5

ip address 172.16.14.1 255.255.255.0

!

interface Loopback6

ip address 172.16.15.1 255.255.255.0

!

interface Loopback7

ip address 172.16.16.1 255.255.255.0

!

interface Loopback8

ip address 172.16.17.1 255.255.255.0

!

interface Loopback9

ip address 172.16.18.1 255.255.255.0

!

interface Loopback10

ip address 172.16.19.1 255.255.255.0

!

interface Serial0/0

description **::LINK_TO_iBGP**::

  ip address 62.150.214.1 255.255.255.252

serial restart-delay 0

!

interface Serial0/1

description ::**LINK_TO_AS_1700**::

ip address 1.150.14.1 255.255.255.252

serial restart-delay 0

!

!

router bgp 1600

no synchronization

bgp log-neighbor-changes

network 172.16.10.0 mask 255.255.255.0

network 172.16.11.0 mask 255.255.255.0

network 172.16.12.0 mask 255.255.255.0

network 172.16.13.0 mask 255.255.255.0

network 172.16.14.0 mask 255.255.255.0

network 172.16.15.0 mask 255.255.255.0

network 172.16.16.0 mask 255.255.255.0

network 172.16.17.0 mask 255.255.255.0

network 172.16.18.0 mask 255.255.255.0

network 172.16.19.0 mask 255.255.255.0

neighbor 1.150.14.2 remote-as 1700

neighbor 172.16.20.1 remote-as 1600

neighbor 172.16.20.1 ebgp-multihop 2

neighbor 172.16.20.1 update-source Loopback1

no auto-summary

!

no ip http server

no ip http secure-server

ip route 172.16.20.1 255.255.255.255 62.150.214.2



=======

R2

=======


interface Loopback1
ip address 172.16.20.1 255.255.255.255
!
interface Loopback2
ip address 172.16.21.1 255.255.255.0
!
interface Loopback3
ip address 172.16.22.1 255.255.255.0
!
interface Loopback4
ip address 172.16.23.1 255.255.255.0
!
interface Loopback5
ip address 172.16.24.1 255.255.255.0
!
interface Loopback6
ip address 172.16.25.1 255.255.255.0
!
interface Loopback7
ip address 172.16.26.1 255.255.255.0
!
interface Loopback8
ip address 172.16.27.1 255.255.255.0
!
interface Loopback9
ip address 172.16.28.1 255.255.255.0
!
interface Loopback10
ip address 172.16.29.1 255.255.255.0
!
interface Serial0/0
description **::LINK_TO_iBGP**::
ip address 62.150.214.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
description ::**LINK_TO_AS_1800**::
ip address 2.150.14.1 255.255.255.252
serial restart-delay 0
!
!
router bgp 1600
no synchronization
bgp log-neighbor-changes
network 172.16.21.0 mask 255.255.255.0
network 172.16.22.0 mask 255.255.255.0
network 172.16.23.0 mask 255.255.255.0
network 172.16.24.0 mask 255.255.255.0
network 172.16.25.0 mask 255.255.255.0
network 172.16.26.0 mask 255.255.255.0
network 172.16.27.0 mask 255.255.255.0
network 172.16.28.0 mask 255.255.255.0
network 172.16.29.0 mask 255.255.255.0
neighbor 2.150.14.2 remote-as 1800
neighbor 172.16.10.1 remote-as 1600
neighbor 172.16.10.1 ebgp-multihop 255
neighbor 172.16.10.1 update-source Loopback1
no auto-summary
!
no ip http server
no ip http secure-server
ip route 172.16.10.1 255.255.255.255 62.150.214.1



====

R3

====

interface Loopback2
ip address 150.16.1.1 255.255.255.0
!
interface Loopback3
ip address 150.16.2.1 255.255.255.0
!
interface Loopback4
ip address 150.16.3.1 255.255.255.0
!
interface Loopback5
ip address 150.16.4.1 255.255.255.0
!
interface Loopback6
ip address 150.16.5.1 255.255.255.0
!
interface Loopback7
ip address 150.16.6.1 255.255.255.0
!
interface Loopback8
ip address 150.16.7.1 255.255.255.0
!
interface Loopback9
ip address 150.16.8.1 255.255.255.0
!
interface Loopback10
ip address 150.16.9.1 255.255.255.0
!
interface Serial0/0
description ::**LINK_TP_AS_1600**::
ip address 1.150.14.2 255.255.255.252
serial restart-delay 0
!
!
router bgp 1700
no synchronization
bgp log-neighbor-changes
network 150.16.1.0 mask 255.255.255.0
network 150.16.2.0 mask 255.255.255.0
network 150.16.3.0 mask 255.255.255.0
network 150.16.4.0 mask 255.255.255.0
network 150.16.5.0 mask 255.255.255.0
network 150.16.6.0 mask 255.255.255.0
network 150.16.7.0 mask 255.255.255.0
network 150.16.8.0 mask 255.255.255.0
network 150.16.9.0 mask 255.255.255.0
neighbor 1.150.14.1 remote-as 1600
no auto-summary


=====

R4

=====

interface Loopback2
ip address 180.25.1.1 255.255.255.0
!
interface Loopback3
ip address 180.25.2.1 255.255.255.0
!
interface Loopback4
ip address 180.25.3.1 255.255.255.0
!
interface Loopback5
ip address 180.25.4.1 255.255.255.0
!
interface Loopback6
ip address 180.25.5.1 255.255.255.0
!
interface Loopback7
ip address 180.25.6.1 255.255.255.0
!
interface Loopback8
ip address 180.25.7.1 255.255.255.0
!
interface Loopback9
ip address 180.25.8.1 255.255.255.0
!
interface Loopback10
ip address 180.25.9.1 255.255.255.0
!
interface Serial0/0
description ::**LINK_TO_AS_1600**::
ip address 2.150.14.2 255.255.255.252
serial restart-delay 0
!
!
router bgp 1800
no synchronization
bgp log-neighbor-changes
network 180.25.1.0 mask 255.255.255.0
network 180.25.2.0 mask 255.255.255.0
network 180.25.3.0 mask 255.255.255.0
network 180.25.4.0 mask 255.255.255.0
network 180.25.5.0 mask 255.255.255.0
network 180.25.6.0 mask 255.255.255.0
network 180.25.7.0 mask 255.255.255.0
network 180.25.8.0 mask 255.255.255.0
network 180.25.9.0 mask 255.255.255.0
neighbor 2.150.14.1 remote-as 1600
no auto-summary


=====

end

=====

Correct Answer by Dan-Ciprian Cicioiu about 5 years 3 months ago

Hi,


your issue is related to the next-hop of the eBGP prefixes between iBGP peers - currently the next hop is unknown


Solution 1 :



R1


router bgp 1600

nei 172.16.20.1 next-hop-self

end

clear ip bgp * soft



R2


router bgp 1600

nei 172.16.10.1 next-hop-self

end

clear ip bgp * soft



Solution 2 :


R1


router bgp 1600

net 1.150.14.0 mask 255.255.255.252


R2


router bgp 1600

net 2.150.14.0 mask 255.255.255.252




Dan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Dan-Ciprian Cicioiu Tue, 05/08/2012 - 23:42
User Badges:
  • Gold, 750 points or more

Hi,


your issue is related to the next-hop of the eBGP prefixes between iBGP peers - currently the next hop is unknown


Solution 1 :



R1


router bgp 1600

nei 172.16.20.1 next-hop-self

end

clear ip bgp * soft



R2


router bgp 1600

nei 172.16.10.1 next-hop-self

end

clear ip bgp * soft



Solution 2 :


R1


router bgp 1600

net 1.150.14.0 mask 255.255.255.252


R2


router bgp 1600

net 2.150.14.0 mask 255.255.255.252




Dan

Sabby0115 Wed, 05/09/2012 - 01:36
User Badges:

Thank You Dan for you kind help…


I hope you won’t mind it I have this question. If you may explain it



Actually I tired that solution last night but failed,  I tried again & still no success. Than I thought it is must be something wrong between R1 & R2.


I enable debug on R4 & ping from R1 & the echo was not even reaching in R4 from R1. Next I ping from R2 to R4 with source loop 1 which was successful. Next Ping R2 to R4 with source s0/0 it was dest to 62.150.214.2 unsuccessful.


Then I check my BGP table & 62.150.214.2 was not there, because I did not add that in to BGP process I though Loopback will do that cause I added loop 1 in to BGP & it was update source.


Now I added 62.150.214.0/30 in to bgp & it works. All routers can see routes on remote routers.


But I am still not very sure why loopback have not did that when the neighbour relation are formed with Loopback.



Once again

Thanks

Dan-Ciprian Cicioiu Wed, 05/09/2012 - 02:26
User Badges:
  • Gold, 750 points or more

Hi,


From R1 to R4 the issue is that R2 is advertising the prefixes from R4 without changing the next-hop. So R1 will receive R4's prefix with R4 next-hop.

The real issue is that R1 does not have any prefix in the routing table pointing to R4's next-hop (2.150.14.2). If you look in the R1's BGP table for the R4's prefix you will see that the next-hop is maked as inaccesible. That's why the solution included the advertisement of the interconnection prefixes between R1-R3 and R2-R4 into BGP.



R2   show ip bgp 150.16.8.0


R1    show ip bgp 180.25.9.0



You have some mistakes in the BGP config - the mask of loopback1 prefixes of both R1 and R2 are configured wrong on bgp, therefore those 2 prefixes will not be advertised into BGP. You can modify the Loopback's 1 netmask to /24 or you can modifiy the bgp command network for 172.16.20.1 and 172.16.10.1 to /32.



R2


router bgp 1600

no synchronization

bgp log-neighbor-changes

network 172.16.21.0 mask 255.255.255.0


interface Loopback1

ip address 172.16.20.1 255.255.255.255


R1


router bgp 1600

no synchronization

bgp log-neighbor-changes

network 172.16.10.0 mask 255.255.255.0


interface Loopback1

ip address 172.16.10.1 255.255.255.255



Dan

Sabby0115 Wed, 05/09/2012 - 03:13
User Badges:

Thanks you so much sir it was very helpful.....I have changed loop address & removed the serial links from bgp process & it works.....


Best Regards

Sabby

Actions

This Discussion

Related Content