Fabric Interconnect Uplink port channeling...

Unanswered Question
May 9th, 2012

Hi,

We setup port channel of two 10G uplink interfaces on each Fabric Interconnect. Everything is running as expected.
However we noticed that under 'Port-Channel # (Fabric #)' setting on LAN tap, 'Admin Speed' was set to '10Gbps'.

Should we leave this configuration as is or match to the maximum bandwidth of port Channel we set up (20Gbps)?

I only see four options on each port channel configuration, 1 Gbps, 10Gbps, 20Gbps and 40Gbps so I'm not sure if we should change this setting.

Thank you                   

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
padramas Wed, 05/09/2012 - 21:21

Hello,

You do not need to change the speed ( admin ). 20 Gbps configuration is applicable for certain server models.

--------  NXOS output -----------------

FI-A(nxos)# sh run int port-channel 1

interface port-channel1

  description U: Uplink

  switchport mode trunk

  speed 10000

FI-A(nxos)# show int port-channel 1

port-channel1 is up

  Hardware: Port-Channel, address: 547f.ee67.e0fb (bia 547f.ee67.e0fb)

  Description: U: Uplink

  MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  full-duplex, 10 Gb/s

FI-A(nxos)# sh int bri

--------------------------------------------------------------------------------

Port-channel VLAN  Type Mode   Status  Reason                    Speed  Protocol

Interface                                                               

--------------------------------------------------------------------------------

Po1          1     eth  trunk  up      none                       a-10G(D)  lacp

-------------------------------------------------------------------

There is cosmetic defect where we list the operational speed as 10 Gbps instead of 20Gbps

FI-A /eth-uplink/fabric # show port-channel detail

Port Channel:

    Port Channel Id: 1

    Name: FIA

    Admin State: Enabled

    Oper State: Up

   Speed: 10 Gbps

    Oper Speed: 10 Gbps

    State Reason:

    flow control policy: default

HTH

Padma

shinepjoseph68 Sun, 09/23/2012 - 14:40

Hi Padma,

The Admin Speed settings 1/10/20/40 Gbps are availbale on physical interfaces from GUI as shown in your screen-shot. Just wondering where would 20 and 40 Gbps gets applied! I think no documentation is availble in the public domain in Cisco site. Can you please lead me to any documentation on this?

Thanks in adavance,

Shine

shinepjoseph68 Mon, 09/24/2012 - 13:27

Hi Padma,

Thanks for the response.

This Admin Speed is availablable not just on port-channel interfaces, but on physical interfaces as well. What confuses me is, I haven't heard of a 20Gbps Ethernet standard. The bug id is talking about Operational Speed not the Admin Speed. I was referring to the Admin Speed that you can set as part of configuration.

Can you please clarify above?

Thanks in advance again.

Cheers,

Shine

padramas Tue, 09/25/2012 - 01:30

Hello Shine,

Some adapters do support 20 Gbps and they are available in UCSM for such hardware.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtt98475

Resulted in updating the doc with following note

-----------------------------

http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/gui/config/guide/2.0/b_UCSM_GUI_Configuration_Guide_2_0_chapter_0101.html

The admin speed can be changed only for certain ports, and not all  speeds are available on all systems. For more information, see the Hardware Installation Guide for your fabric interconnect.

------------------------------

http://www.cisco.com/en/US/prod/collateral/modules/ps10277/ps12377/data_sheet_c78-699459.html

/chassis/server # show adapter detail

Adapter:

    Id: 1

    Product Name: Cisco UCS VIC 1240

    PID: UCSB-MLOM-40G-01

    VID: V00

    Vendor: Cisco Systems Inc

    ...........

    Product Description: PCI Express Dual Port Cisco Converged Network Adapter Supporting 20Gb Ethernet and 20Gb Fibre Channel

HTH

Padma

shinepjoseph68 Tue, 09/25/2012 - 04:48

Hi Padma,

The card "VIC 1240" supports 4 x 10Base-KR or 8 x 10Base-KR (with expansion card). The adapter doesn't support 20Gbps on a single physical interface. The bug ID CSCtt98475 says 20Gbps will never exist. So I can't see a reason why the option of Admin Speed 20Gbps on physcial port required - EVER.

I don't believe the  following statement is accurate from a physical interface perspective

"Some adapters do support 20 Gbps and they are available in UCSM for such hardware."

Thanks and best reagrds,

Shine

Actions

Login or Register to take actions

This Discussion

Posted May 9, 2012 at 2:07 PM
Stats:
Replies:6 Avg. Rating:
Views:1853 Votes:0
Shares:0
Categories: General UCS Hardware
+

Related Content

Discussions Leaderboard