Manualy add a new vLan to blade server in Cisco UCS 5108

Answered Question
May 11th, 2012

Hi

I have tried to add a new vLan to my server chassie and then add it manulay to the blad server. The problem is that i can´t connect to the network, do I have to initate it in the fabric switch? Anyone got a tip where to start trubleshooting?

/T                  

I have this problem too.
0 votes
Correct Answer by padramas about 3 years 2 months ago

Hello,

You need to SSH into Fabric Interconnect ( FI ) and then change to nxos context

Padma

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
padramas Fri, 05/11/2012 - 09:46

Hello Tobias,

To start with,

1) Are you able to ping the gateway of the device ?

2) If not, we need to trace the MAC address. We can determine the path taken by vnic of server by following command 

show service-profile circuit server x/y  ( where x is chassis number and y is blade slot number )

3) Connect to nxos mode of the FI and check whether mac address is learned on correct VLAN or not

show mac address-table

If not, we need to verify OS NIC VLAN configuration ( whether assigned proper VLAN or not )

4) Verify VLAN configuration on the upstream switch.

Padma

tobias1979 Fri, 05/11/2012 - 10:37

HI

Do I have to add the vLan under appliance to, it seams to be missing there?

padramas Fri, 05/11/2012 - 10:44

Hello Tobias,

Not required unless if you are trying to communicate to a device connected to FI on appliance port.

Providing more information about source / destination would help us here.

What is the OS installed on the blade ?

Chassis and blade number ?

Are you able to ping the gateway ip address for Vlan 102 ?

Padma

tobias1979 Fri, 05/11/2012 - 11:03

HI

The vLAn should be deployed to all blad servers 6 at the moment in 2 chassis. I ám running esxi 4.1 on the blade. I can´t ping the gateway from a vm on the blade.

Tobias

padramas Fri, 05/11/2012 - 11:37

Tobias,

Is the virtual machine NIC configured to use VLAN 102 in ESXi ?

Padma

rammuthaiya Fri, 05/11/2012 - 11:39

Hi ,

Make sure that, correct VLANs have been added to vNIC 0f the blades on whicj ESX is installed.

Ram

padramas Sat, 05/12/2012 - 00:49

On FI, check the mac address of the VM nic is learned on vlan 102 or not.

Padma

tobias1979 Sat, 05/12/2012 - 13:01

The vNIC in UCS has the same MAC adress as the vSwitch in vSphere. How can I see a specific virtual machines mac adress in USC´n?

padramas Sun, 05/13/2012 - 20:00

Hello,

You can check the mac address table by

connect nxos

show mac address-table

Padma

tobias1979 Sun, 05/13/2012 - 22:00

HI

How do I connect to "nxos", is it lika a terminal session to UCS?

.T

Correct Answer
padramas Sun, 05/13/2012 - 22:03

Hello,

You need to SSH into Fabric Interconnect ( FI ) and then change to nxos context

Padma

tobias1979 Tue, 05/15/2012 - 13:01

Hi

I found the MAC adress and we found the problem in the router. Thank you Padramas you have been very helpful.

Rgds

Tobias

Actions

This Discussion

Related Content