Break Key

Unanswered Question
May 14th, 2012

I have a Dell Latitude 5420. I purchased a USB to Serial interface to  communicate thru serial port with MXP devices. I need to FLASH the  memory of one of my units. The standard procedure is to do a BREAK  command during boot up and type command eee in order to flash the  memory. Unfortunatly, all these new keyboards don't have the BREAK  function key available. Any ideas on how I can get my issue resolved?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
thobonho Mon, 05/14/2012 - 13:40

Hi Steve,

Look in Putty or TeraTerm menus, you should be able to send a BREAK command from there.

Steve Deslandes Mon, 05/14/2012 - 13:57

Hi Thomas,

I tried that and it doesn't work. The issue is that it is not only a BREAK command that needs to be sent, it's a CTRL + BREAK command. I've tried it with Hyper-Terminal, Putty, TeraTerm with the same result. Also tried different ways of typing it in (CTRL + B, ALT + B, etc.) with the same result. By looking on the web, the issue seems to be more related to the fact that Windows 7 doesn't support the BREAK key. Therefore, even if I try to simulate it with commands in Putty or Hyper-Terminal, I can't seem to be able to do the CTRL + BREAK. Can anybody try to simulate it with their laptop and confirm if they were able to get thru? I sure can't....

Justin Ferello Mon, 05/14/2012 - 17:15

Steve,

I know this is not ideal, however we always suggest hooking up USB keyboards to laptops so you can have the break key.

Thanks,

Justin

Steve Deslandes Tue, 05/15/2012 - 11:45

Hi Jason,

Tried that already but I think it's Windows 7 that doesn't understand the BREAK key itself. I was given a work around from CISCO to at least be able to access system commands thru telnet once the unit is booted up. It doesn't help me with my issue when an MXP system is stuck in a reboot loop, but, it does allow me to select software image or switch the units from PAL to NTSC (Cisco sends all the MXP replacements as PAL) which is normally done thru the system commands you can access once you do the CTRL + BREAK.

thobonho Fri, 05/18/2012 - 01:20

Hi Steve,

It won't solve your original issue, but from F9.0.2 you can choose between PAL and NTSC standards directly from the web interface. The URL is: http://MXP_IP/setproductversion.ssi

Paul Anholt Thu, 05/17/2012 - 07:53

Also in putty you can click on the icon in the top left title bar and navigate to special command > break. This is how I always do it and I have never had any issues.

Martin Koch Tue, 05/15/2012 - 15:18

Hello Steve!

I just tried it with Win7/64, Putty with a cheap PL2303 USB2Serial adapter on a lenovo thinkpad

towards an MXP3000 running F9.1.1 and it worked with the integrated keyboad or with the

on-screen windows keyboard.

First check that your com port and serial port speed are correct, in my case it was COM7 and 9600.

Then open putty and the on screen keyboard (just search for keyboard in the windows search, think

its somewhere in accessories or something like that).

Reboot the codec, you should now see "Break ?" on the screen (if not most likely your connection is not ok).

I simply held down my Ctrl key and then clicked on the ScrLk button on the On-Screen Keyboard.

The faster way on the thinkpad was to press the Fn key together with break, often these keys

can be activated by some 2nd-level key function, ...

By that I would also say Justins external USB Keyboard method shall work fine as well.

Other options:

* Use a different computer with a different OS or just download yourself a bootable linux cd/usb-stick

* I think I had seen  some terminal programms supporting such control codes as on screen buttons as well

and so on, ...

Good success!

Steve: Please rate the message using the stars below and set the thread to answered if it is.

Add-on:

Tried it with the putty break function mentioned by Thomas/Paul and worked like a charm as well:

(so no additional ctrl is required). Are your really sure the endpoint / cable / serial adapter / settings / ... are ok?)

BW Dijk Tue, 11/12/2013 - 13:03

I had the same issue in Windows 7.

Got my old XP laptop and the CTRL + BREAK works!

Now to find the right command for switching memory bank

Actions

Login or Register to take actions

This Discussion

Posted May 14, 2012 at 6:51 AM
Stats:
Replies:8 Overall Rating:
Views:4120 Votes:0
Shares:0
Tags: key, break
+

Related Content

 
 
 

Discussions Leaderboard

Rank Username Points
1
Martin Koch
2,539
2
Patrick Sparkman
2,326
3
Wayne DeNardi
2,109
4
Jens Didriksen
1,265
5
Paulo Souza
853
Rank Username Points
Patrick Sparkman
201
Martin Koch
64
Wayne DeNardi
37
Chris Swinney
30
Nick Halbert-Li...
20