WEIM: archive job

Answered Question
May 15th, 2012

Dears,

WEIM 4.3.2(8) integrated with ucce 8.0

I am running an archive job to archive some closed cases.

The job is completed but if I go to the history window, I can see that there is a zero case archived and zero activity archived.

I got the following error from the archive process logs:

<@> ERROR <@> [1:main] <@> ProcessId:6904 <@> PID:0 <@> UID:12 <@> HttpSessionId: <@> com.egain.platform.framework.dsm.BatchExecutor <@> main() <@> ProcessName = archive-process <@>

2012-05-15 14:27:21.221 GMT+0300 <@> ERROR <@> [22:RMI TCP Connection(2)-10.0.2.26] <@> ProcessId:6904 <@> PID:0 <@> UID:12 <@> HttpSessionId: <@> com.egain.platform.framework.event <@> registerExceptionListener() <@> Registering exception listener <@>

2012-05-15 14:28:21.393 GMT+0300 <@> ERROR <@> [3:Finalizer] <@> ProcessId:6904 <@> PID:-1 <@> UID:-1 <@> HttpSessionId: <@> DBConnection <@> finalize() <@> The connection was not released previously. It is now released during GC. <@>

Any idea?

thanks

Georges

I have this problem too.
0 votes
Correct Answer by rhobab about 1 year 11 months ago

Are you using SQL 2005 Enterprise? I had the same problem you are describing and it was solved by TAC with an Engineering Special. My advice is for you to contact TAC to obtain the Engineering Special or update.

Below is the link to the post I had created at the time.

https://supportforums.cisco.com/message/3374845#3374845

Regards,

Victor

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
egain_karthik Thu, 05/17/2012 - 13:27

The job did not have any qualified activities or cases to archive hence completed but did not archive. The errors can be ignored, it is probably registered as an object.

ghajjmoussa Fri, 05/18/2012 - 00:58

hi Karthik,

Actually I have many cases that are ready to be archived (cases that have been closed for more than 8 days {the time frame that I have selected in the archive job options})

If I search for cases based on their close status, I get a lot of cases but still stuck in the same issue on the archive job: it is completed but no cases or activities that been archived.

Regards,

Georges

Correct Answer
rhobab Fri, 05/18/2012 - 02:04

Are you using SQL 2005 Enterprise? I had the same problem you are describing and it was solved by TAC with an Engineering Special. My advice is for you to contact TAC to obtain the Engineering Special or update.

Below is the link to the post I had created at the time.

https://supportforums.cisco.com/message/3374845#3374845

Regards,

Victor

ghajjmoussa Fri, 05/18/2012 - 02:25

Hi Victor,

Thanks for your reply.

It seems that it is the same issue that you have faced. Do you still have the ES9? If yes, can you please send it to me?

Thanks in advance

Georges

rhobab Fri, 05/18/2012 - 02:44

Hello Georges

I'm not sure on the legal situation of providing you with the ES directly, in any case I recomend you take this up with TAC because it may not be the exact same issue and also ther may be a normal update that already includes this solution.

Regards,

Victor

ghajjmoussa Fri, 05/25/2012 - 01:30

Hi Victor,

After I have installed ES9, the archive job is working properly.

Thanks for your help.

Regards,

Georges

rhobab Fri, 05/25/2012 - 01:44

Hi Georges

I'm glad to have pointed you in the right direction.

Regards,

Victor

Actions

Login or Register to take actions

This Discussion

Posted May 15, 2012 at 4:59 AM
Stats:
Replies:8 Avg. Rating:5
Views:502 Votes:0
Shares:0
Tags: archive, job
+

Related Content

Discussions Leaderboard