Jabber on Samsung Galaxy SII - OneWayAudio

Unanswered Question
Jun 24th, 2011

I installed Jabber on a Samsung Galaxy SII (model GT-I9100) (Android Version 2.3.3)

When I initiate a call from a Cisco phone (79xx) I get One-Way-Audio (audio only from the 79xx to the Samsung)

When I initiate a call from the Samsung to a 79xx phone, there is no problem

So I installed the same Jabber version on a HTC (Android version 2.2), and used the same device-id as the Samsung, connected and there

was no problem, normal two-way-audio.

Has anyone experienced the same problem?

My quick reaction is that there is an issue with this version of Jabber in combination with the Samsung Galaxy SII

I use CUCM version

thx for the help in advance


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Carlo Poggiarelli Thu, 06/30/2011 - 21:56


Same problem here.

All other features work fine (voicemail, LDAP search etc)

Tried to factory reset the phone and install Jabber only.

Tried to install the latest release of Phon firmware from Samsung, but the issue is still there.

Any point?



marlojooste Mon, 07/18/2011 - 06:06

I am experiencing the same problem on Jabber with Samsung Galaxy SII using CUCM

System version:

ivarnhagen Mon, 07/25/2011 - 05:00

Same problem here. I am using a Samsung Galaxy S i9000 With Android 2.3.3 with CUCM 8.5(1)SU2. I even installed the correct COP file on the CUCM, but it doesn't seem to help. I also get one-way audio when calling to/from the PSTN. The only way I get 2-way audio is when calling from Jabber to an internal extension.

If anybody has a solution, please let us know!

Carlo Poggiarelli Mon, 07/25/2011 - 11:53


In your case I think it'san android version problem. I tried Jabber on a Samsung Galaxy S I9000 with a version 2.2.1 and it worked just fine.

My I9100 has a 2.3.1 and has the above issue.

I asked Samsung support for a 2.2.1 version for my S2.

Hope this will solve this issue.

I'll keep you informed.



marlojooste Wed, 07/27/2011 - 00:00

@ Carlo : Please keep us posted as to the feedback from Samsung.

I however feel that I will not downgrade Android, just to support the Jabber application.

Vikrant Ambhore Sat, 08/06/2011 - 05:13

Hi All Friends,

I need some guidence regarding Jabber for Android

We are using Cisco UC520 router for VOIP, Now I want to use Cisco Jabber with UC520, We have Android Phone & we want to configure Jabber with UC520 & want to place & receive call from My android phone by UC520, I Installed Jabber on My Samsung Galaxy phone,  but I am not sure where to start, I have the TFTP server address. What do i enter in the device id field in Jabber ?

Can anyone help me

Does I need more configuration on UC520 for using Jabber ?  I have below software on Cisco UC520, Can we use CIsco Jabber on this Software,

coinop-uc520#sh telephony-service
CONFIG (Version=4.2(0))

Version 4.2(0)
Cisco Unified Communications Manager Express

coinop-uc520#sh ver

Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 12.4(11)X


System image file is "flash:uc500-advipservicesk9-mz.124-11.XW5"

usmantaokeer Sat, 09/10/2011 - 22:51


I am facing almost the same issue, i have Jabber running on Galaxy S2 2.3.4. I am actuallly unable to register the phone with our CUCM, i have configured the phone as 'Cisco Dual Mode for Android' and the phone does not even register, i have nothing in CUCM logs as well. But if i configure the Phone as 'Cisco Dual Mode for iPhone' the phone is able to register (as an iphone) but then i get one-way audio intermitten.

I tested on Sony Xperia Arc as 'Cisco Dual Mode for iPhone' and it works fine!!. I am confused!!!

Any suggestions / Help?




martijnbuts Fri, 10/14/2011 - 00:15

I had the same problem here. With the original software the jabber had a one way voice problem. The solution for the problem was to switch from the original software to Cyanogen mod. When I use the Cyanogen mod software I have two way sound. Other people that use the Cyanogen mod software also don’t experience the problem.

Carlo Poggiarelli Thu, 11/10/2011 - 06:14


I tried both a Cyanogen MOD and a 2.2 Android version on my S2 and Jabber works great with both releases.

Roll back to 2.3  with the same result... One way audio.

I'll keep my cyanogen MOD.




Henk.Lasker_2 Fri, 11/18/2011 - 00:03

Hi All,

I received good news from Cisco today.

They are working on version 8.6.2 Beta

They tested this version in combination with the Galaxy S2 - Android 2.3.3, and 2-way-audio is working now.

The release date is not known yet (hope soon)



usmantaokeer Fri, 11/18/2011 - 02:41


2.3.3 is OLD, android v4 a.k.a ice creame sandwhich has been released and will be coming in market in a couple of months... hope jabber will work on it!


Usman Taokeer

Sent from Mobile Device.

Gary Wong Mon, 11/21/2011 - 00:08

Hi everyone,

Are you guys using the Jabber directly connected to the CUCM network or via the Anyconnect?

I tried to connect the Jabber (8.6.1) via the Anyconnect (wifi), both parties hear silence. After checking the wireshake, I found the Jabber sent the wrong MTP ip address (wireless router internal ip address) instead of the VPN ip address of the connected party. Is there any specail setting the Jabber or Anyconnect or ASA?

Thanks a lot!


usmantaokeer Mon, 11/21/2011 - 00:48


I am unable to even register my SG2 using Jabber, it says ‘Registration Failed’. On iPhone the Cisco apps works like a charm, do we need a different license for Jabber to make it work, is it licensing related or something else?


Usman Taokeer

Network Administrator - ENS

Georgios Sotiro... Tue, 11/22/2011 - 02:09

Hello Team,

I am trying to locate and donwload the "cmterm-android_8.6.2v17.cop.sgn" file in order to make the "Cisco Dual Mode for Android" as an availiable phone device type on the CUCM 8.5

Can you plese suggest where i can find this file?  Cisco suggests

Go to the software download site: http://tools.cisco.com/support/downloads/pub/Redirect.x?mdfid=281001428 ,but unfotunatelly i cannot find such a file.

Any suggestions?

Henk.Lasker_2 Thu, 11/24/2011 - 06:53

Hi All,

Today Cisco released Jabber version

I installed it, and..............it worked, 2way audio is now available in all situations (calling and called)

So upgrade and it should work

Note: I use Android version 2.3.4



usmantaokeer Fri, 11/25/2011 - 00:49

I had it long time ago via our cisco account manager. It was not available for down load.


Usman Taokeer

Sent from Mobile Device.

usmantaokeer Thu, 11/24/2011 - 07:08

likewise.. working fine for me as well.


Usman Taokeer

Sent from Mobile Device.

danielgarzon Tue, 12/20/2011 - 07:49


I have a problem with my Galaxy S2.

I can not connect to Cisco Jabber from my Samsung Galaxy 2 , GT-I9100 model and 2.3.3 Android version.

I have a 8.0.3 CUCM version.

When I tried to register to Cisco Jabber I have the same error: "internet calling"

How do you do this config in CUCM?

If I register my iphone, as Cisco Dual Mode for iPhone, and all works fine.


bagusutomo Thu, 02/02/2012 - 00:55

I have the same problem. I'm using CUCM version 8.0.3 and Samsung Galaxy S2 with android version 2.3.6.

When I'm using Cisco Jabber version 8.6.1 I can register to CUCM but experiencing one way audio.

And then I check at the android market for version 8.6.3 and 8.6.4, with both version I can't register to CUCM.

Both give the same error like Daniel. I can only register using version 8.6.1 with one way audio problem.

Still waiting for new version of Cisco Jabber.

And can someone help me providing Cisco Jabber apk version 8.6.2? I want to try that version.


cinanza90 Fri, 02/03/2012 - 02:47

I need the same problem with Jabber 8.2 on Iphone and Callmanager 8.6.

The call from Jabber to 7962 works, the reverse no.


from CallManager to Jabber ->   ACK

from Jabber to CallManager -> RST ACK

Why Jabber response is a reset ? Something wrong in SIP signalling ?

Someone can help me ?


usmantaokeer Fri, 02/03/2012 - 21:53

Which rom and version of gingerbread are you using. I had the same problem but eversince last update of jabber its working fine now.


Usman Taokeer

Sent from Mobile Device.

ievalleyccie Sat, 05/19/2012 - 06:42

I installed the Cisco Jabber on Samsung S2 but it gives me the following

ERROR "Please check your Internet Calling Settings and try again. If the problem persists, contact your system administrator"

Jasmeet Sandhu Sun, 05/20/2012 - 19:41

The error looks like Cisco Jabber can¹t resolve the CUCM host.  There is a known bug in Android OS, where non-FQDN host names are not resolvable.  Cisco Jabber has provide a solution to using non-FQDN CUCM hostname by adding a domain field in the product specific configuration.

Please refer to the Admin Guide for more information on configuring the domain in the product specific configuration:


If the value in                      System > Server                     in Cisco Unified Communications Manager is a hostname without a domain, enter                     your domain name in the                      Domain Name field in the                      Cisco Dual Mode for Android device page.


This Discussion