Cisco Jabber for Android 4 (Ice Cream Sandwich)?

Unanswered Question
Apr 3rd, 2012

Hi,

I'm curious to know if there are any plans to make an Android 4 version of the Cisco Jabber client. If so, do you have any estimates on release date?

Best regards,

Pauli

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
minkdennis Sun, 05/06/2012 - 21:56

I am contemplating running Cisco jabber 8.6.4 on CUCM 8.2.1a

Has anyone been able to successfully run this on a (non Samsung Galaxy) android 4 device?  

Asking this because the Cisco Jabber 8.6.4 release notes say:

To obtain the latest Cisco Jabber for Android client software, visit the Google Android Market and search for Jabber. Your device must run either Android operating system (OS) 2.2 or 2.3 to access and use the Cisco Jabber application.

ronpatel Mon, 06/18/2012 - 22:26

Hi,

Support of Android may come soon with 4.0.3. July is the release month. Let us wait and watch the release. It is under testing with Samsung Galaxy S2 (9100P) with Android 4.0.3. This is tentative information and  We have to wait and see when actual supports comes.

regards

Ronak Patel

Rate helpful posts.

szelenka Tue, 06/19/2012 - 09:20

ICS support will be there, but as Ronak pointed out there are some open defects in the Android Kernel for ICS that need to be resolved first.  July is a tenative date for release.

Paul McGurn Fri, 07/13/2012 - 10:39

Chiming in here to see if July is still targeted.  I'm trying to get this running on a Samsung Epic Touch 4G (Galaxy S2 on Sprint), and am getting the error

Please check your internet calling settings.  If the problem persists, please contact your system administrator.

I'm the administrator.

I've verified that the phone can connect to CUCM (TFTP is configured with IP address, so ruling out DNS issues).

Paul McGurn Mon, 08/20/2012 - 08:05

Installed the newest version on a Samsung Galaxy Nexus running Jelly Bean (Cyanogenmod 10 ROM).  It "works", but the in-call dial-pad is extremely flakey in regards to responding to keypresses.  Everything else appeared to work, but this was a deal-breaker. 

If any of the Cisco devs are monitoring this thread, note, you should be preventing install on devices you haven't either confirmed as successfuly working, or ones you know will not work (block by OS version).  As an Adnroid developer releasing to the market, it is absolutely possible for you to prevent the headaches we're going through by blocking the ability to install on kernel versions that you know will not work.

michael.pye Thu, 07/26/2012 - 06:54

We are building an integrated VXI, BYOD and UC offering, and need to test a number of Android devices in our labs, the first being an Asus Transformer TF101 running ICS 4.0.3. Can we get an early release of the Jabber for Android client to install and test ourselves. You cant download from Google Play

vnmathur Sat, 08/18/2012 - 10:32

Hi Ronak,

Is there any update? we are testing jabber for andriod integration inour corporate environmemt with the following 3 devices:

Samsung Galaxy SII - android 2.1.3

Samsung Galaxy SIII - android 4.0.3

HTC one X - android 4.0.3

Jabber works fine on the SII but will not work on any of the newer devices. We are trying to showcase the strengths of Cisco telephony, and the lack of jabber support on any device other than 3 old and near end-of-life devices is extremely frustrating!

samuel.suen Mon, 08/06/2012 - 03:33

Hi all,

I upgrade my Samsung Note into 4.0.4. The Jabber can eventually register into my CM8.0. And I can make voip call to other IP Phone via my Andriod Jabber. You can try on it. (FYI, I tested it under ICS 4.0, but it cannot work on Jabber). However, it seems Cisco does not officially support on ICS4.0. Any Cisco SE can tell us when it is officially support on ICS 4.0?

Samuel

adem_dp@yahoo.com Tue, 08/07/2012 - 19:19

Dear Samuel,

Thank you for your information, today I tried to upgrade my note and running well.

Ade

pieterjbotes Sun, 08/12/2012 - 00:28

I've noticed that with my Samsung Galaxy Note on 4.0.4 that when using my Jabber I do seem to have some sound issues afterwards... For instance after putting my phone into silent mode and taking it back out again, I would see the phone going into silent mode everytime I received a call after that. After eventually closing down Jabber and restarting it the problem went away.

Also my sound seems to go "softer" after using Jabber... When receiving a call it would not ring as loud as it should. Almost sounds like it rings via the earpiece and not the speaker.

Sent from Cisco Technical Support Android App

pauleversonCFH Tue, 08/14/2012 - 15:32

An update from my side for anyone who is intereseted.

Android 4.0.4 for the Samsung Galaxy S2 fixes the Jabber login issue.

I have tried a few things and can report its the kernel itself within the 4.0.4 update that fixes it (as I expected).

I have successfully got Android 4.0.3 working with Jabber by flashing the kernel from 4.0.4 onto the device.

Cheers,

pieterjbotes Sat, 08/18/2012 - 23:04

Hi Vivek

You need to be on kernel 4.0.4 for it to work. S3 in most countries already have 4.0.4 out. Not sure about S2.

Sent from Cisco Technical Support Android App

vnmathur Sun, 08/19/2012 - 09:43

Petrus,

I mis quoted the Kernel version - it is 4.0.4 on the HTC (see screen shot) and I still cannot get Jabber to work.

Any help is appreciated.

Thanks

pieterjbotes Sun, 08/19/2012 - 11:11

How does the setup on the CallManager look?

Sent from Cisco Technical Support Android App

pieterjbotes Sun, 08/19/2012 - 20:45

Also see that there is a new Jabber v9 out released 17/08/2012. You have to uninstall the old version before installing the new one. It does however not see it as an upgrade as it looks like they published it as a seperate app.

It supports a few more phones but not as much as I hoped for.

Sent from Cisco Technical Support Android App

vnmathur Mon, 08/20/2012 - 07:25

Petrus,

I installed the new 9.0.1 Jabber client and unfortunately still have the same issue......

Is it worth opening a TAC case for this issue?

jsteinberg Mon, 08/20/2012 - 08:00

My S3 also has the same error.   Hopefully Cisco updates the Jabber app to address this issue.

vnmathur Thu, 08/30/2012 - 07:09

So the Case with TAC came to nothing. Tehy finally came back with the list of the 3devices that they support and nothing more. Here's their response:

"This is a follow up to our conversation over the phone. I apologize for the inconvenience with regard to the compatibility of the Jabber for Android client. I hope that I have provided the support that you expected. Below is the link to the release notes which talks about the supported devices with Jabber for Android -

 http://www.cisco.com/en/US/partner/docs/voice_ip_comm/jabber/Android/8_6/Cisco_Jabber_Android_8_6_4_RN.html#wp46650 
 
 
"Requirements for users and devices
 
The following Android devices are supported:
 
*Samsung Galaxy S International (GT-I9000) with Android 2.2.1 or 2.3
 
*Samsung Galaxy Tab International (GT-P1000) with Android 2.2.1 or 2.3
 
*Samsung Galaxy S II (AT&T) with Android 2.3"

I will resolve this case now, but don't hesitate to contact GTC or contact me directly
  anytime if you have any further issues. Thanks again for all your time and patience.
It was a pleasure working with you."

It was more than a little disappointing to say the least!

pieterjbotes Tue, 09/18/2012 - 21:38

I see my Jabber Android updated last night.  Anyone maybe got an idea of what else was fixed except the what is said in the app section?

vnmathur Wed, 09/19/2012 - 07:52

The new update does not fix anything on the HTC One X or the Samsung S3. The support still applies to:

Samsung Galaxy Nexus running Android Version 4.0.4

Samsung Galaxy S II (AT&T) running Android Version 2.3

Samsung Galaxy S II SC-02C (NTT Docomo) running Android Version 2.3

Samsung Galaxy S i9000 (model number GT-I9000) running Android Version 2.3

Samsung Galaxy Ace (model number GT-S5830L) running Android Version 2.3

Samsung Galaxy Tab international version (model number GT-P1000) running Android Version 2.3

Given CISCO's responsiveness so far, I am giving up and concluding that this perhaps going the way of the CIUS tablets for CISCO.

From a corporate standpoint, I think we need to look for other options!

risilver Tue, 10/09/2012 - 13:13

Many many standards-based SIP apps out, and they can't make this work on vanilla android? Seems very strange. Very disappointing too.

wozzlegummich Thu, 08/08/2013 - 17:06

I cannot believe CISCO only supports a handful of Android handsets. Android now had 80% of the market vs IOS. We run over 400 android phones worldwide yet we can only connect a few of them which are nearing E.O.L.

Come on CISCO - lift your game.

Can any other client be used? Maybe Xabber?

arnaud@guenon.fr Tue, 08/20/2013 - 01:48

Hello,

I can't register on cucm with the last version of jabber 9.1.3

I've test a ES version of jabber it works with sony Xperia T on android 4.1.2.

I've downloaded this version here :

http://www.firewall.cx/downloads/cat_view/167-cisco-tools-a-applications.html

Cisco Jabber Client for Android 4.0.4 (ice cream sandwich) and 2.3 (gingerbread).

Release Date:

10 October 2012

Version:

9.0.1.1911

This  version has been released for users who are experiencing registration  problems with Cisco Jabber from Google Play Store. It contains a bug fix  that allows your Android phone to connect and register to CallManager  Express. 

Rob Wilson Mon, 11/25/2013 - 03:39

I have a 7" Android Tablet (Tesco Hudl for folks in the UK) that's running 4.2.2. With CUCM 8.6(2) and client version 9.1.4 I have the following issues:

  • No menu once the app is installed so no way to quit the app without forcing quit and no way to change settings without uninstalling!
  • Although it registered with CUCM there are no calls possible in either direction (monitored using wireshark and outgoing calls from the client start with a NOTIFY that is simply ignored)

I installed the Beta mentioned in Arnaud's reply above and that works perfectly (over 1 year old at the time of writing!)

If anyone technical at Cisco is reading this, can you possibly comment on the lack of support for Android tablets running 4.2.2 or later?

I tried version 9.1.4 of the client on a Nexus 7 running KitKat and that didn't even run without crashing. Very poor.

Actions

Login or Register to take actions

This Discussion

Posted April 3, 2012 at 12:20 AM
Stats:
Replies:28 Avg. Rating:5
Views:17047 Votes:1
Shares:1
Tags: No tags.
Categories: Jabber for Android
+

Discussions Leaderboard