Cisco Jabber for Windows - IM Address can't contain space?

Answered Question
Apr 20th, 2012

I've downloaded and been experimenting with the new Cisco Jabber for Windows 9.0.1 client.  While I really like the new UI, I haven't been able to get IM/Chat to work at all.  Voicemail and phone integration work fine.  I can search LDAP (AD) fine.  But when it comes to presence and IM, its a mess.  Specifically:

1. Adding new contact from LDAP either doesn't add at all, or disappears after restarting the client

2. While the contact list will show presence for individuals when I login, as soon as I attempt to send them an IM, they immediately change status to offline. 

3. Any attempt to send an IM results in "Message to User could not be sent"

After a good bit of testing (hours and hours), I realized that it might be the space in the IM address that was causing it, so I created two new users in Active Directory whose sAMAccountName did not include spaces, sync'd them to CUCM, enabled their CUP and CUPC features in Licenses, and logged in with Cisco Jabber.  Lo and behold, their presence information updates correctly, I can add and remove from each other's contact lists normaly, and I can IM each other with no problem at all. 

So it appears in this new version, user names can no longer contain spaces?  I can't imagine I'm alone in having sAMAccountNames in a format that contains spaces and then having it LDAP sync'd with CUCM?  Its worth noting it works fine in CUPC 8.5.5, I can IM everyone, presence works fine, etc.

Can somebody from Cisco please test this/confirm it/file a bug, whatever needs to happen, because its not listed as an open caveat on the release notes.  I would consider this a severe bug, I know the workaround will be "go back to CUPC 8.5.5" but that cannot be a long term solution.

Thanks

I have this problem too.
0 votes
Correct Answer by gmendivi about 1 year 9 months ago

Dear all,

I would like to close this discussion informing you that the fix for defect CSCtz76102 was integrated on Cisco Jabber for Windows version 9.0(2), which was released last 7th June 2012.

Thanks,

German

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Tommer Catlin Mon, 04/23/2012 - 08:31

On the flip side of the coin... why are you using a space in your samaccountname anyways?  Im not really sure why a space would be in there, but I would go ahead and run a script to remove this attribute in AD.    

bill.roland Mon, 04/23/2012 - 11:40

Hi Tommer, thanks for your reply. In my mind the discussion is not about why my user names do what they do. Its legal in Active Directory, it works with 100% of everything we've ever tried to do for the last 12 years.

The real issue to me is that it appears that XEP-0106: JID Escaping is the cure but may not be implemented. If Cisco doesn't want to implement the XEP, they need to at least give us an option somewhere of being able to manipulate the XMPP IM Address so we could use, say, the MailNickName AD attribute (which does not contain a space) to get the username part of the IM address.

Tommer Catlin Mon, 04/23/2012 - 14:27

I see what you are saying and I agree with you. THe XMPP XEP should at least support this.  My guess is that it was overlooked if it was working in 8.5 and now in 8.6 it is not working.   This may be something Cisco is prepping for with Presence 9.0 and it is a bug currently in 8.5.   My advice would be to escalate to your local Cisco SE and straight into the BU to see why the space is not supported or stopped working.

I heard in future releases that custom LDAP fields can be mapped in CUCM which I assume will roll into CUPS.

bill.roland Tue, 04/24/2012 - 20:24

Thanks Tommer, I'll go that route.  Just hoping to catch the eyes of any of Cisco's people who might troll the forums as well.

econstantinou Wed, 04/25/2012 - 03:28

Hi Bill,

   I am having the same problem -

2. While the contact list will show presence for individuals when I login, as soon as I attempt to send them an IM, they immediately change status to offline.

3. Any attempt to send an IM results in "Message to User could not be sent"

   When login the presence information for my contacts is ok, but if i try to IM then their status changed to offline.

   Did you mange to fix this?

   We are using userPrincipalName as username so I changed the UserAccountName attribute to support this via the jabber-config.xml file (multiforest AD).

thanks

bill.roland Wed, 04/25/2012 - 13:52

No, not yet.  It looks like Cisco has us between a rock and a hard place for now; they don't appear to have implemented the JID-Escaping XEP that would solve this on the client, and do not appear to allow us to manipulate the "IM Address" on the CUPS server either.  Until one of the two happens, or until anybody who has a space (or other "illegal" character in XMPP) changes their user names on the LDAP. 

econstantinou Thu, 04/26/2012 - 02:54

In my case all usernames have a “-“ between first name and last name. If this is not an illegal character then the problem is that we are using userPrincipalName for userid rather than sAMAccountName.

So, I believe we have to wait…

Thanks for the respond.

bill.roland Tue, 05/01/2012 - 12:49

I don't usually "bump" my own posts but I want to make sure it catches Cisco's eye. 

Craig.Behr@city... Sat, 05/12/2012 - 13:58

I will add an "us too" to the list. We have had a few users that have spaces in their name. Worked fine in CUPC and not working in Jabber.

Same symptoms as OP.

bill.roland Mon, 05/14/2012 - 19:33

German, thanks for opening a defect on this, much appreciated.

If I may ask, who decides the severity of the issue?  It seems to me a matter of perspective, as the workaround simply isn't one; I doubt many users are going to totally re-engineer their AD with new user names for this bug.  I don't think this is a show stopper critical bug, but I don't think its a minor one, either, especially if you (Cisco) want to really push Jabber, the fact is it has to be able to deal with such user names. 

Thanks again.

gmendivi Mon, 05/14/2012 - 05:20

Dear all,

Thanks for bringing up this issue to Cisco. We have opened a new defect to track this misbehavior:

CSCtz76102

Cisco Jabber for Windows should allow for a "space" in UID

Externally found minor (Sev4) bug: N-New

For the time being, the only available workaround is to not use spaces in the user ID.

Please be aware that it might take some time for this fix to be integrated.

Thanks,

German

Correct Answer
gmendivi Wed, 07/04/2012 - 01:33

Dear all,

I would like to close this discussion informing you that the fix for defect CSCtz76102 was integrated on Cisco Jabber for Windows version 9.0(2), which was released last 7th June 2012.

Thanks,

German

Actions

Login or Register to take actions

This Discussion

Posted April 20, 2012 at 11:55 AM
Stats:
Replies:13 Avg. Rating:5
Views:4201 Votes:0
Shares:0
Categories: Jabber for Windows
+

Related Content

Discussions Leaderboard